Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Rename - Refactor hotkey inserts registered trademark symbol
Rename - Refactor hotkey inserts registered trademark symbol [message #987714] Tue, 27 November 2012 17:27 Go to next message
Matt Burke is currently offline Matt BurkeFriend
Messages: 3
Registered: November 2012
Junior Member
Previously, using the ALT+COMMAND+R key combination after highlighting a variable name in a Java file would go into the rename refactor mode. Now, the key combination replaces the highlighted text with a registered trademark symbol. How can I get the key combination to go into the rename refactor mode instead of inserting the symbol?

The current file encoding is set to MacRoman, which is the default setting inherited from container. As far as I know, nothing here has changed.

I am using Eclipse Indigo (Build id: 20110615-0604) on Mac OS X 10.7.5. Eclipse IDE for Java EE Developers 1.4.0.20110615-0550 and FreeMarker IDE SDK 1.1.0.v201006011046R-H111-GA are installed. I don't think there are any non-standard plugins.

The only recent change I can remember making is installing PyDev last week. With the default PyDev installed, ALT+COMMAND+R opens a context menu in the lower right corner with 2 option: rename and set next symbol (this is in addition to replace the text with the symbol). I disabled the Set Next Symbol key binding in my preferences, restarted eclipse, and tried the key combo again. The text was still replaced by the symbol but the rename refactor mode was not entered did not open. I uninstalled PyDev, restarted eclipse, and tried the key combo again. The text was still replaced by the symbol.
Re: Rename - Refactor hotkey inserts registered trademark symbol [message #990973 is a reply to message #987714] Sat, 15 December 2012 21:47 Go to previous messageGo to next message
Shiri Dori-Hacohen is currently offline Shiri Dori-HacohenFriend
Messages: 1
Registered: December 2012
Junior Member
Any hints on this one? I'm also having the same issue. Like the OP and another person elsewhere on the web (I can't share the link since I have fewer than 5 messages, but it's on metafilter.com), PyDev seems to have somehow replaced my refactor-rename command with the pesky registered trademark sign.

Using Helios, Build ID 20100917-0705 and Mac OS X 10.6.8.
All three cases are on Eclipse for Mac and recently installed PyDev.

Neither changing Eclipse settings nor Mac-wide settings helps; when typing Cmd+Option+R the rename command is absent and the registered trademark appears instead ( ® ). At first the PyDev option for "Set Next Symbol" was appearing alongside rename in the context window (as described by the OP) at the same time as the ® appeared. But once I removed that shortcut, the context menu doesn't appear at all and only the ® appears.

Note that when anywhere outside of Eclipse, Cmd+Option+R does *not* bring up the trademark sign. Normally that's just Option+R.

Any help would be highly appreciated!
Re: Rename - Refactor hotkey inserts registered trademark symbol [message #997095 is a reply to message #987714] Thu, 03 January 2013 16:08 Go to previous messageGo to next message
Matt Burke is currently offline Matt BurkeFriend
Messages: 3
Registered: November 2012
Junior Member
I have opened [APSTUD-7664][] in PyDev's Jira. Hopefully, a developer will pick it up and find a solution.

I will update my [stackoverflow question][] about this same topic more than this thread. If a resolution is found, I will try to remember to update this thread.

(forum won't let me post full links. Prepend each URL with "HTTP:"
[APSTUD-7664]: //jira.appcelerator.org/browse/APSTUD-7664
[stackoverflow question]: //stackoverflow.com/questions/13750847/eclipse-rename-refactor-hotkey-inserts-registered-trademark-symbol
Re: Rename - Refactor hotkey inserts registered trademark symbol [message #1000495 is a reply to message #987714] Mon, 14 January 2013 22:12 Go to previous message
Matt Burke is currently offline Matt BurkeFriend
Messages: 3
Registered: November 2012
Junior Member
A [workaround][] has been posted by Ed Baskerville on stack overflow.

[workaround]: //stackoverflow.com/a/14264812/300900
Previous Topic:Trigger view refresh after preference import
Next Topic:Eclipse freezes after opening wsdl in design( gui ) mode on Arch Linux + Openbox
Goto Forum:
  


Current Time: Tue Dec 23 00:10:42 GMT 2014

Powered by FUDForum. Page generated in 0.01636 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software