Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Eclipse Problem(Error trying to debug my project)
Eclipse Problem [message #987498] Mon, 26 November 2012 21:18 Go to next message
Kevin Young is currently offline Kevin Young
Messages: 1
Registered: November 2012
Junior Member
Hello. I am new to java and I'm trying to make a script. It worked for my friend, but not me. When I try to run the script, it says this:

Usage: javaw [-options] class [args...]
(to execute a class)
or javaw [-options] -jar jarfile [args...]
(to execute a jar file)
where options include:
-d32 use a 32-bit data model if available
-d64 use a 64-bit data model if available
-client to select the "client" VM
-server to select the "server" VM
-hotspot is a synonym for the "client" VM [deprecated]
The default VM is client.

-cp <class search path of directories and zip/jar files>
-classpath <class search path of directories and zip/jar files>
A ; separated list of directories, JAR archives,
and ZIP archives to search for class files.
-D<name>=<value>
set a system property
-verbose[:class|gc|jni]
enable verbose output
-version print product version and exit
-version:<value>
require the specified version to run
-showversion print product version and continue
-jre-restrict-search | -no-jre-restrict-search
include/exclude user private JREs in the version search
-? -help print this help message
-X print help on non-standard options
-ea[:<packagename>...|:<classname>]
-enableassertions[:<packagename>...|:<classname>]
enable assertions with specified granularity
-da[:<packagename>...|:<classname>]
-disableassertions[:<packagename>...|:<classname>]
disable assertions with specified granularity
-esa | -enablesystemassertions
enable system assertions
-dsa | -disablesystemassertions
disable system assertions
-agentlib:<libname>[=<options>]
load native agent library <libname>, e.g. -agentlib:hprof
see also, -agentlib:jdwp=help and -agentlib:hprof=help
-agentpath:<pathname>[=<options>]
load native agent library by full pathname
-javaagent:<jarpath>[=<options>]
load Java programming language agent, see java.lang.instrument
-splash:<imagepath>
show splash screen with specified image
Read (deleted URL) for more details.

I thank whoever (tries to) helps me fix this.
Re: Eclipse Problem [message #987631 is a reply to message #987498] Tue, 27 November 2012 11:18 Go to previous message
Dani Megert is currently offline Dani Megert
Messages: 3801
Registered: July 2009
Senior Member
On 26.11.2012 22:44, Kevin Young wrote:
> Hello. I am new to java and I'm trying to make a script. It worked for
> my friend, but not me. When I try to run the script, it says this:

What's the relation to Eclipse?

Dani
>
> Usage: javaw [-options] class [args...]
> (to execute a class)
> or javaw [-options] -jar jarfile [args...]
> (to execute a jar file)
> where options include:
> -d32 use a 32-bit data model if available
> -d64 use a 64-bit data model if available
> -client to select the "client" VM
> -server to select the "server" VM
> -hotspot is a synonym for the "client" VM [deprecated]
> The default VM is client.
>
> -cp <class search path of directories and zip/jar files>
> -classpath <class search path of directories and zip/jar files>
> A ; separated list of directories, JAR archives,
> and ZIP archives to search for class files.
> -D<name>=<value>
> set a system property
> -verbose[:class|gc|jni]
> enable verbose output
> -version print product version and exit
> -version:<value>
> require the specified version to run
> -showversion print product version and continue
> -jre-restrict-search | -no-jre-restrict-search
> include/exclude user private JREs in the version search
> -? -help print this help message
> -X print help on non-standard options
> -ea[:<packagename>...|:<classname>]
> -enableassertions[:<packagename>...|:<classname>]
> enable assertions with specified granularity
> -da[:<packagename>...|:<classname>]
> -disableassertions[:<packagename>...|:<classname>]
> disable assertions with specified granularity
> -esa | -enablesystemassertions
> enable system assertions
> -dsa | -disablesystemassertions
> disable system assertions
> -agentlib:<libname>[=<options>]
> load native agent library <libname>, e.g.
> -agentlib:hprof
> see also, -agentlib:jdwp=help and -agentlib:hprof=help
> -agentpath:<pathname>[=<options>]
> load native agent library by full pathname
> -javaagent:<jarpath>[=<options>]
> load Java programming language agent, see
> java.lang.instrument
> -splash:<imagepath>
> show splash screen with specified image
> Read (deleted URL) for more details.
>
> I thank whoever (tries to) helps me fix this.
Previous Topic:Building projects programmatically and JRE_CONTAINER
Next Topic:Jars under Bundled Libraries folder not getting updated in Enterprise archive project
Goto Forum:
  


Current Time: Fri Sep 19 00:05:31 GMT 2014

Powered by FUDForum. Page generated in 0.03570 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software