Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP » DSDP/DSF
DSDP/DSF [message #13193] Wed, 09 January 2008 16:59 Go to next message
Eclipse User
Originally posted by: jesper.eskilson.iar.com

Hi all,

I'm trying to checkout the DSDP/DSF projects in order to study the
implementations, but I get loads of build errors; things like
"AbstractUIPlugin cannot be resolved".

> Severity and Description Path Resource Location Creation Time Id
> AbstractUIPlugin cannot be resolved org.eclipse.dd.dsf.mi.ui/src/org/eclipse/dd/dsf/mi/ui DsfMIUIPlugin.java line 75 1199895367690 674

I've got a couple of other plugins which work fine, so my Eclipse
installation is not totally broken.

Can anybody give a hint about where I should start looking?

--
/Jesper
Re: DSDP/DSF build problems [message #13223 is a reply to message #13193] Thu, 10 January 2008 16:32 Go to previous messageGo to next message
Martin Oberhuber is currently offline Martin Oberhuber
Messages: 983
Registered: July 2009
Senior Member
The classpath that PDE has for your DSF plugins has might be
broken. Try "PDE Tools > Update classpath". Clean all projects
(without rebuild), close project, reopen project might also
help. You do have a Java 1.5 runtime installed that Eclipse can use?
(Window > Preferences > Java > Installed JREs)

AbstractUIPlugin should definitely be found, so somehow your
PDE / Classpath seems to be broken. I've seen that before on other
plugins, but never quite found what's causing this or how to workaround
it exactly... after some time of trying it eventually worked again.

Also copying the dsdp.dd newsgroup and the dsdp-dd-dev list.

Cheers,
--
Martin Oberhuber, Senior Member of Technical Staff, Wind River
Target Management Project Lead, DSDP PMC Member
http://www.eclipse.org/dsdp/tm




Jesper Eskilson wrote:
> Hi all,
>
> I'm trying to checkout the DSDP/DSF projects in order to study the
> implementations, but I get loads of build errors; things like
> "AbstractUIPlugin cannot be resolved".
>
>> Severity and Description Path Resource Location Creation
>> Time Id
>> AbstractUIPlugin cannot be resolved
>> org.eclipse.dd.dsf.mi.ui/src/org/eclipse/dd/dsf/mi/ui
>> DsfMIUIPlugin.java line 75 1199895367690 674
>
> I've got a couple of other plugins which work fine, so my Eclipse
> installation is not totally broken.
>
> Can anybody give a hint about where I should start looking?
>
> --
> /Jesper
Re: DSDP/DSF build problems [message #13251 is a reply to message #13223] Thu, 10 January 2008 20:23 Go to previous messageGo to next message
Eclipse User
Originally posted by: jesper.eskilson.iar.com

Martin Oberhuber wrote:
> The classpath that PDE has for your DSF plugins has might be
> broken. Try "PDE Tools > Update classpath". Clean all projects
> (without rebuild), close project, reopen project might also
> help.

No effect.

> You do have a Java 1.5 runtime installed that Eclipse can use?
> (Window > Preferences > Java > Installed JREs)

Yes. Also, the problem appears on both my XP workstation and on my Vista
laptop.

> AbstractUIPlugin should definitely be found, so somehow your
> PDE / Classpath seems to be broken. I've seen that before on other
> plugins, but never quite found what's causing this or how to workaround
> it exactly... after some time of trying it eventually worked again.

Weird. Well, at the moment I'm just reading code. Lets hope by the time
I need to start hacking things will have fixed themselves. ;-)

--
/Jesper
Re: DSDP/DSF build problems [message #13278 is a reply to message #13251] Thu, 10 January 2008 21:32 Go to previous message
Pawel Piech is currently offline Pawel Piech
Messages: 9
Registered: July 2009
Junior Member
Hi Jesper,
One thing to keep in mind, DSF HEAD is now dependent on Eclipse 3.4 M4
and CDT 5.0 M4.
-Pawel

Jesper Eskilson wrote:
> Martin Oberhuber wrote:
>> The classpath that PDE has for your DSF plugins has might be
>> broken. Try "PDE Tools > Update classpath". Clean all projects
>> (without rebuild), close project, reopen project might also
>> help.
>
> No effect.
>
>> You do have a Java 1.5 runtime installed that Eclipse can use? (Window
>> > Preferences > Java > Installed JREs)
>
> Yes. Also, the problem appears on both my XP workstation and on my Vista
> laptop.
>
>> AbstractUIPlugin should definitely be found, so somehow your
>> PDE / Classpath seems to be broken. I've seen that before on other
>> plugins, but never quite found what's causing this or how to
>> workaround it exactly... after some time of trying it eventually
>> worked again.
>
> Weird. Well, at the moment I'm just reading code. Lets hope by the time
> I need to start hacking things will have fixed themselves. ;-)
>
> --
> /Jesper
Re: DSDP/DSF build problems [message #571604 is a reply to message #13193] Thu, 10 January 2008 16:32 Go to previous message
Martin Oberhuber is currently offline Martin Oberhuber
Messages: 983
Registered: July 2009
Senior Member
The classpath that PDE has for your DSF plugins has might be
broken. Try "PDE Tools > Update classpath". Clean all projects
(without rebuild), close project, reopen project might also
help. You do have a Java 1.5 runtime installed that Eclipse can use?
(Window > Preferences > Java > Installed JREs)

AbstractUIPlugin should definitely be found, so somehow your
PDE / Classpath seems to be broken. I've seen that before on other
plugins, but never quite found what's causing this or how to workaround
it exactly... after some time of trying it eventually worked again.

Also copying the dsdp.dd newsgroup and the dsdp-dd-dev list.

Cheers,
--
Martin Oberhuber, Senior Member of Technical Staff, Wind River
Target Management Project Lead, DSDP PMC Member
http://www.eclipse.org/dsdp/tm




Jesper Eskilson wrote:
> Hi all,
>
> I'm trying to checkout the DSDP/DSF projects in order to study the
> implementations, but I get loads of build errors; things like
> "AbstractUIPlugin cannot be resolved".
>
>> Severity and Description Path Resource Location Creation
>> Time Id
>> AbstractUIPlugin cannot be resolved
>> org.eclipse.dd.dsf.mi.ui/src/org/eclipse/dd/dsf/mi/ui
>> DsfMIUIPlugin.java line 75 1199895367690 674
>
> I've got a couple of other plugins which work fine, so my Eclipse
> installation is not totally broken.
>
> Can anybody give a hint about where I should start looking?
>
> --
> /Jesper
Re: DSDP/DSF build problems [message #571640 is a reply to message #13223] Thu, 10 January 2008 20:23 Go to previous message
Jesper Eskilson is currently offline Jesper Eskilson
Messages: 131
Registered: July 2009
Senior Member
Martin Oberhuber wrote:
> The classpath that PDE has for your DSF plugins has might be
> broken. Try "PDE Tools > Update classpath". Clean all projects
> (without rebuild), close project, reopen project might also
> help.

No effect.

> You do have a Java 1.5 runtime installed that Eclipse can use?
> (Window > Preferences > Java > Installed JREs)

Yes. Also, the problem appears on both my XP workstation and on my Vista
laptop.

> AbstractUIPlugin should definitely be found, so somehow your
> PDE / Classpath seems to be broken. I've seen that before on other
> plugins, but never quite found what's causing this or how to workaround
> it exactly... after some time of trying it eventually worked again.

Weird. Well, at the moment I'm just reading code. Lets hope by the time
I need to start hacking things will have fixed themselves. ;-)

--
/Jesper
Re: DSDP/DSF build problems [message #571661 is a reply to message #13251] Thu, 10 January 2008 21:32 Go to previous message
Pawel Piech is currently offline Pawel Piech
Messages: 9
Registered: July 2009
Junior Member
Hi Jesper,
One thing to keep in mind, DSF HEAD is now dependent on Eclipse 3.4 M4
and CDT 5.0 M4.
-Pawel

Jesper Eskilson wrote:
> Martin Oberhuber wrote:
>> The classpath that PDE has for your DSF plugins has might be
>> broken. Try "PDE Tools > Update classpath". Clean all projects
>> (without rebuild), close project, reopen project might also
>> help.
>
> No effect.
>
>> You do have a Java 1.5 runtime installed that Eclipse can use? (Window
>> > Preferences > Java > Installed JREs)
>
> Yes. Also, the problem appears on both my XP workstation and on my Vista
> laptop.
>
>> AbstractUIPlugin should definitely be found, so somehow your
>> PDE / Classpath seems to be broken. I've seen that before on other
>> plugins, but never quite found what's causing this or how to
>> workaround it exactly... after some time of trying it eventually
>> worked again.
>
> Weird. Well, at the moment I'm just reading code. Lets hope by the time
> I need to start hacking things will have fixed themselves. ;-)
>
> --
> /Jesper
Previous Topic:DSDP/DSF
Next Topic:Eclipse Plugin Fest
Goto Forum:
  


Current Time: Fri Sep 19 11:56:47 GMT 2014

Powered by FUDForum. Page generated in 0.03069 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software