Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » how to fix failed to load the jni(can somewone help me fix failed to load the jni shared library)
icon4.gif  how to fix failed to load the jni [message #986385] Tue, 20 November 2012 10:05 Go to next message
luc bleumer is currently offline luc bleumer
Messages: 1
Registered: November 2012
Junior Member
i tried to start eclips but than i get the error

failed to load the jni shared library''C:\program files (x86)\java\jre7\bin\client\jvm.dll''.

i have tried serveral fixes but all dint work
my eclipse.ini is like this

-startupplugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.librarypluginsorg.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20120522-1813-productorg.eclipse.epp.package.java.product--launcher.defaultActionopenFile--launcher.XXMaxPermSize256M-showsplashorg.eclipse.platform--launcher.XXMaxPermSize256m
--launcher.defaultActionopenFile-vmargs-Dosgi.requiredJavaVersion=1.5-Dhelp.lucene.tokenizer=standard-Xms40m-Xmx512m

and than i saw some forums and fixes and i changed it to this

-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20120522-1813
-product
org.eclipse.epp.package.java.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vm
C:\Program Files (x86)\Java\jre7\bin\client\jvm.dll
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Dhelp.lucene.tokenizer=standard
-Xms40m
-Xmx512m

but the C:\Program Files (x86)\Java\jre7\bin\client\jvm.dll
i have tried C:\Program Files (x86)\Java\jdk1.7.0\bin\javaw.exe
and al i have treid nothing works so please help me
(ps if you dont understand some thing i am dutch so thats why)
  • Attachment: Naamloos.png
    (Size: 153.17KB, Downloaded 165 times)
Re: how to fix failed to load the jni [message #986490 is a reply to message #986385] Tue, 20 November 2012 16:00 Go to previous message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2310
Registered: July 2009
Senior Member
You're trying to use a 64-bit Eclipse with a 32-bit JRE. They have to match.

---
Nitin Dahyabhai
Eclipse WTP, IBM
Previous Topic:Create Web Service - Java naming conventions
Next Topic:Update Site for org.eclipse.wst.ws_ui.feature
Goto Forum:
  


Current Time: Sun Oct 26 04:33:27 GMT 2014

Powered by FUDForum. Page generated in 0.09870 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software