Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP 2.0 tool issue
RAP 2.0 tool issue [message #986340] Tue, 20 November 2012 02:11 Go to next message
Avrajit Chatterjee is currently offline Avrajit Chatterjee
Messages: 63
Registered: September 2011
Member
Hi ,

I have Eclipse Juno(for RCP and RAP developers) and when I try to install Rap 2.0 M3 tool using update site http://download.eclipse.org/rt/rap/tools/2.0 I get the following error in Eclipse.


Cannot complete the install because of a conflicting dependency.
Software being installed: Rich Ajax Platform (RAP) Tools 2.0.0.20121109-1500 (org.eclipse.rap.tools.feature.feature.group 2.0.0.20121109-1500)
Software currently installed: Eclipse for RCP and RAP Developers 1.5.1.20120917-1257 (epp.package.rcp 1.5.1.20120917-1257)
Only one of the following can be installed at once:
RAP Templates Plug-in 1.5.0.20121106-1204 (org.eclipse.rap.ui.templates 1.5.0.20121106-1204)
RAP Templates Plug-in 1.5.0.20120613-1425 (org.eclipse.rap.ui.templates 1.5.0.20120613-1425)
RAP Templates Plug-in 1.5.1.20120917-1138 (org.eclipse.rap.ui.templates 1.5.1.20120917-1138)
Cannot satisfy dependency:
From: Eclipse for RCP and RAP Developers 1.5.1.20120917-1257 (epp.package.rcp 1.5.1.20120917-1257)
To: org.eclipse.epp.package.rcp.feature.feature.group [1.5.1.20120917-1257]
Cannot satisfy dependency:
From: EPP RCP/RAP Feature 1.5.1.20120917-1257 (org.eclipse.epp.package.rcp.feature.feature.group 1.5.1.20120917-1257)
To: org.eclipse.rap.tools.feature.group 0.0.0
Cannot satisfy dependency:
From: Rich Ajax Platform (RAP) Tools 2.0.0.20121109-1500 (org.eclipse.rap.tools.feature.feature.group 2.0.0.20121109-1500)
To: org.eclipse.rap.ui.templates [1.5.0.20121106-1204]
Cannot satisfy dependency:
From: Rich Ajax Platform (RAP) Tools 1.5.0.20120613-1425 (org.eclipse.rap.tools.feature.group 1.5.0.20120613-1425)
To: org.eclipse.rap.ui.templates [1.5.0.20120613-1425]
Cannot satisfy dependency:
From: Rich Ajax Platform (RAP) Tools 1.5.1.20120917-1138 (org.eclipse.rap.tools.feature.group 1.5.1.20120917-1138)
To: org.eclipse.rap.ui.templates [1.5.1.20120917-1138]
Re: RAP 2.0 tool issue [message #986345 is a reply to message #986340] Tue, 20 November 2012 02:53 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1794
Registered: July 2009
Senior Member
Hi,
this is a know issue with the "Eclipse for RCP and RAP developers"
package and the latest RAP 2.0 Tools. See:
391336: [Tools] Failed to install latest nigthly from the repo
https://bugs.eclipse.org/bugs/show_bug.cgi?id=391336
We didn't manage to fix it for M3, but definitely will be fixed in M4.
I'm sorry for the inconvenience.
Best,
Ivan

On 11/20/2012 9:11 AM, Avrajit Chatterjee wrote:
> Hi ,
>
> I have Eclipse Juno(for RCP and RAP developers) and when I try to
> install Rap 2.0 M3 tool using update site
> http://download.eclipse.org/rt/rap/tools/2.0 I get the following error
> in Eclipse.
>
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Rich Ajax Platform (RAP) Tools
> 2.0.0.20121109-1500 (org.eclipse.rap.tools.feature.feature.group
> 2.0.0.20121109-1500)
> Software currently installed: Eclipse for RCP and RAP Developers
> 1.5.1.20120917-1257 (epp.package.rcp 1.5.1.20120917-1257)
> Only one of the following can be installed at once: RAP Templates
> Plug-in 1.5.0.20121106-1204 (org.eclipse.rap.ui.templates
> 1.5.0.20121106-1204)
> RAP Templates Plug-in 1.5.0.20120613-1425
> (org.eclipse.rap.ui.templates 1.5.0.20120613-1425)
> RAP Templates Plug-in 1.5.1.20120917-1138
> (org.eclipse.rap.ui.templates 1.5.1.20120917-1138)
> Cannot satisfy dependency:
> From: Eclipse for RCP and RAP Developers 1.5.1.20120917-1257
> (epp.package.rcp 1.5.1.20120917-1257)
> To: org.eclipse.epp.package.rcp.feature.feature.group
> [1.5.1.20120917-1257]
> Cannot satisfy dependency:
> From: EPP RCP/RAP Feature 1.5.1.20120917-1257
> (org.eclipse.epp.package.rcp.feature.feature.group 1.5.1.20120917-1257)
> To: org.eclipse.rap.tools.feature.group 0.0.0
> Cannot satisfy dependency:
> From: Rich Ajax Platform (RAP) Tools 2.0.0.20121109-1500
> (org.eclipse.rap.tools.feature.feature.group 2.0.0.20121109-1500)
> To: org.eclipse.rap.ui.templates [1.5.0.20121106-1204]
> Cannot satisfy dependency:
> From: Rich Ajax Platform (RAP) Tools 1.5.0.20120613-1425
> (org.eclipse.rap.tools.feature.group 1.5.0.20120613-1425)
> To: org.eclipse.rap.ui.templates [1.5.0.20120613-1425]
> Cannot satisfy dependency:
> From: Rich Ajax Platform (RAP) Tools 1.5.1.20120917-1138
> (org.eclipse.rap.tools.feature.group 1.5.1.20120917-1138)
> To: org.eclipse.rap.ui.templates [1.5.1.20120917-1138]

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: RAP 2.0 tool issue [message #986355 is a reply to message #986345] Tue, 20 November 2012 03:34 Go to previous messageGo to next message
Avrajit Chatterjee is currently offline Avrajit Chatterjee
Messages: 63
Registered: September 2011
Member
Thanks Ivan, I checkout some workarounds for these kind of issues but didnt want to spent any time to fix it by updating feature.xml and context.xml etc.
Instead I got Eclipse Classic Juno and installed RAP 2.0 M3 tool and its working for me.
Re: RAP 2.0 tool issue [message #989511 is a reply to message #986355] Thu, 06 December 2012 09:44 Go to previous messageGo to next message
Markus Knauer is currently offline Markus Knauer
Messages: 106
Registered: July 2009
Senior Member

While I am trying to implement a solution for this problem, I tested different scenarios.

If you are starting with any EPP package that does *not* contain the RAP Tools, e.g. the Classic/SDK packages

eclipse-rcp-juno-SR1-linux-gtk-x86_64.tar.gz
eclipse-rcp-kepler-M3-linux-gtk-x86_64.tar.gz

you should be able to install RAP Tools 2.0 from http://download.eclipse.org/rt/rap/tools/2.0/ without any problems.
The Kepler M3 RCP/RAP package (eclipse-rcp-kepler-M3-linux-gtk-x86_64.tar.gz) from http://www.eclipse.org/downloads/index-developer.php already contains the RAP Tools 2.0 M3 and can be upgraded safely to the latest and greatest RAP nightly build.

The only package that does not work with RAP Tools 2.0 M3 is the Juno RCP/RAP package (and every package that had RAP Tools 1.5 installed manually). In this case you will run into dependency errors caused by singletons. Moreover you will run into additional problems if you try to install the latest nightly build. It *is* possible to install the new RAP Tools nightly builds into the Juno RCP/RAP package, but you will end up with a cluttered UI and even more problems. Be warned!



--
Markus Knauer

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: RAP 2.0 tool issue [message #989969 is a reply to message #989511] Mon, 10 December 2012 05:11 Go to previous message
Markus Knauer is currently offline Markus Knauer
Messages: 106
Registered: July 2009
Senior Member

This should be solved now with the latest nightly builds of the RAP Tools.
You can test it with the nightly build p2 repository at http://download.eclipse.org/rt/rap/nightly/tooling/.

Further information about the solution can be found in Bugzilla: https://bugs.eclipse.org/bugs/show_bug.cgi?id=391336

Thanks,
Markus


--
Markus Knauer

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:TableColumn and Table Fonts
Next Topic: JFace TableViewer/Table setitemcount() slow
Goto Forum:
  


Current Time: Fri Aug 22 11:58:38 EDT 2014

Powered by FUDForum. Page generated in 0.02436 seconds