Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Java7 Compatibility with Eclipse(Eclipse won't run with Java7)
Java7 Compatibility with Eclipse [message #986063] Sun, 18 November 2012 02:54 Go to next message
Kevin Lennox is currently offline Kevin Lennox
Messages: 1
Registered: November 2012
Junior Member
I recently started an Android programming course and downloaded Java Development Kit version 7 and ADT bundle for Windows (which has Eclipse bundled with it) and installed both. Eclipse would not run (see attached image) as it said that it was incompatible with my version of Windows (which is Windows 7 Home Premium).

I checked my course notes and it said "DO NOT USE the Java Development Kit version 7 as it is not fully compatible with current versions of Eclipse" and to use Version 6 Update 27 instead.

I have tried uninstalling Version 7 and installing 6 but Java installer still thinks a newer version is in existence. I try running Eclipse and it still won't run.

Any ideas?

index.php/fa/12430/0/
  • Attachment: Capture.PNG
    (Size: 30.07KB, Downloaded 386 times)
Re: Java7 Compatibility with Eclipse [message #986106 is a reply to message #986063] Sun, 18 November 2012 22:41 Go to previous message
Russell Bateman is currently offline Russell Bateman
Messages: 3219
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 11/17/2012 09:23 PM, Kevin Lennox wrote:
> I recently started an Android programming course and downloaded Java Development Kit version 7 and ADT bundle for Windows (which has Eclipse bundled with it) and installed both. Eclipse would not run (see attached image) as it said that it was incompatible with my version of Windows (which is Windows 7 Home Premium).
>
> I checked my course notes and it said "DO NOT USE the Java Development Kit version 7 as it is not fully compatible with current versions of Eclipse" and to use Version 6 Update 27 instead.
>
> I have tried uninstalling Version 7 and installing 6 but Java installer still thinks a newer version is in existence. I try running Eclipse and it still won't run.
>
> Any ideas?

First, this isn't an Android programming forum.

Second, you don't need to uninstall JDK 7, just install a copy of JDK 6,
wire it up to Eclipse and you can get back to work. If you are mystified
by this answer, please read the first couple of articles in this
summary: http://www.javahotchocolate.com/tutorials/eclipse-summary.html .
Previous Topic:Updates and plugin installs are impossible
Next Topic:Recent and Open Projects feature in Eclipse IDE
Goto Forum:
  


Current Time: Tue Oct 21 07:05:51 GMT 2014

Powered by FUDForum. Page generated in 0.01677 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software