Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Profiling Web Application on JBOSS Attaching an Agent
Profiling Web Application on JBOSS Attaching an Agent [message #142915] Mon, 29 June 2009 10:50 Go to next message
surbhigl is currently offline surbhiglFriend
Messages: 13
Registered: July 2009
Junior Member
Hi,

I am trying to profile a web application deployed on JBOSS 3.2.7 launching
server associating profiling agent and then attaching the agent. But i am
unable to get any profiling data Profiling and logging perspective when
opening with Execution Statistics in JBOSS. Here is my configuration
settings:

Eclipse 3.3.2
JRE 1.6
TPTP 4.4.1.
JBOSS 3.2.7

I have configured all the required plugins TPTP-WTP integration with
eclipse that
includes
# EMF and XSD 2.3.2
# Eclipse Web Tools Platform (WTP) 2.0.2
# Graphics Editor Framework (GEF) 3.3.2
# Data Tools Platform (DTP) 1.5.2

I have added following arguments in the run script of JBOSS
set JAVA_OPTS=-agentlib:JPIBootLoader=JPIAgent:server=enabled;CG Prof
%JAVA_OPTS%

Running jboss server after starting RAServer starts successfully and i get
agents to attach in the list as:
JRE 1.5 or newer with execution time analysis.
I am selecting them and setting filter as
com.one.administration.struts.action* INCLUDE
* EXCLUDE

I have also set env variables
MARTINI_LOGGER_DIRECTORY =
C:\downloads\agntctrl.win_ia32-TPTP-4.4.1\plugins\org.eclips e.tptp.javaprofiler\log
MARTINI_LOGGER_LOG_LEVEL = 5
TPTP_OUTPUT_FORMAT = xml

But I am not able to get any log file. Also the file created when
selecting option to send profile data in a file is not in xml format but
is in binary format. Binary file created has some data and is around 4 KB.

I installed All TPTP plugins version 4.4.1 in Eclipse.
And I using agntctrl.win_ia32-TPTP-4.4.1 (installed separately)for
launching the agent. May this can cause the problem?

Please help I have been trying this since a long time now.
Re: Profiling Web Application on JBOSS Attaching an Agent [message #142926 is a reply to message #142915] Mon, 29 June 2009 10:55 Go to previous messageGo to next message
surbhigl is currently offline surbhiglFriend
Messages: 13
Registered: July 2009
Junior Member
in addition to the previous post:

Here is the serverlog.log

<CommonBaseEvent creationTime="2009-06-29T10:14:15.198000Z"
globalInstanceId="A068F2366EC445D99AD5B8700F2FD9CD" msg="Received command
for unrecognized interface: iid=org.eclipse.tptp.eventProvider,
cmd=listenerAccepted" severity="50" version="1.0.1">
<sourceComponentId component="AgentController"
componentIdType="TPTPComponent"
executionEnvironment=" D:\cygwin\home\build\TPTP\4.4.1\TPTP-4.4.1-200802230953\agnt ctrl\src\transport\TPTPClientCompTL\Connect2AC.c,
line 2238" instanceId="1004" location="D-19187.synapse.com"
locationType="IPV4" processId="5068" subComponent="Client Compatibility
TL" threadId="3392" componentType="Eclipse_TPTP"/>
<situation categoryName="ReportSituation">
<situationType xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:type="ReportSituation" reasoningScope="INTERNAL" reportCategory="LOG"/>
</situation>
</CommonBaseEvent>
<CommonBaseEvent creationTime="2009-06-29T10:14:16.010000Z"
globalInstanceId="AB20B77AD92A494C89F20314FA5879E4" msg="File server
started listening on port 10005" severity="10" version="1.0.1">
<sourceComponentId component="AgentController"
componentIdType="TPTPComponent"
executionEnvironment=" D:\cygwin\home\build\TPTP\4.4.1\TPTP-4.4.1-200802230953\agnt ctrl\src\transport\TPTPClientCompTL\fileServer.c,
line 177" instanceId="1004" location="D-19187.synapse.com"
locationType="IPV4" processId="5068" subComponent="Client Compatibility
TL" threadId="5724" componentType="Eclipse_TPTP"/>
<situation categoryName="ReportSituation">
<situationType xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:type="ReportSituation" reasoningScope="INTERNAL" reportCategory="LOG"/>
</situation>
</CommonBaseEvent>
<CommonBaseEvent creationTime="2009-06-29T10:24:16.303000Z"
globalInstanceId="A748FF3B793648329855F52FDCFD88E2" msg="A
processExitedEvent was received for which we have no corresponding agent."
severity="30" version="1.0.1">
<sourceComponentId component="AgentController"
componentIdType="TPTPComponent"
executionEnvironment=" D:\cygwin\home\build\TPTP\4.4.1\TPTP-4.4.1-200802230953\agnt ctrl\src\agentController\AgentManager.c,
line 3006" instanceId="1" location="D-19187.synapse.com"
locationType="IPV4" processId="5068" subComponent="Agent Manager"
threadId="4892" componentType="Eclipse_TPTP"/>
<situation categoryName="ReportSituation">
<situationType xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:type="ReportSituation" reasoningScope="INTERNAL" reportCategory="LOG"/>
</situation>
</CommonBaseEvent>
<CommonBaseEvent creationTime="2009-06-29T10:24:16.303000Z"
globalInstanceId="A6F932D7D3644704A24FE7F8D0EAE004" msg="A
processExitedEvent was received for which we have no corresponding agent."
severity="30" version="1.0.1">
<sourceComponentId component="AgentController"
componentIdType="TPTPComponent"
executionEnvironment=" D:\cygwin\home\build\TPTP\4.4.1\TPTP-4.4.1-200802230953\agnt ctrl\src\agentController\AgentManager.c,
line 3006" instanceId="1" location="D-19187.synapse.com"
locationType="IPV4" processId="5068" subComponent="Agent Manager"
threadId="4892" componentType="Eclipse_TPTP"/>
<situation categoryName="ReportSituation">
<situationType xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:type="ReportSituation" reasoningScope="INTERNAL" reportCategory="LOG"/>
</situation>
</CommonBaseEvent>
<CommonBaseEvent creationTime="2009-06-29T10:24:16.303000Z"
globalInstanceId="AF82444B415647849C91EA81C1A9DD7E" msg="A
processExitedEvent was received for which we have no corresponding agent."
severity="30" version="1.0.1">
<sourceComponentId component="AgentController"
componentIdType="TPTPComponent"
executionEnvironment=" D:\cygwin\home\build\TPTP\4.4.1\TPTP-4.4.1-200802230953\agnt ctrl\src\agentController\AgentManager.c,
line 3006" instanceId="1" location="D-19187.synapse.com"
locationType="IPV4" processId="5068" subComponent="Agent Manager"
threadId="4892" componentType="Eclipse_TPTP"/>
<situation categoryName="ReportSituation">
<situationType xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:type="ReportSituation" reasoningScope="INTERNAL" reportCategory="LOG"/>
</situation>
</CommonBaseEvent>
<CommonBaseEvent creationTime="2009-06-29T10:24:16.163000Z"
globalInstanceId="ADD32AE53CCD4C9DB13D11FA818DDC63" msg="PC
handleProcessEvents: Process has exited with status 0." severity="50"
version="1.0.1">
<sourceComponentId component="ProcessController"
componentIdType="TPTPComponent" componentType="Eclipse_TPTP"
executionEnvironment=" D:\cygwin\home\build\TPTP\4.4.1\TPTP-4.4.1-200802230953\agnt ctrl\src\agents\tptpProcessController\ProcessController_md.c pp,
line 284" instanceId="101" location="D-19187.synapse.com"
locationType="IPV4" processId="4284" subComponent="ProcessController"
threadId="4360"/>
<situation categoryName="ReportSituation">
<situationType reasoningScope="INTERNAL" reportCategory="LOG"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:type="ReportSituation"/>
</situation>
</CommonBaseEvent>


Also after getting the list of agent to attach for the first time starting
the jboss server and launching the monitor, when i come again in the
profile configuration option to attach an agent, i don't get agents and it
says

Error retrieving agents - see log for more details.
Re: Profiling Web Application on JBOSS Attaching an Agent [message #142976 is a reply to message #142926] Tue, 30 June 2009 21:13 Go to previous messageGo to next message
Eugene Chan is currently offline Eugene ChanFriend
Messages: 287
Registered: July 2009
Senior Member
Hi Surbhigl,

If you choose the option to 'Profile to File', the profiling file created on
your file system that contains all the trace data is in bindary format and
can be import back into the TPTP workbench via the 'File>Import>Profile
File' options, make sure you select the right type of data in the import
dialog for import.
On the other hand, if you choose not to profile to file, all live trace data
will be sent to the workbench and viewable in the profiling views in the
Profiling and Logging perspective.

Eugene


"surbhigl " <surbhi.mittal@globallogic.com> wrote in message
news:e2d072503df161207409876906a8304e$1@www.eclipse.org...
> in addition to the previous post:
>
> Here is the serverlog.log
>
> <CommonBaseEvent creationTime="2009-06-29T10:14:15.198000Z"
> globalInstanceId="A068F2366EC445D99AD5B8700F2FD9CD" msg="Received command
> for unrecognized interface: iid=org.eclipse.tptp.eventProvider,
> cmd=listenerAccepted" severity="50" version="1.0.1">
> <sourceComponentId component="AgentController"
> componentIdType="TPTPComponent"
> executionEnvironment=" D:\cygwin\home\build\TPTP\4.4.1\TPTP-4.4.1-200802230953\agnt ctrl\src\transport\TPTPClientCompTL\Connect2AC.c,
> line 2238" instanceId="1004" location="D-19187.synapse.com"
> locationType="IPV4" processId="5068" subComponent="Client Compatibility
> TL" threadId="3392" componentType="Eclipse_TPTP"/>
> <situation categoryName="ReportSituation">
> <situationType xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:type="ReportSituation" reasoningScope="INTERNAL"
> reportCategory="LOG"/>
> </situation>
> </CommonBaseEvent>
> <CommonBaseEvent creationTime="2009-06-29T10:14:16.010000Z"
> globalInstanceId="AB20B77AD92A494C89F20314FA5879E4" msg="File server
> started listening on port 10005" severity="10" version="1.0.1">
> <sourceComponentId component="AgentController"
> componentIdType="TPTPComponent"
> executionEnvironment=" D:\cygwin\home\build\TPTP\4.4.1\TPTP-4.4.1-200802230953\agnt ctrl\src\transport\TPTPClientCompTL\fileServer.c,
> line 177" instanceId="1004" location="D-19187.synapse.com"
> locationType="IPV4" processId="5068" subComponent="Client Compatibility
> TL" threadId="5724" componentType="Eclipse_TPTP"/>
> <situation categoryName="ReportSituation">
> <situationType xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:type="ReportSituation" reasoningScope="INTERNAL"
> reportCategory="LOG"/>
> </situation>
> </CommonBaseEvent>
> <CommonBaseEvent creationTime="2009-06-29T10:24:16.303000Z"
> globalInstanceId="A748FF3B793648329855F52FDCFD88E2" msg="A
> processExitedEvent was received for which we have no corresponding agent."
> severity="30" version="1.0.1">
> <sourceComponentId component="AgentController"
> componentIdType="TPTPComponent"
> executionEnvironment=" D:\cygwin\home\build\TPTP\4.4.1\TPTP-4.4.1-200802230953\agnt ctrl\src\agentController\AgentManager.c,
> line 3006" instanceId="1" location="D-19187.synapse.com"
> locationType="IPV4" processId="5068" subComponent="Agent Manager"
> threadId="4892" componentType="Eclipse_TPTP"/>
> <situation categoryName="ReportSituation">
> <situationType xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:type="ReportSituation" reasoningScope="INTERNAL"
> reportCategory="LOG"/>
> </situation>
> </CommonBaseEvent>
> <CommonBaseEvent creationTime="2009-06-29T10:24:16.303000Z"
> globalInstanceId="A6F932D7D3644704A24FE7F8D0EAE004" msg="A
> processExitedEvent was received for which we have no corresponding agent."
> severity="30" version="1.0.1">
> <sourceComponentId component="AgentController"
> componentIdType="TPTPComponent"
> executionEnvironment=" D:\cygwin\home\build\TPTP\4.4.1\TPTP-4.4.1-200802230953\agnt ctrl\src\agentController\AgentManager.c,
> line 3006" instanceId="1" location="D-19187.synapse.com"
> locationType="IPV4" processId="5068" subComponent="Agent Manager"
> threadId="4892" componentType="Eclipse_TPTP"/>
> <situation categoryName="ReportSituation">
> <situationType xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:type="ReportSituation" reasoningScope="INTERNAL"
> reportCategory="LOG"/>
> </situation>
> </CommonBaseEvent>
> <CommonBaseEvent creationTime="2009-06-29T10:24:16.303000Z"
> globalInstanceId="AF82444B415647849C91EA81C1A9DD7E" msg="A
> processExitedEvent was received for which we have no corresponding agent."
> severity="30" version="1.0.1">
> <sourceComponentId component="AgentController"
> componentIdType="TPTPComponent"
> executionEnvironment=" D:\cygwin\home\build\TPTP\4.4.1\TPTP-4.4.1-200802230953\agnt ctrl\src\agentController\AgentManager.c,
> line 3006" instanceId="1" location="D-19187.synapse.com"
> locationType="IPV4" processId="5068" subComponent="Agent Manager"
> threadId="4892" componentType="Eclipse_TPTP"/>
> <situation categoryName="ReportSituation">
> <situationType xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:type="ReportSituation" reasoningScope="INTERNAL"
> reportCategory="LOG"/>
> </situation>
> </CommonBaseEvent>
> <CommonBaseEvent creationTime="2009-06-29T10:24:16.163000Z"
> globalInstanceId="ADD32AE53CCD4C9DB13D11FA818DDC63" msg="PC
> handleProcessEvents: Process has exited with status 0." severity="50"
> version="1.0.1">
> <sourceComponentId component="ProcessController"
> componentIdType="TPTPComponent" componentType="Eclipse_TPTP"
> executionEnvironment=" D:\cygwin\home\build\TPTP\4.4.1\TPTP-4.4.1-200802230953\agnt ctrl\src\agents\tptpProcessController\ProcessController_md.c pp,
> line 284" instanceId="101" location="D-19187.synapse.com"
> locationType="IPV4" processId="4284" subComponent="ProcessController"
> threadId="4360"/>
> <situation categoryName="ReportSituation">
> <situationType reasoningScope="INTERNAL" reportCategory="LOG"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:type="ReportSituation"/>
> </situation>
> </CommonBaseEvent>
>
>
> Also after getting the list of agent to attach for the first time starting
> the jboss server and launching the monitor, when i come again in the
> profile configuration option to attach an agent, i don't get agents and it
> says
> Error retrieving agents - see log for more details.
>
>
>
>
Re: Profiling Web Application on JBOSS Attaching an Agent [message #143009 is a reply to message #142976] Wed, 01 July 2009 11:18 Go to previous messageGo to next message
surbhigl is currently offline surbhiglFriend
Messages: 13
Registered: July 2009
Junior Member
Hi Eugene,

If I choose not to profile to file, I am not able to get and see data in
the workbench in profiling views in the Profiling and Logging perspective.

If I choose the option to 'Profile to File', and i import the profiling
file created on my file system into the TPTP workbench via the
'File>Import>Profile
File' options, choosing Profiling File option and selecting the created
*.trcxml file IWAT0279E File Import Exception.

I think there is some issue in collecting the profile data.
Re: Profiling Web Application on JBOSS Attaching an Agent [message #143039 is a reply to message #143009] Fri, 03 July 2009 16:54 Go to previous messageGo to next message
Eugene Chan is currently offline Eugene ChanFriend
Messages: 287
Registered: July 2009
Senior Member
Hi Surbhigl,

Is your profiling session that generated the profiling file finished before
importing the profile file?
Does your filter setting filter out data of application under profiled? eg.
your package naming is already filtered out by the default filter.

Eugene

"surbhigl " <surbhi.mittal@globallogic.com> wrote in message
news:b89dba8c9a5a3c0f0302819b5793b80f$1@www.eclipse.org...
> Hi Eugene,
>
> If I choose not to profile to file, I am not able to get and see data in
> the workbench in profiling views in the Profiling and Logging perspective.
>
> If I choose the option to 'Profile to File', and i import the profiling
> file created on my file system into the TPTP workbench via the
> 'File>Import>Profile
> File' options, choosing Profiling File option and selecting the created
> *.trcxml file IWAT0279E File Import Exception.
> I think there is some issue in collecting the profile data.
>
>
Re: Profiling Web Application on JBOSS Attaching an Agent [message #143049 is a reply to message #143009] Mon, 06 July 2009 08:59 Go to previous messageGo to next message
surbhigl is currently offline surbhiglFriend
Messages: 13
Registered: July 2009
Junior Member
Hi Eugene,

I imported the file after my profiling session was terminated and i also
checked filter setting. I have included the package which I want to
profile and excluded the rest.

As i have mentioned in the previous posts -

I am selecting them and setting filter as
com.one.administration.struts.action* INCLUDE * EXCLUDE

Another thing can you help in getting the logs so that I can get some idea
about whats the problem. I have mentioned in the previous posts that

I have also set env variables MARTINI_LOGGER_DIRECTORY =
C:\downloads\agntctrl.win_ia32-TPTP-4.4.1\plugins\org.eclips e.tptp.javaprofiler\log
MARTINI_LOGGER_LOG_LEVEL = 5

But I am not able to get any log file.

Thanks,
Re: Profiling Web Application on JBOSS Attaching an Agent [message #143059 is a reply to message #143049] Mon, 06 July 2009 14:37 Go to previous messageGo to next message
Eugene Chan is currently offline Eugene ChanFriend
Messages: 287
Registered: July 2009
Senior Member
I see you have the right variables setup already.

How about profiling a more simple HelloWorld type of application? Do you get
any data?

Eugene



"surbhigl " <surbhi.mittal@globallogic.com> wrote in message
news:e5b9749f0211b972b1ec918e0b6a9a26$1@www.eclipse.org...
> Hi Eugene,
>
> I imported the file after my profiling session was terminated and i also
> checked filter setting. I have included the package which I want to
> profile and excluded the rest.
>
> As i have mentioned in the previous posts -
> I am selecting them and setting filter as
> com.one.administration.struts.action* INCLUDE * EXCLUDE
>
> Another thing can you help in getting the logs so that I can get some idea
> about whats the problem. I have mentioned in the previous posts that
> I have also set env variables MARTINI_LOGGER_DIRECTORY =
> C:\downloads\agntctrl.win_ia32-TPTP-4.4.1\plugins\org.eclips e.tptp.javaprofiler\log
> MARTINI_LOGGER_LOG_LEVEL = 5
>
> But I am not able to get any log file.
>
> Thanks,
>
Re: Profiling Web Application on JBOSS Attaching an Agent [message #143067 is a reply to message #143059] Thu, 09 July 2009 09:12 Go to previous messageGo to next message
surbhigl is currently offline surbhiglFriend
Messages: 13
Registered: July 2009
Junior Member
Hi,

I have again tried launching the agent controller along with jboss and
attaching the agent from the eclipse.

This time it worked little further and started generating the log. I made
changes in the environment variables and altered path environment variable
to add absolute paths instead of using their created Home environment
variables.
Secondly, in the eclipse when i go to Profile dialog -> Attach An Agent, I
have added another host i.e. localhost:10006. There was an entry
localhost:10002. This was for IAC so I think the problem was this.

After making all these changes, and using filter setting for my packages,
it appears it starts to profile but with no success.

Here is the trace from Mlog containing error :

Informative 07/09/09 08:55:25 1588 3 CClassRedefThread Received request to
to redefine 157 classes. isBlocking = 1

Informative 07/09/09 08:55:33 4876 3 CGAdaptor Class
com/one/administration/degreearea/delegate/DegreeAreaCnstDel egate was not
instrumented because all its methods were excluded
Informative 07/09/09 08:55:33 4876 3 CGAdaptor Class
com/one/memberships/creditcard/delegate/CreditCardDelegate was not
instrumented because all its methods were excluded
Informative 07/09/09 08:55:37 2744 3 CGAdaptor Class
com/one/csf/struts/form/SourceCodeForm was not instrumented because all
its methods were excluded
Informative 07/09/09 08:55:37 2744 0 CDataManager Class
'com/one/csf/struts/form/SourceCodeForm' has wrong instrumentation, but
will not be redefined due to user-defined filters or an internal reason
Informative 07/09/09 08:55:37 2744 3 CGAdaptor Class
com/one/csf/struts/action/SourceCodeAction was not instrumented because
all its methods were excluded
Informative 07/09/09 08:55:37 2744 3 CGAdaptor Class
com/one/csf/struts/action/SourceCodeAction was not instrumented because
all its methods were excluded
Informative 07/09/09 08:55:37 2744 0 CDataManager Class
'com/one/csf/struts/action/SourceCodeAction' has wrong instrumentation,
but will not be redefined due to user-defined filters or an internal reason
Informative 07/09/09 08:55:37 2744 3 CGAdaptor Class
com/one/csf/audittrail/AuditTrail was not instrumented because all its
methods were excluded
Informative 07/09/09 08:55:37 2744 3 CGAdaptor Class
com/one/csf/audittrail/AuditTrailException was not instrumented because
all its methods were excluded
Informative 07/09/09 08:55:40 4876 0 CJVMTIInterface RedefineClasses:
failed to redefine 1 classes. JVMTI Error: 110

Error 07/09/09 08:55:40 4876 0 CJavaInstrumentorManager RedefineClasses
failed. Instrumented classes may be in inconsistent state

And Jboss shutdown with the following errors:
[Error: EC JPIAgent received message (FATAL ERROR): Internal error (see
log file).]

Thanks,
Re: Profiling Web Application on JBOSS Attaching an Agent [message #143085 is a reply to message #143059] Thu, 09 July 2009 10:27 Go to previous messageGo to next message
surbhigl is currently offline surbhiglFriend
Messages: 13
Registered: July 2009
Junior Member
Hi,

I also tried running the profiler, changing the filter settings. In some
instances i got the following traces in the log.

Informative 07/09/09 09:52:43 2064 3 CClassRedefThread Received request to
to redefine 6 classes. isBlocking = 1

Informative 07/09/09 09:52:43 3572 3 CJavaInstrumentorManager [ClassRedefThreadProc]
6 classes successfully redefined

...................

Informative 07/09/09 09:53:17 1184 3 CJVMTIInterface [GetLineNumberTable]
user-supplied buffer is too short. table size = 5, buffer size = 1, buffer
actual size = 5)
Informative 07/09/09 09:53:17 1184 3 CJVMTIInterface [GetLineNumberTable]
user-supplied buffer is too short. table size = 2, buffer size = 1, buffer
actual size = 2)
Informative 07/09/09 09:53:17 1184 3 CJVMTIInterface [GetLineNumberTable]
user-supplied buffer is too short. table size = 2, buffer size = 1, buffer
actual size = 2)
Informative 07/09/09 09:53:17 1184 3 CJVMTIInterface [GetLineNumberTable]
user-supplied buffer is too short. table size = 2, buffer size = 1, buffer
actual size = 2)
Informative 07/09/09 09:53:17 1184 3 CJVMTIInterface [GetLineNumberTable]
user-supplied buffer is too short. table size = 2, buffer size = 1, buffer
actual size = 2)
Informative 07/09/09 09:53:17 1184 3 CJVMTIInterface [GetLineNumberTable]
user-supplied buffer is too short. table size = 2, buffer size = 1, buffer
actual size = 2)
Informative 07/09/09 09:53:17 1184 3 CJVMTIInterface [GetLineNumberTable]
user-supplied buffer is too short. table size = 2, buffer size = 1, buffer
actual size = 2)
Informative 07/09/09 09:53:17 1184 3 CJVMTIInterface [GetLineNumberTable]
user-supplied buffer is too short. table size = 2, buffer size = 1, buffer
actual size = 2)
Informative 07/09/09 09:53:17 1184 3 CJVMTIInterface [GetLineNumberTable]
user-supplied buffer is too short. table size = 2, buffer size = 1, buffer
actual size = 2)
Informative 07/09/09 09:53:17 1184 3 CJVMTIInterface [GetLineNumberTable]
user-supplied buffer is too short. table size = 2, buffer size = 1, buffer
actual size = 2)
Informative 07/09/09 09:53:17 1184 3 CJVMTIInterface [GetLineNumberTable]
user-supplied buffer is too short. table size = 2, buffer size = 1, buffer
actual size = 2)

But i could not get any profiling data in the profiler view.

JBOSS run out of memory after trying multiple times.
Re: Profiling Web Application on JBOSS Attaching an Agent [message #143131 is a reply to message #143067] Mon, 13 July 2009 19:20 Go to previous messageGo to next message
Eugene Chan is currently offline Eugene ChanFriend
Messages: 287
Registered: July 2009
Senior Member
Hi Surbhigl,

Re the IAC vs AC, did you have a standalone Agent controller running and
have it setup to use port 10006?
I read your original posting again and see that you are using 441 with JRE
1.6. JRE 1.6 was not support with TPTP 441. If you have to use JRE 1.6,
please tried with latst TPTP release v4.6.

Eugene

"surbhigl " <surbhi.mittal@globallogic.com> wrote in message
news:78be54d9da49d160be169be6838007e3$1@www.eclipse.org...
> Hi,
>
> I have again tried launching the agent controller along with jboss and
> attaching the agent from the eclipse.
> This time it worked little further and started generating the log. I made
> changes in the environment variables and altered path environment variable
> to add absolute paths instead of using their created Home environment
> variables. Secondly, in the eclipse when i go to Profile dialog -> Attach
> An Agent, I have added another host i.e. localhost:10006. There was an
> entry localhost:10002. This was for IAC so I think the problem was this.
> After making all these changes, and using filter setting for my packages,
> it appears it starts to profile but with no success.
> Here is the trace from Mlog containing error :
>
> Informative 07/09/09 08:55:25 1588 3 CClassRedefThread Received request to
> to redefine 157 classes. isBlocking = 1
>
> Informative 07/09/09 08:55:33 4876 3 CGAdaptor Class
> com/one/administration/degreearea/delegate/DegreeAreaCnstDel egate was not
> instrumented because all its methods were excluded
> Informative 07/09/09 08:55:33 4876 3 CGAdaptor Class
> com/one/memberships/creditcard/delegate/CreditCardDelegate was not
> instrumented because all its methods were excluded
> Informative 07/09/09 08:55:37 2744 3 CGAdaptor Class
> com/one/csf/struts/form/SourceCodeForm was not instrumented because all
> its methods were excluded
> Informative 07/09/09 08:55:37 2744 0 CDataManager Class
> 'com/one/csf/struts/form/SourceCodeForm' has wrong instrumentation, but
> will not be redefined due to user-defined filters or an internal reason
> Informative 07/09/09 08:55:37 2744 3 CGAdaptor Class
> com/one/csf/struts/action/SourceCodeAction was not instrumented because
> all its methods were excluded
> Informative 07/09/09 08:55:37 2744 3 CGAdaptor Class
> com/one/csf/struts/action/SourceCodeAction was not instrumented because
> all its methods were excluded
> Informative 07/09/09 08:55:37 2744 0 CDataManager Class
> 'com/one/csf/struts/action/SourceCodeAction' has wrong instrumentation,
> but will not be redefined due to user-defined filters or an internal
> reason
> Informative 07/09/09 08:55:37 2744 3 CGAdaptor Class
> com/one/csf/audittrail/AuditTrail was not instrumented because all its
> methods were excluded
> Informative 07/09/09 08:55:37 2744 3 CGAdaptor Class
> com/one/csf/audittrail/AuditTrailException was not instrumented because
> all its methods were excluded
> Informative 07/09/09 08:55:40 4876 0 CJVMTIInterface RedefineClasses:
> failed to redefine 1 classes. JVMTI Error: 110
>
> Error 07/09/09 08:55:40 4876 0 CJavaInstrumentorManager RedefineClasses
> failed. Instrumented classes may be in inconsistent state
>
> And Jboss shutdown with the following errors:
> [Error: EC JPIAgent received message (FATAL ERROR): Internal error (see
> log file).]
>
> Thanks,
>
Re: Profiling Web Application on JBOSS Attaching an Agent [message #143152 is a reply to message #143131] Tue, 14 July 2009 11:15 Go to previous message
surbhigl is currently offline surbhiglFriend
Messages: 13
Registered: July 2009
Junior Member
Hi Eugene,

I tried using TPTP 4.6 along with JRE 1.6 and Eclipse 3.3.2.
Now i am able to get profiling data in eclipse Profiling view.

Thanks for the support.
Previous Topic:where is tptp 4.6 log file
Next Topic:TPTP going to die?
Goto Forum:
  


Current Time: Sat Nov 29 04:02:51 GMT 2014

Powered by FUDForum. Page generated in 0.03786 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software