Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Visual Editor (VE) » Re: Error by EMF-Update
Re: Error by EMF-Update [message #142624] Thu, 01 November 2007 11:46 Go to next message
Eclipse User
Originally posted by: merks.ca.ibm.com

Cue,

I don't think there is a VE update on the Europa update site. Also, you
certainly shouldn't need to install OCL to install VE. I added the VE
newsgroup to the "to" of the reply. I suggest you look at that
newsgroup for discussions about how to load a version of VE that's
compatible with Eclipse 3.3. I also added the OCL newsgroup in case
this issue represents an actual problem on the update site (though as I
said, you won't be able to use the update site to install a version of
VE that works with Eclipse 3.3 and you shouldn't need OCL for that anyway).


Cui, Hua wrote:
> Hi, I want to install Visual Editor, but bevor that I must install the
> EMF.
> Then come the error report:
> Requested operation cannot be performed because it would invalidate
> the current configuration...
>
> EMF Model Query OCL
> Intergration(1.1.0.v200706071712-10-7w311817182823) requirea plug-in
> "org.eclipse.emf.ocl(1.1.0)", or compatible.
> 20-10-7w31181718EMF Validation Framework OCL
> Integration(1.1.0.v200706071520-10-7w311817182631)requires plug-in
> "org.eclipse.emf.ocl(1.0.0)", or compatible.
>
> I have try to use the Help->Software Updates->find and Install->search
> for new features to install. but come the error.
>
> Information about the system:
> Windows XP, eclipse-java-europa-fall-win32
>
> I am new, PLEASE simply answer
> thanks
> Cui
>
Re: Error by EMF-Update [message #142646 is a reply to message #142624] Thu, 01 November 2007 14:21 Go to previous message
Eclipse User
Originally posted by: cdamus.ca.ibm.com

Hi, Ed, Cui,

This message is not indicating that OCL is required in order to install VE.

Update Manager will refuse to install *anything* if there is any problem
already in the install configuration. In this case, that happens to be an
installed EMF Model Query feature (org.eclipse.emf.query.ocl) that is
missing its OCL prerequisite.

Installing OCL will resolve this configuration problem and unblock
UpdateManager so that you can proceed to install VE. Of course, since VE
has nothing to do with OCL as Ed mentioned and installing it can't make the
configuration any more broken, UpdateManager should not refuse the install.
This is a bug in UM, which I think is already reported in Bugzilla but I
don't have a reference on hand.

Cheers,

Christian


Ed Merks wrote:

> Cue,
>
> I don't think there is a VE update on the Europa update site. Also, you
> certainly shouldn't need to install OCL to install VE. I added the VE
> newsgroup to the "to" of the reply. I suggest you look at that
> newsgroup for discussions about how to load a version of VE that's
> compatible with Eclipse 3.3. I also added the OCL newsgroup in case
> this issue represents an actual problem on the update site (though as I
> said, you won't be able to use the update site to install a version of
> VE that works with Eclipse 3.3 and you shouldn't need OCL for that
> anyway).
>
>
> Cui, Hua wrote:
>> Hi, I want to install Visual Editor, but bevor that I must install the
>> EMF.
>> Then come the error report:
>> Requested operation cannot be performed because it would invalidate
>> the current configuration...
>>
>> EMF Model Query OCL
>> Intergration(1.1.0.v200706071712-10-7w311817182823) requirea plug-in
>> "org.eclipse.emf.ocl(1.1.0)", or compatible.
>> 20-10-7w31181718EMF Validation Framework OCL
>> Integration(1.1.0.v200706071520-10-7w311817182631)requires plug-in
>> "org.eclipse.emf.ocl(1.0.0)", or compatible.
>>
>> I have try to use the Help->Software Updates->find and Install->search
>> for new features to install. but come the error.
>>
>> Information about the system:
>> Windows XP, eclipse-java-europa-fall-win32
>>
>> I am new, PLEASE simply answer
>> thanks
>> Cui
>>
Re: Error by EMF-Update [message #616838 is a reply to message #142624] Thu, 01 November 2007 14:21 Go to previous message
Eclipse User
Originally posted by: cdamus.ca.ibm.com

Hi, Ed, Cui,

This message is not indicating that OCL is required in order to install VE.

Update Manager will refuse to install *anything* if there is any problem
already in the install configuration. In this case, that happens to be an
installed EMF Model Query feature (org.eclipse.emf.query.ocl) that is
missing its OCL prerequisite.

Installing OCL will resolve this configuration problem and unblock
UpdateManager so that you can proceed to install VE. Of course, since VE
has nothing to do with OCL as Ed mentioned and installing it can't make the
configuration any more broken, UpdateManager should not refuse the install.
This is a bug in UM, which I think is already reported in Bugzilla but I
don't have a reference on hand.

Cheers,

Christian


Ed Merks wrote:

> Cue,
>
> I don't think there is a VE update on the Europa update site. Also, you
> certainly shouldn't need to install OCL to install VE. I added the VE
> newsgroup to the "to" of the reply. I suggest you look at that
> newsgroup for discussions about how to load a version of VE that's
> compatible with Eclipse 3.3. I also added the OCL newsgroup in case
> this issue represents an actual problem on the update site (though as I
> said, you won't be able to use the update site to install a version of
> VE that works with Eclipse 3.3 and you shouldn't need OCL for that
> anyway).
>
>
> Cui, Hua wrote:
>> Hi, I want to install Visual Editor, but bevor that I must install the
>> EMF.
>> Then come the error report:
>> Requested operation cannot be performed because it would invalidate
>> the current configuration...
>>
>> EMF Model Query OCL
>> Intergration(1.1.0.v200706071712-10-7w311817182823) requirea plug-in
>> "org.eclipse.emf.ocl(1.1.0)", or compatible.
>> 20-10-7w31181718EMF Validation Framework OCL
>> Integration(1.1.0.v200706071520-10-7w311817182631)requires plug-in
>> "org.eclipse.emf.ocl(1.0.0)", or compatible.
>>
>> I have try to use the Help->Software Updates->find and Install->search
>> for new features to install. but come the error.
>>
>> Information about the system:
>> Windows XP, eclipse-java-europa-fall-win32
>>
>> I am new, PLEASE simply answer
>> thanks
>> Cui
>>
Previous Topic:Re: Error by EMF-Update
Next Topic:recommended GUI builder
Goto Forum:
  


Current Time: Tue Sep 23 06:22:14 GMT 2014

Powered by FUDForum. Page generated in 0.03356 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software