Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Can't find data collectors
Can't find data collectors [message #142268] Wed, 27 May 2009 12:03 Go to next message
oebidoebi is currently offline oebidoebi
Messages: 2
Registered: July 2009
Junior Member
Hi,

Yesterday I've installed the tptp plugin to profile my java-application,
which I did succesfully a couple of times. Today I wanted to profile
again, but it wouldn't work. It sais: IWAT0435E an error occured when
connecting to the host. And he doesn't show any data collectors.

What I've tried so far is:
- Run SetConfig.dat (didn't work, so...)
- reinstal Eclipse and the TPTP-plugin (in a folder without spaces in the
name)
- delete .metadata (from workspace), delete serviceconfig.xml (from the
config folder), run SetConfig.dat, restart Eclipse

The strange thing (to me) is that when I delete the .metadata folder and
then check the connection with the localhost (via
Window->preferences->Agent Controller->hosts->Test connection) it sais:
Connection success. But when I then click on "Integrated Agent Controller"
under "Agent Controller" a pop up sais 'the currently displayed page
contains invalid values' and it refuses to go to the "Integrated Agent
Controller". Then I click OK and nothing happens. I then first have to
click on "Agent Controller", and then I can go to the "Integrated Agent
Controller". I can set the values there (start/stop:enable, machine
access:localhost, security:off) and then I click apply, it restarts the
IAC. When I then check the connection with the local host again it gives
me error IWAT0284E.

I've also tried to set these values with the SetConfig.bat. But that
doesn't seem to have any effect. Because when I delete the .metadata
folder and the serviceconfig.xml (in the config folder) (to get a 'fresh'
start), it creates a new serviceconfig.xml but it doesn't seem to set the
values in Eclipse (in Window->preferences->Agent Controller->Integrated
Agent Controller no bullets are selected, every textfield or bullet is
empty).

I'm out of options. Can you help me?


Specifications

Environment Variables
JAVA_HOME = C:\Program Files\Java\jdk1.6.0_13
JAVA_PROFILER_HOME =
C:\EclipseJava\eclipse\plugins\org.eclipse.tptp.platform.jvm ti.runtime_4.4.201.v200902180100\agent_files\win_ia32
Path = ...;C:\Program
Files\Java\jdk1.6.0_13\bin;%JAVA_PROFILER_HOME%;%TPTP_AC_HOM E%\bin;%TPTP_AC_HOME%\lib;%PATH%

Desktop
TPTP latest version till date (4.5)
Eclipse 3.4
Java 1.6.0_13
Windows XP SP3

ps. My Eclipse workspace is shared via a dropbox by two computers (1
desktop XP 32bit, 1 laptop Vista 64bit, both Eclipse 3.4).
Re: Can't find data collectors, error IWAT0435E [message #142280 is a reply to message #142268] Thu, 28 May 2009 10:09 Go to previous message
oebidoebi is currently offline oebidoebi
Messages: 2
Registered: July 2009
Junior Member
Sorry for bothering you guys!

I was so eager to get that thing running that I tried one more 'hard
reset'. My last reset wasn't hard enough apparently. What I've done to get
it working:
- delete Eclipse
- delete .metadata folder (I want to use the same workspace)
- delete the environment variables I created (see previous post)
- run CCleaner to clean registry

- unzip Eclipse
- install tptp plugin via update manager

And it works! Without configuring anything. It's profiling right now. (on
my desktop btw, see my previous post)

Thanks for any time spent on this problem!
Previous Topic:Verification Class
Next Topic:"An error occured when connecting to the host."
Goto Forum:
  


Current Time: Fri Oct 31 08:01:28 GMT 2014

Powered by FUDForum. Page generated in 0.05936 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software