Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Unable to attach an agent locally using eclipse 3.4.2
Unable to attach an agent locally using eclipse 3.4.2 [message #141331] Wed, 25 March 2009 13:56 Go to next message
Rahuldeb Barman is currently offline Rahuldeb Barman
Messages: 2
Registered: July 2009
Junior Member
I was trying to attach an agent locally using eclipse GANYMETE but was
getting an error
I am giving the all step followeds in details

The initial installation setup ::

I put a java process whose performance I want to monitor in this location
-> C:\D\workspace_tptp\testtptp\com.test.ibm.CarModel.java say
$applicationHome
I also downloded eclipse GANYMEDE of version 3.4.2
I have installed the AgentController from this location ->
http://www.eclipse.org/tptp/home/downloads/#agentController
and installed it in this location -> C:\performance\tptp\AgentController
say $TPTP_AC_HOME


The process followed::

step 1.
I configured the AgentController by running the SetConfig.bat from the
$TPTP_AC_HOME\bin
I have given all these data as part of the AgentController configuration

Specify the fully qualified path of "java.exe" (e.g.
c:\jdk1.4\jre\bin\java.exe):
Default>"C:\Program Files\IBM\Java50\jre\bin\java.exe" (Press <ENTER>
to accept the default value)
New value>
Network access mode (ALL=allow any host, LOCAL=allow only this host,
CUSTOM=list of hosts):
Default>"LOCAL" (Press <ENTER> to accept the default value)
New value>ALL
Security enabled. (true/false):
Default>"FALSE" (Press <ENTER> to accept the default value)
New value>

step 2.
Configuring the Enironment variables

# Set TPTP_AC_HOME=<<Agent Controller Home>> -------> in environment
var
# Set
JAVA_PROFILER_HOME=%TPTP_AC_HOME%\plugins\org.eclipse.tptp.j avaprofiler
---->in environment var
# Set LD_LIBRARY_PATH=%JAVA_PROFILER_HOME%;%TPTP_AC_HOME%\lib ---->in
environment var


step 3.

Running the Agent Controller

Then I started the ACServer.exe from the $TPTP_AC_HOME\bin
It has started listening in the 10005 port
This is logged in the servicelog.log file which resides in the
$TPTP_AC_HOME\config location.

Running the agent

3.1. Go to the $applicationHome in command prompt
3.2. # Set PATH=%JAVA_PROFILER_HOME%;%PATH%;%TPTP_AC_HOME%\bin
# Set PATH=%LD_LIBRARY_PATH%;%PATH%
3.3. Running the application locally by running this command
java
-agentlib:JPIBootLoader=JPIAgent:server=standalone,filters=m yFilter.txt;HeapProf:allocsites=true
com.test.ibm.CarModel

step 4.

Trying to atttach the agent from local eclipse
4.1 open eclipse GANYMEDE
4.2 click on run->profile configurations->AttachToAgent
4.3 i selected the default port (i.e. 10005) the connection was
successful
4.4 But if I try to see the running agent locally by clicking the agent
tab it is throwing an error

The error is ::

Exception stack trace

org.eclipse.tptp.platform.execution.exceptions.AgentControll erUnavailableException:
Error: Unable to connect to the Agent Controller.Connection reset
at
org.eclipse.tptp.platform.execution.client.core.internal.Nod eImpl.connect(NodeImpl.java:128)
at
org.eclipse.tptp.platform.execution.util.internal.AgentContr ollerFactory$EstablishConnection.run(AgentControllerFactory. java:126)
at java.lang.Thread.run(Thread.java:801)

Session Data

eclipse.buildId=M20090211-1700
java.fullversion=J2RE 1.5.0 IBM J9 2.3 Windows XP x86-32
j9vmwi3223-20070426 (JIT enabled)
J9VM - 20070420_12448_lHdSMR
JIT - 20070419_1806_r8
GC - 200704_19
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86


Any help will be of grt help
Thanks in advance
Re: Unable to attach an agent locally using eclipse 3.4.2 [message #141477 is a reply to message #141331] Mon, 30 March 2009 15:29 Go to previous message
Eugene Chan is currently offline Eugene Chan
Messages: 287
Registered: July 2009
Senior Member
Hi Rahuldeb,

Please see my answer to your posting on 3/25/2009 10.02am.

Eugene

"Rahuldeb Barman" <barman.rahuldeb@gmail.com> wrote in message
news:74c89c700df6ebcbda4d988d9a586dc9$1@www.eclipse.org...
>I was trying to attach an agent locally using eclipse GANYMETE but was
>getting an error
> I am giving the all step followeds in details
> The initial installation setup ::
>
> I put a java process whose performance I want to monitor in this
> location -> C:\D\workspace_tptp\testtptp\com.test.ibm.CarModel.java say
> $applicationHome
> I also downloded eclipse GANYMEDE of version 3.4.2
> I have installed the AgentController from this location ->
> http://www.eclipse.org/tptp/home/downloads/#agentController
> and installed it in this location -> C:\performance\tptp\AgentController
> say $TPTP_AC_HOME
>
>
> The process followed::
>
> step 1. I configured the AgentController by running the SetConfig.bat from
> the $TPTP_AC_HOME\bin
> I have given all these data as part of the AgentController configuration
>
> Specify the fully qualified path of "java.exe" (e.g.
> c:\jdk1.4\jre\bin\java.exe):
> Default>"C:\Program Files\IBM\Java50\jre\bin\java.exe" (Press <ENTER> to
> accept the default value)
> New value>
> Network access mode (ALL=allow any host, LOCAL=allow only this host,
> CUSTOM=list of hosts):
> Default>"LOCAL" (Press <ENTER> to accept the default value)
> New value>ALL
> Security enabled. (true/false):
> Default>"FALSE" (Press <ENTER> to accept the default value)
> New value>
> step 2. Configuring the Enironment variables
>
> # Set TPTP_AC_HOME=<<Agent Controller Home>> -------> in environment var
> # Set
> JAVA_PROFILER_HOME=%TPTP_AC_HOME%\plugins\org.eclipse.tptp.j avaprofiler ---->in
> environment var
> # Set LD_LIBRARY_PATH=%JAVA_PROFILER_HOME%;%TPTP_AC_HOME%\lib ---->in
> environment var
>
>
> step 3.
>
> Running the Agent Controller
>
> Then I started the ACServer.exe from the $TPTP_AC_HOME\bin It has started
> listening in the 10005 port
> This is logged in the servicelog.log file which resides in the
> $TPTP_AC_HOME\config location.
>
> Running the agent
> 3.1. Go to the $applicationHome in command prompt
> 3.2. # Set PATH=%JAVA_PROFILER_HOME%;%PATH%;%TPTP_AC_HOME%\bin # Set
> PATH=%LD_LIBRARY_PATH%;%PATH%
> 3.3. Running the application locally by running this command
> java -agentlib:JPIBootLoader=JPIAgent:server=standalone,filters=m yFilter.txt;HeapProf:allocsites=true
> com.test.ibm.CarModel
> step 4.
>
> Trying to atttach the agent from local eclipse
> 4.1 open eclipse GANYMEDE
> 4.2 click on run->profile configurations->AttachToAgent
> 4.3 i selected the default port (i.e. 10005) the connection was successful
> 4.4 But if I try to see the running agent locally by clicking the agent
> tab it is throwing an error
>
> The error is ::
>
> Exception stack trace
>
> org.eclipse.tptp.platform.execution.exceptions.AgentControll erUnavailableException:
> Error: Unable to connect to the Agent Controller.Connection reset
> at
> org.eclipse.tptp.platform.execution.client.core.internal.Nod eImpl.connect(NodeImpl.java:128)
> at
> org.eclipse.tptp.platform.execution.util.internal.AgentContr ollerFactory$EstablishConnection.run(AgentControllerFactory. java:126)
> at java.lang.Thread.run(Thread.java:801)
>
> Session Data
>
> eclipse.buildId=M20090211-1700
> java.fullversion=J2RE 1.5.0 IBM J9 2.3 Windows XP x86-32
> j9vmwi3223-20070426 (JIT enabled)
> J9VM - 20070420_12448_lHdSMR
> JIT - 20070419_1806_r8
> GC - 200704_19
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
> Command-line arguments: -os win32 -ws win32 -arch x86
>
>
> Any help will be of grt help
> Thanks in advance
>
>
Previous Topic:Symptom Catalog format
Next Topic:Questions about profiling a WebSphere web application
Goto Forum:
  


Current Time: Mon Sep 22 04:31:24 GMT 2014

Powered by FUDForum. Page generated in 0.01597 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software