Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » [Monitor]: The launch requires at least one data collector to be selected.
[Monitor]: The launch requires at least one data collector to be selected. [message #141276] Tue, 17 March 2009 12:09 Go to next message
Martin Heusel is currently offline Martin Heusel
Messages: 5
Registered: July 2009
Junior Member
Hi,

i get this message after installing TPTP. The Monitor tab says Pending...
and the Profile Button is greyed out. Also there is a background process
idling with 0% 'Fetching children of data collector' 'Filtering data
collectors'. Is there a package missing? Thanks for any advice.

Setup:

Linux Gentoo

java version "1.6.0_12"
Java(TM) SE Runtime Environment (build 1.6.0_12-b04)
Java HotSpot(TM) Server VM (build 11.2-b01, mixed mode)


Eclipse Platform

Version: 3.4.2
Build id: M20090211-1700

TPTP Platform Project 4.5.1
TPTP Monitoring Tools Project 4.4.101
TPTP Tracing and Profiling Tools Project 4.3.201
Re: [Monitor]: The launch requires at least one data collector to be selected. [message #141520 is a reply to message #141276] Mon, 30 March 2009 11:51 Go to previous messageGo to next message
Eugene Chan is currently offline Eugene Chan
Messages: 287
Registered: July 2009
Senior Member
Hi Martin,

Could you try the following and try agian:
1. shutdown Eclipse workbench
2. stop the following processes on your system:
a. ACServer
b. java
c. eclipse
3. restart Eclipseworkbench

It sounds like your Agent Controller may have problem starting/stopping
itself automatically.

Eugene

"Martin Heusel" <mheusel@gmail.com> wrote in message
news:0e56da1bf3ab2975aec5a642975c06ea$1@www.eclipse.org...
> Hi,
>
> i get this message after installing TPTP. The Monitor tab says Pending...
> and the Profile Button is greyed out. Also there is a background process
> idling with 0% 'Fetching children of data collector' 'Filtering data
> collectors'. Is there a package missing? Thanks for any advice.
>
> Setup:
>
> Linux Gentoo
>
> java version "1.6.0_12"
> Java(TM) SE Runtime Environment (build 1.6.0_12-b04)
> Java HotSpot(TM) Server VM (build 11.2-b01, mixed mode)
>
>
> Eclipse Platform
>
> Version: 3.4.2
> Build id: M20090211-1700
>
> TPTP Platform Project 4.5.1
> TPTP Monitoring Tools Project 4.4.101
> TPTP Tracing and Profiling Tools Project 4.3.201
>
>
>
Re: [Monitor]: The launch requires at least one data collector to be selected. [message #141616 is a reply to message #141520] Wed, 01 April 2009 06:56 Go to previous messageGo to next message
Martin Heusel is currently offline Martin Heusel
Messages: 5
Registered: July 2009
Junior Member
Hi Eugene,

thanks for your help. I already found this ACServer process. The ACServer
is here with a child tptpProcessCont. Both disappear if eclipse is
stopped. But the situation is the same if eclipse is started again.

Regards

Martin
Re: [Monitor]: The launch requires at least one data collector to be selected. [message #141626 is a reply to message #141616] Wed, 01 April 2009 11:28 Go to previous messageGo to next message
Eugene Chan is currently offline Eugene Chan
Messages: 287
Registered: July 2009
Senior Member
Hi Martin,

It sounds like it may be a corrupted Agent Controller plugin. Could you try
with the all-in-one package from TPTP >
http://www.eclipse.org/tptp/home/downloads/?ver=4.5.2

Eugene

"Martin Heusel" <mheusel@gmail.com> wrote in message
news:0f477539733b0841f3b7e872ab1a177e$1@www.eclipse.org...
> Hi Eugene,
>
> thanks for your help. I already found this ACServer process. The ACServer
> is here with a child tptpProcessCont. Both disappear if eclipse is
> stopped. But the situation is the same if eclipse is started again.
>
> Regards
>
> Martin
>
>
Re: [Monitor]: The launch requires at least one data collector to be selected. [message #141724 is a reply to message #141626] Tue, 07 April 2009 15:54 Go to previous messageGo to next message
Martin Heusel is currently offline Martin Heusel
Messages: 5
Registered: July 2009
Junior Member
Hi Eugene,

i tried the all-in-one package and get the data collectors.
But profiling (Execution Time Analysis) leads to an error

ERROR: JVMPI, an experimental interface, is no longer supported.
Please use the supported interface: the JVM Tool Interface (JVM TI).
Could not resolve to JVMPI interface
Error occurred during initialization of VM
-Xrun library failed to init: piAgent


my java -version is

java version "1.6.0_13"
Java(TM) SE Runtime Environment (build 1.6.0_13-b03)
Java HotSpot(TM) Server VM (build 11.3-b02, mixed mode)
Re: [Monitor]: The launch requires at least one data collector to be selected. [message #141754 is a reply to message #141724] Thu, 09 April 2009 11:05 Go to previous messageGo to next message
Eugene Chan is currently offline Eugene Chan
Messages: 287
Registered: July 2009
Senior Member
Hi Martin,

It sounds like your AC is not configuration with the right version of Java.
Could you confirm the AC Java version by Windows>Perferences>Agent
Controller>Integerated Agent Controller>JVM setup? Integrated AC uses the
JVM configurated under the Java Runtime perferences.
If you have mutiple profiling agents showing up in the Monitor tab, pick the
one named 'Java Profiler - Java 1.5 or newer' and try again.

Eugene

"Martin Heusel" <mheusel@gmail.com> wrote in message
news:0de065847d0228fc1a76be373ece707c$1@www.eclipse.org...
> Hi Eugene,
>
> i tried the all-in-one package and get the data collectors. But profiling
> (Execution Time Analysis) leads to an error
>
> ERROR: JVMPI, an experimental interface, is no longer supported.
> Please use the supported interface: the JVM Tool Interface (JVM TI).
> Could not resolve to JVMPI interface
> Error occurred during initialization of VM
> -Xrun library failed to init: piAgent
>
>
> my java -version is
>
> java version "1.6.0_13"
> Java(TM) SE Runtime Environment (build 1.6.0_13-b03)
> Java HotSpot(TM) Server VM (build 11.3-b02, mixed mode)
>
>
Re: [Monitor]: The launch requires at least one data collector to be selected. [message #141925 is a reply to message #141754] Thu, 16 April 2009 06:02 Go to previous messageGo to next message
Martin Heusel is currently offline Martin Heusel
Messages: 5
Registered: July 2009
Junior Member
Hi Eugene,

both AC Java version and Java Runtime preferences point to the same (and
only) Java installation. But what confuses me is that
Profile->Configurations->Monitor only shows

Java Profiling - pre JRE 1.5
Instrument Collector - pre JRE 1.6

maybe this is the problem because i have JRE 1.6 and this could maybe lead
to the 'ERROR: JVMPI, an experimental interface, is no longer supported.'
error message(?).

regards and thanks for the help

Martin

> It sounds like your AC is not configuration with the right version of Java.
> Could you confirm the AC Java version by Windows>Perferences>Agent
> Controller>Integerated Agent Controller>JVM setup? Integrated AC uses the
> JVM configurated under the Java Runtime perferences.
> If you have mutiple profiling agents showing up in the Monitor tab, pick the
> one named 'Java Profiler - Java 1.5 or newer' and try again.


>> ERROR: JVMPI, an experimental interface, is no longer supported.
>> Please use the supported interface: the JVM Tool Interface (JVM TI).
>> Could not resolve to JVMPI interface
>> Error occurred during initialization of VM
>> -Xrun library failed to init: piAgent
Re: [Monitor]: The launch requires at least one data collector to be selected. [message #142036 is a reply to message #141925] Thu, 16 April 2009 13:02 Go to previous messageGo to next message
Eugene Chan is currently offline Eugene Chan
Messages: 287
Registered: July 2009
Senior Member
Hi Martin,

This sounds like bug 272048 to me.

Eugene

"Martin Heusel" <mheusel@gmail.com> wrote in message
news:d2579bdf42458780a10418a524c58170$1@www.eclipse.org...
> Hi Eugene,
>
> both AC Java version and Java Runtime preferences point to the same (and
> only) Java installation. But what confuses me is that
> Profile->Configurations->Monitor only shows
>
> Java Profiling - pre JRE 1.5
> Instrument Collector - pre JRE 1.6
>
> maybe this is the problem because i have JRE 1.6 and this could maybe lead
> to the 'ERROR: JVMPI, an experimental interface, is no longer supported.'
> error message(?).
> regards and thanks for the help
>
> Martin
>
>> It sounds like your AC is not configuration with the right version of
>> Java.
>> Could you confirm the AC Java version by Windows>Perferences>Agent
>> Controller>Integerated Agent Controller>JVM setup? Integrated AC uses the
>> JVM configurated under the Java Runtime perferences.
>> If you have mutiple profiling agents showing up in the Monitor tab, pick
>> the one named 'Java Profiler - Java 1.5 or newer' and try again.
>
>
>>> ERROR: JVMPI, an experimental interface, is no longer supported.
>>> Please use the supported interface: the JVM Tool Interface (JVM TI).
>>> Could not resolve to JVMPI interface
>>> Error occurred during initialization of VM
>>> -Xrun library failed to init: piAgent
>
>
Re: [Monitor]: The launch requires at least one data collector to be selected. [message #142043 is a reply to message #142036] Sun, 19 April 2009 16:20 Go to previous message
Martin Heusel is currently offline Martin Heusel
Messages: 5
Registered: July 2009
Junior Member
Hi Eugene,

yes this is exactly this bug. So i will wait for TPTP 2.6.0 or check out
the next development build.

Thank you very much

Martin
Previous Topic:TPTP and WebStart apps...
Next Topic:Why native code for agents?
Goto Forum:
  


Current Time: Fri Aug 29 10:16:07 EDT 2014

Powered by FUDForum. Page generated in 0.02695 seconds