Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » OSX: use bundled JRE
OSX: use bundled JRE [message #979040] Sat, 10 November 2012 10:12 Go to next message
Andy Dunkel is currently offline Andy Dunkel
Messages: 6
Registered: November 2011
Junior Member
Hi all,

I hope thats the correct board here.

I am currently running into the following issue. I want to export my application for OSX. My goal is, that I do not have any dependency on the JRE, so I bundled the JRE with my export.

The export is running fine, and the JRE is bundled into the folder "jre" of the application

However, when I launch the application it always prompts the user to download the JRE 6:

http://andy.ekiwi.de/stuff/eclipse.png

I am using Eclipse 3.7.2 and the JRE 6. I also tried to export with the JRE 7, having the same issue.

How can I bring my application to use the bundled JRE?

Thanks,
Andy
Re: OSX: use bundled JRE [message #986289 is a reply to message #979040] Mon, 19 November 2012 13:23 Go to previous message
Libor Jelinek is currently offline Libor Jelinek
Messages: 143
Registered: January 2012
Location: Prague, Czech Rep.
Senior Member

Hello Andy,
what's in your launcher config file (has the same name as your native
executable launcher but .ini extension)?

Also see
http://help.eclipse.org/juno/topic/org.eclipse.platform.doc.isv/reference/misc/launcher.html?cp=2_1_3_1

Libor

On 11/10/2012 04:12 PM, Andy Dunkel wrote:
> Hi all,
>
> I hope thats the correct board here.
>
> I am currently running into the following issue. I want to export my
> application for OSX. My goal is, that I do not have any dependency on
> the JRE, so I bundled the JRE with my export.
> The export is running fine, and the JRE is bundled into the folder "jre"
> of the application
> However, when I launch the application it always prompts the user to
> download the JRE 6:
>
>
>
> I am using Eclipse 3.7.2 and the JRE 6. I also tried to export with the
> JRE 7, having the same issue.
>
> How can I bring my application to use the bundled JRE?
> Thanks,
> Andy
Previous Topic:[p2] How to disable the "Review Licenses" dialogue?
Next Topic:Preventing 5000ms classloading timeout
Goto Forum:
  


Current Time: Wed Aug 20 18:28:50 EDT 2014

Powered by FUDForum. Page generated in 0.01689 seconds