Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Problems with starting first cheat sheet test....
Problems with starting first cheat sheet test.... [message #977780] Fri, 09 November 2012 15:17 Go to next message
Patrick R. is currently offline Patrick R.Friend
Messages: 10
Registered: July 2009
Junior Member
Hello,
i've worked through the first cheat sheets for jubula. But now i can't get my Tests to work. I've been using the stand alone version on a Windows 7 Machine.

1. I start my autagent. Then i see a commandline Window which disappears after a second or two again. (How can i make sure the agent really runs? There are no logs for it.)
2. I start my simpleAdder1 AUT.
3. I click on "Start Test Execution" -> Nothing happens

Can anybody give me a hint?

Thanks
Patrick
Re: Problems with starting first cheat sheet test.... [message #977882 is a reply to message #977780] Fri, 09 November 2012 17:04 Go to previous messageGo to next message
Patrick R. is currently offline Patrick R.Friend
Messages: 10
Registered: July 2009
Junior Member
Installed it on another machine. Worked my way through the first test cheat sheet again. Now when i try to start the tests, nothing happens and the logfile for the client is full of exceptions.... i'think i take a break for now. Wink
Re: Problems with starting first cheat sheet test.... [message #981218 is a reply to message #977882] Mon, 12 November 2012 08:46 Go to previous messageGo to next message
Patrick R. is currently offline Patrick R.Friend
Messages: 10
Registered: July 2009
Junior Member
Ok,back again. This is on example of the exceptions i get, when i try to run the Tests from the cheatsheet:

2012-11-12 09:11:01.323 [ModalContext] ERROR o.e.jubula.tools.i18n.CompSystemI18n - Cannot find I18N-key in resource bundles: 1
java.util.MissingResourceException: No entry found for key: 1
at org.eclipse.jubula.tools.i18n.CompSystemI18n.getStringInternal(CompSystemI18n.java:128) ~[org.eclipse.jubula.tools_1.3.0.201210161256.jar:na]
at org.eclipse.jubula.tools.i18n.CompSystemI18n.getString(CompSystemI18n.java:80) ~[org.eclipse.jubula.tools_1.3.0.201210161256.jar:na]
at org.eclipse.jubula.client.core.utils.StringHelper.initMap(StringHelper.java:154) [org.eclipse.jubula.client.core_1.3.0.201210161256.jar:na]
at org.eclipse.jubula.client.core.utils.StringHelper.<init>(StringHelper.java:56) [org.eclipse.jubula.client.core_1.3.0.201210161256.jar:na]
at org.eclipse.jubula.client.core.utils.StringHelper.getInstance(StringHelper.java:85) [org.eclipse.jubula.client.core_1.3.0.201210161256.jar:na]
at org.eclipse.jubula.client.core.businessprocess.ComponentNamesBP.initDefaultNames(ComponentNamesBP.java:743) [org.eclipse.jubula.client.core_1.3.0.201210161256.jar:na]
at org.eclipse.jubula.client.core.businessprocess.ComponentNamesBP.<init>(ComponentNamesBP.java:158) [org.eclipse.jubula.client.core_1.3.0.201210161256.jar:na]
at org.eclipse.jubula.client.core.businessprocess.ComponentNamesBP.getInstance(ComponentNamesBP.java:167) [org.eclipse.jubula.client.core_1.3.0.201210161256.jar:na]
at org.eclipse.jubula.client.core.persistence.ProjectPM.loadProjectInROSession(ProjectPM.java:507) [org.eclipse.jubula.client.core_1.3.0.201210161256.jar:na]
at org.eclipse.jubula.client.ui.rcp.handlers.project.OpenProjectHandler$OpenProjectOperation.load(OpenProjectHandler.java:274) [org.eclipse.jubula.client.ui.rcp_1.3.0.201210161256.jar:na]
at org.eclipse.jubula.client.ui.rcp.handlers.project.OpenProjectHandler$OpenProjectOperation.run(OpenProjectHandler.java:121) [org.eclipse.jubula.client.ui.rcp_1.3.0.201210161256.jar:na]
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121) [org.eclipse.jface_3.7.0.v20110928-1505.jar:na]
Re: Problems with starting first cheat sheet test.... [message #981452 is a reply to message #981218] Mon, 12 November 2012 12:28 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1193
Registered: July 2009
Senior Member
Hi Patrick,

For the log exceptions, there is a bug open at the moment. I don't think you need to worry about it for now.

When you start the tests, I have the feeling you're running into a usability problem I've seen before - are you just pressing the "start test suite" button, or are you selecting the test suite to start from the drop down menu? Unfortunately, the first time you start a test suite, you have to select it. After that, it's remembered.

Hope that helps!
Alex
Re: Problems with starting first cheat sheet test.... [message #982779 is a reply to message #981452] Tue, 13 November 2012 12:14 Go to previous message
Patrick R. is currently offline Patrick R.Friend
Messages: 10
Registered: July 2009
Junior Member
Thanks for the response. Smile
I figured the useabillity issue out by myself.
Previous Topic:How do I check whether a tree node is expanded?
Next Topic:check existence of a connection
Goto Forum:
  


Current Time: Mon Dec 22 07:21:59 GMT 2014

Powered by FUDForum. Page generated in 0.01724 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software