Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Gemini » [Solved]Gemini - is there a way to speed the startup?
[Solved]Gemini - is there a way to speed the startup? [message #975274] Wed, 07 November 2012 18:58 Go to next message
Scott Hull is currently offline Scott HullFriend
Messages: 32
Registered: July 2012
Member
Does anyone have any issues starting up their application with gemini and it increasing the startup time from a couple of seconds to over a minute? I have my application handle two EMFs which are instantiated only once each. I have turned off logging to help speed this along, but it does not help very much. Does anyone have any suggestions to speed this along? I would like to get it to the 20 seconds ballpark at the very least for a normal machine.

Thanks!

[Updated on: Tue, 20 November 2012 17:07]

Report message to a moderator

Re: Gemini - is there a way to speed the startup? [message #981600 is a reply to message #975274] Mon, 12 November 2012 14:49 Go to previous messageGo to next message
Michael Keith is currently offline Michael KeithFriend
Messages: 216
Registered: July 2009
Senior Member
Hi Scott,

I have not seen that issue occur but would be interested in learning more about what could be causing it. How many bundles are installed? Have you uninstalled the bundles that I asked you to not have installed (org.eclipse.persistence.jpa.equinox, org.eclipse.persistence.jpa.equinox.weaving, org.eclipse.persistence.jpa.osgi)? When you turn on debugging and logging where does the time get spent?

BTW, if you could identify the Gemini subproject you are asking a question about (e.g. Gemini JPA in this case) in the post title it would help. Thanks.

-Mike
Re: Gemini - is there a way to speed the startup? [message #985562 is a reply to message #981600] Thu, 15 November 2012 13:50 Go to previous message
Scott Hull is currently offline Scott HullFriend
Messages: 32
Registered: July 2012
Member
Mike,

Looks like this issue was related to our previous post about OSGI refresh bundles error. I believe we have obtained an efficient execution time of our product's startup procedure. Turning off the debug in the persistence.xml files and getting the right bundles configured and ordered (including removing the older, obsolete bundles you mentioned earlier) helped out tremendously. I will mark this solved in the next few days once I have confirmed this to work across multiple machines.

Thanks again!

[Updated on: Thu, 15 November 2012 13:51]

Report message to a moderator

Previous Topic:[SOLVED] Gemini JPA bundles refresh even with -DREFRESH_BUNDLES=false
Next Topic:Gemini JPA 1.1.0 released
Goto Forum:
  


Current Time: Sat Dec 20 16:43:16 GMT 2014

Powered by FUDForum. Page generated in 0.02750 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software