Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » EGit imported repositories are not connected to Git once added(see title)
EGit imported repositories are not connected to Git once added [message #973710] Tue, 06 November 2012 15:06 Go to next message
JD Wong is currently offline JD Wong
Messages: 7
Registered: November 2012
Junior Member
http://wiki.eclipse.org/EGit/User_Guide#Use_the_New_Projects_Wizard
From page:
Quote:
After completion of the "New Project" wizard, the "Import Projects from Git" wizard will resume and assist with sharing the projects you just created.


When I finish the new project wizard, nothing else appears. My files are imported but they are not connected to git. I don't want to Team > Share because that might create duplicates and I don't want to do that. How do I get EGit to work properly?

I'm using Eclipse Version: 3.7.2
Build id: I20110613-1736

EGit v1.3.0.201202151440-r

Thanks in advance!
Re: EGit imported repositories are not connected to Git once added [message #973849 is a reply to message #973710] Tue, 06 November 2012 17:18 Go to previous messageGo to next message
Christoph Keimel is currently offline Christoph Keimel
Messages: 371
Registered: December 2010
Location: Germany
Senior Member
I use Team > Share quite a lot after creating a new project in my workspace. What happens is that all the project files are moved (not copied) into the repository, so no duplicates ...
Re: EGit imported repositories are not connected to Git once added [message #973912 is a reply to message #973849] Tue, 06 November 2012 18:18 Go to previous messageGo to next message
JD Wong is currently offline JD Wong
Messages: 7
Registered: November 2012
Junior Member
Thanks for the reply Cristoph. I would do that if the files aren't already in the repository directory. I'm trying to clone an existing local repository with existing files, which I want to edit and commit in eclipse. The files are successfully imported from the repository into my workspace, but they are not connected to git. Right click > Team doesn't show any git options.
Re: EGit imported repositories are not connected to Git once added [message #974175 is a reply to message #973912] Tue, 06 November 2012 22:55 Go to previous message
Matthias Sohn is currently offline Matthias Sohn
Messages: 588
Registered: July 2009
Senior Member
Did you try a newer version ? Latest release is 2.1, you may install it from http://download.eclipse.org/egit/updates
Previous Topic:Does Egit support shallow clone yet?
Next Topic:Pushing, auth fail
Goto Forum:
  


Current Time: Fri Oct 24 15:36:15 GMT 2014

Powered by FUDForum. Page generated in 0.01615 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software