Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Profiler launch timeout
Profiler launch timeout [message #139514] Tue, 13 January 2009 17:13 Go to next message
PM is currently offline PM
Messages: 3
Registered: July 2009
Junior Member
Hi,
I have just installed the TPTP 4.5.1 bundle from tptp/home/downloads.
File : tptp.runtime.allInOne.win32.win32.x86-TPTP-4.5.1.zip

The profiler launch fails with an exception like :

org.eclipse.core.runtime.CoreException
A time-out occurred while attempting to launch the process
org.eclipse.core.runtime.CoreException: A time-out occurred while
attempting to launch the process at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.createCoreException(LauncherUtility.java:124)

I then created a simple main program and get the same error. This same
error occurs if I use the IAC or the external agent control (download :
agntctrl.win_ia32-TPTP-4.5.1.zip).

I have tried changing the profile settings (on the profile configuration
-> monitor tab). With some settings I get an array index out of bounds
exception (I will repeat the adjustments and give specifics if this
helps). However, its the thread analysis I need and that doesnt give the
out of bounds exception.

This is the stock installation with nothing updated. I did then run an
update but got a nothing to update message.

I have found this exact error in earlier posts (2007) and it has been
fixed.

I have tried this with both the bea jdk150_10 and suns 1.5.12 jre with the
same result.

I cannot profile anything. Should I use an older version of TPTP?

TIA

PM

Win XP SP2, Java : bea jdk150_10 or sun 1.5.12
Re: Profiler launch timeout [message #139527 is a reply to message #139514] Wed, 14 January 2009 15:28 Go to previous messageGo to next message
PM is currently offline PM
Messages: 3
Registered: July 2009
Junior Member
Just a further note; I have tried the development build,
tptp.runtime.allInOne.win32.win32.x86-TPTP-4.5.2-20081125091 0.zip which
gives exactly the same results (with a completely new workspace).

PM
Re: Profiler launch timeout [message #139561 is a reply to message #139527] Wed, 14 January 2009 19:18 Go to previous messageGo to next message
PM is currently offline PM
Messages: 3
Registered: July 2009
Junior Member
Finally; it runs ok on one Windows box but fails as described above on a
different box. Does anyone have any idea which particular feature of
windows might be getting in the way?

TIA PM
Re: Profiler launch timeout [message #139651 is a reply to message #139561] Thu, 22 January 2009 11:50 Go to previous message
Asaf Yaffe is currently offline Asaf Yaffe
Messages: 333
Registered: July 2009
Senior Member
PM wrote:
> Finally; it runs ok on one Windows box but fails as described above on a
> different box. Does anyone have any idea which particular feature of
> windows might be getting in the way?
>
> TIA PM
>

Perhaps the problem is related to a local firewall that prevents
connections to the TCPIP ports used by the Agent Controller? (10002 and
10006 if I am not mistaken).

My 2 cents...
Asaf


--
Asaf Yaffe
Eclipse TPTP Committer, JVMTI Profiler
Previous Topic:TPTP profiling; almost no profiling option
Next Topic:Error occurred during initialization of VM
Goto Forum:
  


Current Time: Tue Sep 02 23:48:13 GMT 2014

Powered by FUDForum. Page generated in 0.02313 seconds