Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Could not find agent library when I import the platform.ac.win_ia32
Could not find agent library when I import the platform.ac.win_ia32 [message #139164] Fri, 19 December 2008 06:18 Go to next message
Patrick Ouyang is currently offline Patrick OuyangFriend
Messages: 10
Registered: July 2009
Junior Member
Hi,

I imported the org.eclipse.tptp.platform.ac_win_ia32 plug-in as source
project, and launched an Eclipse Application with the configuration:
enable the source project in the workspace and disable the same in the
target platform (Others were all enabled).
Then I ran a profiling of thread analysis and got an error: "The JVMTI
agent org.eclipse.tptp.jvmti is not avaiable. Make sure that the
liabraries for the agent are avaible and that it is configured properly.".
At the same time the console of launched application showed: "Error
occurred during initialization of VM
Could not find agent library on the library path or in the local
directory: JPIBootLoader". And the console of my workbench showed timeout
exceptions.

Why this happened? How could I run successfully in this case?

The version of TPTP is 4.5.1. JDK is 1.5.
Re: Could not find agent library when I import the platform.ac.win_ia32 [message #139175 is a reply to message #139164] Fri, 19 December 2008 20:10 Go to previous message
Bing Xu is currently offline Bing XuFriend
Messages: 6
Registered: July 2009
Junior Member
Patrick, what are you trying to do? Just profile or you want to take a
look at the source code of IAC?

If all you want to do is to profile a application, you don't need to
import the IAC into your workbench.

Patrick Ouyang wrote:

> Hi,

> I imported the org.eclipse.tptp.platform.ac_win_ia32 plug-in as source
> project, and launched an Eclipse Application with the configuration:
> enable the source project in the workspace and disable the same in the
> target platform (Others were all enabled).
> Then I ran a profiling of thread analysis and got an error: "The JVMTI
> agent org.eclipse.tptp.jvmti is not avaiable. Make sure that the
> liabraries for the agent are avaible and that it is configured properly.".
> At the same time the console of launched application showed: "Error
> occurred during initialization of VM
> Could not find agent library on the library path or in the local
> directory: JPIBootLoader". And the console of my workbench showed timeout
> exceptions.

> Why this happened? How could I run successfully in this case?

> The version of TPTP is 4.5.1. JDK is 1.5.
Previous Topic:to determine volume of replicated data
Next Topic:How to get "throw" or "catch" event
Goto Forum:
  


Current Time: Thu Nov 27 22:33:17 GMT 2014

Powered by FUDForum. Page generated in 0.02227 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software