Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Visual Editor (VE) » JRE
JRE [message #139031] Mon, 16 July 2007 11:31 Go to next message
Eclipse UserFriend
Originally posted by: kristine.johansen.bahn.de

When downloading the latest version of the Visual Editor the following is
stated:
"JRE must be version 1.4.2 or greater for BeanInfo of SWT to work
correctly."

I suppose this applies to the design environment, i.e. the user working
with VE to design an SWT GUI needs to have at least JRE 1.4.2 for VE to
work correctly. Does it also apply to the runtime environment of the SWT
GUI created with VE?
Re: JRE [message #139043 is a reply to message #139031] Mon, 16 July 2007 16:41 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: richkulp.us.NO_SPAM.ibm.com

It applies to runtime environment too.

kjo wrote:
> When downloading the latest version of the Visual Editor the following
> is stated:
> "JRE must be version 1.4.2 or greater for BeanInfo of SWT to work
> correctly."
>
> I suppose this applies to the design environment, i.e. the user working
> with VE to design an SWT GUI needs to have at least JRE 1.4.2 for VE to
> work correctly. Does it also apply to the runtime environment of the SWT
> GUI created with VE?
>
Re: JRE [message #139066 is a reply to message #139043] Tue, 17 July 2007 10:59 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: kristine.johansen.bahn.de

Thanks for your reply!
Do you know under which circumstances BeanInfo is used in the generated
SWT code, so that it will not work with a JRE < 1.4.2?
Re: JRE [message #139105 is a reply to message #139066] Tue, 17 July 2007 15:46 Go to previous message
Eclipse UserFriend
Originally posted by: richkulp.us.NO_SPAM.ibm.com

It is not used in the actual generated code. But it is used by the
remote vm that is used to emulate/execute pieces of your code to display
the results in the VE's editor pane.

kjo wrote:
> Thanks for your reply!
> Do you know under which circumstances BeanInfo is used in the generated
> SWT code, so that it will not work with a JRE < 1.4.2?
>
Re: JRE [message #616275 is a reply to message #139031] Mon, 16 July 2007 16:41 Go to previous message
Eclipse UserFriend
Originally posted by: richkulp.us.NO_SPAM.ibm.com

It applies to runtime environment too.

kjo wrote:
> When downloading the latest version of the Visual Editor the following
> is stated:
> "JRE must be version 1.4.2 or greater for BeanInfo of SWT to work
> correctly."
>
> I suppose this applies to the design environment, i.e. the user working
> with VE to design an SWT GUI needs to have at least JRE 1.4.2 for VE to
> work correctly. Does it also apply to the runtime environment of the SWT
> GUI created with VE?
>
Re: JRE [message #616277 is a reply to message #139043] Tue, 17 July 2007 10:59 Go to previous message
Eclipse UserFriend
Originally posted by: kristine.johansen.bahn.de

Thanks for your reply!
Do you know under which circumstances BeanInfo is used in the generated
SWT code, so that it will not work with a JRE < 1.4.2?
Re: JRE [message #616282 is a reply to message #139066] Tue, 17 July 2007 15:46 Go to previous message
Eclipse UserFriend
Originally posted by: richkulp.us.NO_SPAM.ibm.com

It is not used in the actual generated code. But it is used by the
remote vm that is used to emulate/execute pieces of your code to display
the results in the VE's editor pane.

kjo wrote:
> Thanks for your reply!
> Do you know under which circumstances BeanInfo is used in the generated
> SWT code, so that it will not work with a JRE < 1.4.2?
>
Previous Topic:Visual design with eclipse 3.3
Next Topic:Custom property editor for colors
Goto Forum:
  


Current Time: Fri Dec 19 12:14:55 GMT 2014

Powered by FUDForum. Page generated in 0.01770 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software