Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Use workspace of eclipse 4.2 from eclipse 4.3
Use workspace of eclipse 4.2 from eclipse 4.3 [message #970141] Sat, 03 November 2012 21:50 Go to next message
Jim Jone is currently offline Jim Jone
Messages: 11
Registered: October 2012
Junior Member
I have created an Eclipse 4 application using Eclipse 4.2.
Works ok.
I encountered a bug for which I was recommended to use Eclipse4.3
I downloaded Eclipse4.3 and opened my workspace (created and worked in 4.2).
When I launch my product it does not work. Error says that it can not resolve almost any of my bundles.
I don't get this. Isn't this case supposed to work out of the box?
Re: Use workspace of eclipse 4.2 from eclipse 4.3 [message #970142 is a reply to message #970141] Sat, 03 November 2012 21:53 Go to previous messageGo to next message
Sopot Cela is currently offline Sopot Cela
Messages: 597
Registered: December 2010
Senior Member

What does the error log say? It's most likely the javax.xml missing dependency bug which is already fixed for when creating new projects.
Re: Use workspace of eclipse 4.2 from eclipse 4.3 [message #970172 is a reply to message #970142] Sat, 03 November 2012 22:25 Go to previous messageGo to next message
Jim Jone is currently offline Jim Jone
Messages: 11
Registered: October 2012
Junior Member
If I uncheck the "Validate Plugins Automatically Prior to Launching" the error log is:

!SESSION Sun Nov 04 00:24:08 EET 2012 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2012-11-04 00:24:08.575
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

Re: Use workspace of eclipse 4.2 from eclipse 4.3 [message #970177 is a reply to message #970172] Sat, 03 November 2012 22:30 Go to previous messageGo to next message
Jim Jone is currently offline Jim Jone
Messages: 11
Registered: October 2012
Junior Member
Also when I go back to Eclipse 4.2 to load the workspace the UI is in bad shape:

index.php/fa/12185/0/

I have to restart 4.2 to work.
I also noticed that I can see the error log I opened in eclipse 4.3 from 4.2.
But how is that possible?

[Updated on: Sat, 03 November 2012 22:30]

Report message to a moderator

Re: Use workspace of eclipse 4.2 from eclipse 4.3 [message #972777 is a reply to message #970141] Mon, 05 November 2012 22:18 Go to previous messageGo to next message
Wim Jongman is currently offline Wim Jongman
Messages: 278
Registered: July 2009
Senior Member

Hi,

Did you try restarting with -clean or -clearpersistedstate

It is likely that this new version does not include all the ui from your 4.2 installation.

Regards,

Wim
Re: Use workspace of eclipse 4.2 from eclipse 4.3 [message #984173 is a reply to message #972777] Wed, 14 November 2012 13:22 Go to previous message
Dmitry A. is currently offline Dmitry A.
Messages: 6
Registered: November 2012
Junior Member
Actually i have a similar problem. For Eclipse 4.3 i use this links:
http://download.eclipse.org/releases/kepler (EMF);
http://download.eclipse.org/e4/updates/0.12-I-builds/ (e4)
After installing all the components i try to use my Eclipse 4.2 workspace with Eclipse 4.3. And my app (one PartStack and 2 parts) works strange. My @PostCondtruct methods don't work. I see my part without anything. When i switch between my parts i have error in console:
org.eclipse.e4.core.di.InjectionException: java.lang.NullPointerException
Caused by: java.lang.NullPointerException
at s.d.manager.views.SettingsView.setFocus(SettingsView.java:329)
But my methods marked as @Focus are empty. May be someone have problem like that? My 4.2 workspace works fine with Eclipse 4.2.1.
Previous Topic:How to hide Minimize/Maximize Buttons from PartStack?
Next Topic:No MBasicPackage Interface
Goto Forum:
  


Current Time: Thu Sep 18 03:43:23 GMT 2014

Powered by FUDForum. Page generated in 0.07790 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software