Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Behavior view tab is blank.
Behavior view tab is blank. [message #138262] Mon, 17 November 2008 16:49 Go to next message
matt murphy is currently offline matt murphy
Messages: 21
Registered: July 2009
Junior Member
Hi ,

I'm unable to view the Behavior tab on the Automated gui suite using Tptp
4.5.1 for a given workspace. When I use an older version on the same
workspace I see the tab without a problem. I'm currently working around this
issue by using an older version to add the test case to the suite after
recording in the newer version.

matt
Re: Behavior view tab is blank. [message #138301 is a reply to message #138262] Tue, 18 November 2008 07:26 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Matt,
Are you using the same instance of Eclipse in both cases? Any errors in
the .log file?

Paul
"matt murphy" <murphy@coherentlogix.com> wrote in message
news:gfsotf$m0m$1@build.eclipse.org...
>
> Hi ,
>
> I'm unable to view the Behavior tab on the Automated gui suite using Tptp
> 4.5.1 for a given workspace. When I use an older version on the same
> workspace I see the tab without a problem. I'm currently working around
> this issue by using an older version to add the test case to the suite
> after recording in the newer version.
>
> matt
>
>
Re: Behavior view tab is blank. [message #138377 is a reply to message #138301] Tue, 18 November 2008 19:35 Go to previous messageGo to next message
matt murphy is currently offline matt murphy
Messages: 21
Registered: July 2009
Junior Member
Hi Paul,

below is the message from the error log. The versions of eclipse the
application is based on are different.

matt



eclipse.buildId=unknown
java.version=1.6.0_07
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86


Error
Tue Nov 18 16:14:33 PST 2008
Execution framework configuration file is invalid. This could be caused by
the execution plugin checked out in your workspace


"Paul Slauenwhite" <paules@ca.ibm.com> wrote in message
news:gfuc9q$jl8$1@build.eclipse.org...
> Hi Matt,
> Are you using the same instance of Eclipse in both cases? Any errors
> in the .log file?
>
> Paul
> "matt murphy" <murphy@coherentlogix.com> wrote in message
> news:gfsotf$m0m$1@build.eclipse.org...
>>
>> Hi ,
>>
>> I'm unable to view the Behavior tab on the Automated gui suite using
>> Tptp 4.5.1 for a given workspace. When I use an older version on the same
>> workspace I see the tab without a problem. I'm currently working around
>> this issue by using an older version to add the test case to the suite
>> after recording in the newer version.
>>
>> matt
>>
>>
>
>
Re: Behavior view tab is blank. [message #138464 is a reply to message #138377] Wed, 19 November 2008 07:08 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Matt,
This error message does not indicate anything wrong with the test suite
editor. However, make sure you do not have any TPTP Test plug-ins in your
workspace.

Your install is probably corrupt. Can you try reinstalling the TPTP
all-in-one driver, with a fresh workspace?

Paul
"matt murphy" <murphy@coherentlogix.com> wrote in message
news:gfvn0h$mh5$1@build.eclipse.org...
> Hi Paul,
>
> below is the message from the error log. The versions of eclipse the
> application is based on are different.
>
> matt
>
>
>
> eclipse.buildId=unknown
> java.version=1.6.0_07
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
> Command-line arguments: -os win32 -ws win32 -arch x86
>
>
> Error
> Tue Nov 18 16:14:33 PST 2008
> Execution framework configuration file is invalid. This could be caused
> by the execution plugin checked out in your workspace
>
>
> "Paul Slauenwhite" <paules@ca.ibm.com> wrote in message
> news:gfuc9q$jl8$1@build.eclipse.org...
>> Hi Matt,
>> Are you using the same instance of Eclipse in both cases? Any errors
>> in the .log file?
>>
>> Paul
>> "matt murphy" <murphy@coherentlogix.com> wrote in message
>> news:gfsotf$m0m$1@build.eclipse.org...
>>>
>>> Hi ,
>>>
>>> I'm unable to view the Behavior tab on the Automated gui suite using
>>> Tptp 4.5.1 for a given workspace. When I use an older version on the
>>> same workspace I see the tab without a problem. I'm currently working
>>> around this issue by using an older version to add the test case to the
>>> suite after recording in the newer version.
>>>
>>> matt
>>>
>>>
>>
>>
>
>
Re: Behavior view tab is blank. [message #138856 is a reply to message #138262] Thu, 04 December 2008 12:41 Go to previous messageGo to next message
Graeme Vetterlein is currently offline Graeme Vetterlein
Messages: 6
Registered: July 2009
Junior Member
I am also see this behavior. I am following the tutorial here:

http://www.eclipse.org/tptp/test/documents/userguides/auto-g ui-viewlet/auto-gui-viewlet_viewlet_swf.html

When I get to the point where I selecting the behavior tab I simply see a
bank screen . The log contains the following error:

java.lang.NoSuchFieldError:
org/eclipse/hyades/test/tools/ui/internal/resources/ToolsUiP luginResourceBundle.BEHAVIOR_ADD_CHILD
at
org.eclipse.tptp.test.auto.gui.internal.editor.AutoGUIBehavi orForm$ExtendedBehaviorTree.adjustButtonLabels(AutoGUIBehavi orForm.java:896)
at
org.eclipse.hyades.test.ui.internal.editor.form.util.EObject Tree. <init>(EObjectTree.java:142)
at
org.eclipse.hyades.test.tools.ui.common.internal.editor.Beha viorAccessories$ExtendedObjectTree. <init>(BehaviorAccessories.java:283)
at
org.eclipse.tptp.test.auto.gui.internal.editor.AutoGUIBehavi orForm$ExtendedBehaviorTree. <init>(AutoGUIBehaviorForm.java:885)
at
org.eclipse.tptp.test.auto.gui.internal.editor.AutoGUIBehavi orForm.createBehaviorSection(AutoGUIBehaviorForm.java:825)
at
org.eclipse.hyades.test.tools.ui.common.internal.editor.Beha viorEclipseForm.createLeftColumnControls(BehaviorEclipseForm .java:274)
at
org.eclipse.hyades.test.ui.internal.editor.form.util.EditorE clipseForm.createFormContent(EditorEclipseForm.java:141)
at
org.eclipse.hyades.test.tools.ui.common.internal.editor.Beha viorEclipseForm.createFormContent(BehaviorEclipseForm.java:1 36)
at org.eclipse.ui.forms.editor.FormPage$1.run(FormPage.java:151 )
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:70)
at
org.eclipse.ui.forms.editor.FormPage.createPartControl(FormP age.java:149)
at org.eclipse.ui.forms.editor.FormEditor.pageChange(FormEditor .java:488)
at
org.eclipse.hyades.ui.internal.editor.HyadesEditorPart.pageC hange(HyadesEditorPart.java:161)
at
org.eclipse.ui.part.MultiPageEditorPart$2.widgetSelected(Mul tiPageEditorPart.java:266)
at
org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListe ner.java:228)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1158)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1182)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1167)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1 007)
at org.eclipse.swt.custom.CTabFolder.setSelection(CTabFolder.ja va:3242)
at org.eclipse.swt.custom.CTabFolder.onMouse(CTabFolder.java:20 17)
at org.eclipse.swt.custom.CTabFolder$1.handleEvent(CTabFolder.j ava:320)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1158)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3401)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3033)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2382)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:21 98)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
at
org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:288)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:488)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at
org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:113)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:193)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:386)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:45)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:37)
at java.lang.reflect.Method.invoke(Method.java:599)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

I have just today downloaded an installed all the components neede for
this.
The files I have used are:


Dec 4 14:49 org.eclipse.tptp.test.auto-TPTP-4.5.0.zip
Dec 4 14:04 tptp.runtime.allInOne.linux.gtk.x86-TPTP-4.5.1.zip
Dec 4 11:55 eclipse-SDK-3.4.1-linux-gtk.tar.gz
Re: Behavior view tab is blank. [message #138880 is a reply to message #138856] Fri, 05 December 2008 06:43 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Graeme,
I tested the TPTP 4.5.1 GA build on SLES 10 (IBM Java 1.5) with success.
Please use the AGR download from the TPTP 4.5.1 GA build and following the
installation instructions:

http://www.eclipse.org/tptp/test/documents/gettingstarted/Au tomated_GUI_Recorder_Getting_Started.html#2.0

Note, you do not need the Eclipse SDK when you install the TPTP
all-in-one driver, since it contains the Eclipse SDK.

Paul
"Graeme Vetterlein" <graeme.eclipse@vetterlein.com> wrote in message
news:374513466d6da5319307681b6c92ac9b$1@www.eclipse.org...
>I am also see this behavior. I am following the tutorial here:
>
> http://www.eclipse.org/tptp/test/documents/userguides/auto-g ui-viewlet/auto-gui-viewlet_viewlet_swf.html
>
> When I get to the point where I selecting the behavior tab I simply see a
> bank screen . The log contains the following error:
>
> java.lang.NoSuchFieldError:
> org/eclipse/hyades/test/tools/ui/internal/resources/ToolsUiP luginResourceBundle.BEHAVIOR_ADD_CHILD
> at
> org.eclipse.tptp.test.auto.gui.internal.editor.AutoGUIBehavi orForm$ExtendedBehaviorTree.adjustButtonLabels(AutoGUIBehavi orForm.java:896)
> at
> org.eclipse.hyades.test.ui.internal.editor.form.util.EObject Tree. <init>(EObjectTree.java:142)
> at
> org.eclipse.hyades.test.tools.ui.common.internal.editor.Beha viorAccessories$ExtendedObjectTree. <init>(BehaviorAccessories.java:283)
> at
> org.eclipse.tptp.test.auto.gui.internal.editor.AutoGUIBehavi orForm$ExtendedBehaviorTree. <init>(AutoGUIBehaviorForm.java:885)
> at
> org.eclipse.tptp.test.auto.gui.internal.editor.AutoGUIBehavi orForm.createBehaviorSection(AutoGUIBehaviorForm.java:825)
> at
> org.eclipse.hyades.test.tools.ui.common.internal.editor.Beha viorEclipseForm.createLeftColumnControls(BehaviorEclipseForm .java:274)
> at
> org.eclipse.hyades.test.ui.internal.editor.form.util.EditorE clipseForm.createFormContent(EditorEclipseForm.java:141)
> at
> org.eclipse.hyades.test.tools.ui.common.internal.editor.Beha viorEclipseForm.createFormContent(BehaviorEclipseForm.java:1 36)
> at org.eclipse.ui.forms.editor.FormPage$1.run(FormPage.java:151 )
> at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:70)
> at
> org.eclipse.ui.forms.editor.FormPage.createPartControl(FormP age.java:149)
> at org.eclipse.ui.forms.editor.FormEditor.pageChange(FormEditor .java:488)
> at
> org.eclipse.hyades.ui.internal.editor.HyadesEditorPart.pageC hange(HyadesEditorPart.java:161)
> at
> org.eclipse.ui.part.MultiPageEditorPart$2.widgetSelected(Mul tiPageEditorPart.java:266)
> at
> org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListe ner.java:228)
> at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :84)
> at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1158)
> at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1182)
> at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1167)
> at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1 007)
> at org.eclipse.swt.custom.CTabFolder.setSelection(CTabFolder.ja va:3242)
> at org.eclipse.swt.custom.CTabFolder.onMouse(CTabFolder.java:20 17)
> at org.eclipse.swt.custom.CTabFolder$1.handleEvent(CTabFolder.j ava:320)
> at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :84)
> at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1158)
> at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3401)
> at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3033)
> at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2382)
> at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
> at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:21 98)
> at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
> at
> org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:288)
> at
> org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:488)
> at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
> at
> org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:113)
> at
> org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:193)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:386)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:45)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:37)
> at java.lang.reflect.Method.invoke(Method.java:599)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
>
> I have just today downloaded an installed all the components neede for
> this.
> The files I have used are:
>
>
> Dec 4 14:49 org.eclipse.tptp.test.auto-TPTP-4.5.0.zip
> Dec 4 14:04 tptp.runtime.allInOne.linux.gtk.x86-TPTP-4.5.1.zip
> Dec 4 11:55 eclipse-SDK-3.4.1-linux-gtk.tar.gz
>
>
Re: Behavior view tab is blank. [message #138976 is a reply to message #138880] Mon, 08 December 2008 13:14 Go to previous messageGo to next message
Graeme Vetterlein is currently offline Graeme Vetterlein
Messages: 6
Registered: July 2009
Junior Member
Thanks for that Paul.

When I returned to this the day after I noticed the doc
(http://www.eclipse.org/tptp/home/downloads/) had changed from:

http://www.eclipse.org/downloads/download.php?file=/tptp/4.5 .1/TPTP-4.5.1/org.eclipse.tptp.test.auto-TPTP-4.5.0.zip

to

http://www.eclipse.org/downloads/download.php?file=/tptp/4.5 .1/TPTP-4.5.1/org.eclipse.tptp.test.auto-TPTP-4.5.1.zip

So I Installed in sequence:

eclipse: eclipse-SDK-3.4.1-linux-gtk.tar.gz
The ALL-in-One package
http://www.eclipse.org/downloads/download.php?file=/tptp/4.5 .1/TPTP-4.5.1/tptp.runtime.allInOne.win32.win32.x86-TPTP-4.5 .1.zip)
The Automated GUI Recorder :
http://www.eclipse.org/downloads/download.php?file=/tptp/4.5 .1/TPTP-4.5.1/org.eclipse.tptp.test.auto-TPTP-4.5.1.zip

This got me past the 'blank tab' problem (guess it was a 3.4.0/3.4.1
mismatch)


So now I got onto a new problem with the 'agent controller' ... which
I've worked around (and posted here) so now I'm onto :

WAT4039E The Test Execution Harness reported the following problems:
Failed to retrieve the context that should be used to run the test cases in
Re: Behavior view tab is blank. [message #138988 is a reply to message #138976] Tue, 09 December 2008 08:49 Go to previous message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Graeme,
I am not sure where the AGR download link was changed, but we recommend
installing the same level of TPTP components (e.g. TPTP 4.5.1) on the
suggest dependency levels (e.g. Eclipse 3.4.1).

I will read/reply to you other post on the Agent Controller.

As for your new problem, the execution harness cannot find the current
context (e.g. Eclipse location) specified in the Configuration section of
the Overview tab in the AGR test editor. Do you have the current workbench
set as the context?

Paul
"Graeme Vetterlein" <graeme.eclipse@vetterlein.com> wrote in message
news:62bac7d144d6c57b96969809b68bcafd$1@www.eclipse.org...
> Thanks for that Paul.
>
> When I returned to this the day after I noticed the doc
> (http://www.eclipse.org/tptp/home/downloads/) had changed from:
>
> http://www.eclipse.org/downloads/download.php?file=/tptp/4.5 .1/TPTP-4.5.1/org.eclipse.tptp.test.auto-TPTP-4.5.0.zip
>
> to
>
> http://www.eclipse.org/downloads/download.php?file=/tptp/4.5 .1/TPTP-4.5.1/org.eclipse.tptp.test.auto-TPTP-4.5.1.zip
>
> So I Installed in sequence:
>
> eclipse: eclipse-SDK-3.4.1-linux-gtk.tar.gz
> The ALL-in-One package
> http://www.eclipse.org/downloads/download.php?file=/tptp/4.5 .1/TPTP-4.5.1/tptp.runtime.allInOne.win32.win32.x86-TPTP-4.5 .1.zip)
> The Automated GUI Recorder :
> http://www.eclipse.org/downloads/download.php?file=/tptp/4.5 .1/TPTP-4.5.1/org.eclipse.tptp.test.auto-TPTP-4.5.1.zip
>
> This got me past the 'blank tab' problem (guess it was a 3.4.0/3.4.1
> mismatch)
>
>
> So now I got onto a new problem with the 'agent controller' ... which
> I've worked around (and posted here) so now I'm onto :
>
> WAT4039E The Test Execution Harness reported the following problems:
> Failed to retrieve the context that should be used to run the test cases
> in
>
>
>
>
>
>
Previous Topic:Rrecording of CellEditor Value
Next Topic:iwat0284e iwat4039e linux unable to connect to integrated agent controller
Goto Forum:
  


Current Time: Sat Aug 23 03:30:00 EDT 2014

Powered by FUDForum. Page generated in 0.07603 seconds