Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » JPA Project with EclipseLink 2.4.1 Error-Msg
JPA Project with EclipseLink 2.4.1 Error-Msg [message #968223] Fri, 02 November 2012 09:49 Go to next message
Tim Taylor is currently offline Tim TaylorFriend
Messages: 1
Registered: November 2012
Junior Member

i want to create an JPA Project in Eclipse (Juno) with EclipseLink 2.4.1.
But when i on step "JPA Facet" and select EclipseLink 2.4.x and my libs (eclipselink.jar and javax.persistence_2.0.4.v201112161009.jar) i get an error message
Platform: EclipseLink 2.4.x
JPA Implementation: User Library

The class 'org.hibernate.SessionFactory' is required to be in the selected libraries.

Thx Tim
Re: JPA Project with EclipseLink 2.4.1 Error-Msg [message #968493 is a reply to message #968223] Fri, 02 November 2012 13:55 Go to previous message
Chris Delahunt is currently offline Chris DelahuntFriend
Messages: 1109
Registered: July 2009
Senior Member
This seems due to an issue with a prior installation of Hibernate Tools in Eclipse as described here:

Previous Topic:The attribute type must implement the Serializable interface.
Next Topic:Map Mapping fails if there are duplicate values
Goto Forum:

Current Time: Tue Dec 01 09:41:28 GMT 2015

Powered by FUDForum. Page generated in 1.77677 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software