Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » Use J2ME with eclipse
Use J2ME with eclipse [message #12670] Tue, 14 February 2006 12:25 Go to next message
Eclipse User
Originally posted by: milnfalcon4163.yahoo.com

How I use J2ME with eclipse to develop things for moble phone or
blackberry? I have tried the mtj eclipse home page and I did not any
information on J2ME eclipse plug-ins?
Re: Use J2ME with eclipse [message #12691 is a reply to message #12670] Thu, 16 February 2006 16:12 Go to previous messageGo to next message
Eclipse User
Originally posted by: milnfalcon4163.yahoo.com

Can anyone answer my question?
Re: Use J2ME with eclipse [message #12711 is a reply to message #12691] Fri, 17 February 2006 07:52 Go to previous messageGo to next message
Eclipse User
Originally posted by: milnfalcon4163.yahoo.com

Since no one answered, I guess netbeans with moble pack is the answer. It
is a shame that eclipse does not anything on moble phones or blackberries.
Re: Use J2ME with eclipse [message #12730 is a reply to message #12711] Fri, 17 February 2006 08:35 Go to previous messageGo to next message
Eclipse User
Originally posted by: Michael.Koch.enough.de

Richard wrote:

> Since no one answered, I guess netbeans with moble pack is the answer. It
> is a shame that eclipse does not anything on moble phones or blackberries.

I wonder why don't used Google ....

http://www.google.com/search?q=Eclipse+j2me


1st hit is already very good.


Michael
Re: Use J2ME with eclipse [message #12751 is a reply to message #12711] Fri, 17 February 2006 18:16 Go to previous messageGo to next message
Eclipse User
Originally posted by: breh.atlas_dot._cz

Richard wrote:
> Since no one answered, I guess netbeans with moble pack is the answer.
> It is a shame that eclipse does not anything on moble phones or
> blackberries.
>

Well, what is wrong with NetBeans anyway? Personally I use Netbeans with
Mobility Pack for all MIDP projects (and I start to use it also for J2EE
projects, especially those doing communication with mobile phones) and
Eclipse for the rest. But with the version 5.0 I'm thinking about moving
the whole development to Netbeans (can I post such a thing on an Eclipse
newsgroup ? :-) ) - I think it is currently better IDE than Eclipse ...
It is definitely worth a try.

Martin
Re: Use J2ME with eclipse [message #12772 is a reply to message #12751] Fri, 17 February 2006 19:49 Go to previous messageGo to next message
Eclipse User
Originally posted by: milnfalcon4163.yahoo.com

First of all, I am very much surprised the eclipse foundation lags in
support of moble technology. I should not have to google these things.
They should have these plug-in links on mtj home page.

Secondly, Mentioning the competition like netbeans some times is healthly.
It help the foundation to keep on their toes and strive to do better. Or
otherwise, lose to their competition.

Finally, Thanks for the advise and the googled me plug-ins.
Re: Use J2ME with eclipse [message #12791 is a reply to message #12670] Sat, 18 February 2006 03:55 Go to previous messageGo to next message
Eclipse User
Originally posted by: user.domain.invalid

Hi Richard!

The MTJ project doesn't have any public milestore downloads yet.
Currently there is quite small team building a mobility features enabled
IDE. The IDE will use the Eclipse JDT as the base editor.
We do have plans to enable support to large group of J2ME mobile vendor
devices. There are plans to enable features, which manage the device
fragmentation, e.g. with preprocessing.
Current project plan is that we should have a public milestone available
at the end of March. And the 1st release would be at the end of June
(with the Eclipse 3.2).

So, stay tuned.

-Arto

Richard kirjoitti:
> How I use J2ME with eclipse to develop things for moble phone or
> blackberry? I have tried the mtj eclipse home page and I did not any
> information on J2ME eclipse plug-ins?
>
Re: Use J2ME with eclipse [message #12807 is a reply to message #12791] Sat, 18 February 2006 11:32 Go to previous messageGo to next message
Eclipse User
Originally posted by: milnfalcon4163.yahoo.com

Thanks. I will be watching for that.
Re: Use J2ME with eclipse [message #12826 is a reply to message #12670] Thu, 23 February 2006 02:37 Go to previous message
Eclipse User
Originally posted by: simon.bretin.anyware-tech.com

Hello richard,

I think the good answer for that is EclipseME (http://www.eclipseme.org)
They provide a very good feature set, for working on various J2ME platforms.

Simon.

Richard wrote:
> How I use J2ME with eclipse to develop things for moble phone or
> blackberry? I have tried the mtj eclipse home page and I did not any
> information on J2ME eclipse plug-ins?
>
Re: Use J2ME with eclipse [message #563863 is a reply to message #12670] Thu, 16 February 2006 16:12 Go to previous message
Richard is currently offline Richard
Messages: 49
Registered: July 2009
Member
Can anyone answer my question?
Re: Use J2ME with eclipse [message #563888 is a reply to message #12691] Fri, 17 February 2006 07:52 Go to previous message
Richard is currently offline Richard
Messages: 49
Registered: July 2009
Member
Since no one answered, I guess netbeans with moble pack is the answer. It
is a shame that eclipse does not anything on moble phones or blackberries.
Re: Use J2ME with eclipse [message #563938 is a reply to message #12711] Fri, 17 February 2006 08:35 Go to previous message
Michael Koch is currently offline Michael Koch
Messages: 2
Registered: July 2009
Junior Member
Richard wrote:

> Since no one answered, I guess netbeans with moble pack is the answer. It
> is a shame that eclipse does not anything on moble phones or blackberries.

I wonder why don't used Google ....

http://www.google.com/search?q=Eclipse+j2me


1st hit is already very good.


Michael
Re: Use J2ME with eclipse [message #563968 is a reply to message #12711] Fri, 17 February 2006 18:16 Go to previous message
Eclipse User
Originally posted by: breh.atlas_dot._cz

Richard wrote:
> Since no one answered, I guess netbeans with moble pack is the answer.
> It is a shame that eclipse does not anything on moble phones or
> blackberries.
>

Well, what is wrong with NetBeans anyway? Personally I use Netbeans with
Mobility Pack for all MIDP projects (and I start to use it also for J2EE
projects, especially those doing communication with mobile phones) and
Eclipse for the rest. But with the version 5.0 I'm thinking about moving
the whole development to Netbeans (can I post such a thing on an Eclipse
newsgroup ? :-) ) - I think it is currently better IDE than Eclipse ...
It is definitely worth a try.

Martin
Re: Use J2ME with eclipse [message #563990 is a reply to message #12751] Fri, 17 February 2006 19:49 Go to previous message
Richard is currently offline Richard
Messages: 49
Registered: July 2009
Member
First of all, I am very much surprised the eclipse foundation lags in
support of moble technology. I should not have to google these things.
They should have these plug-in links on mtj home page.

Secondly, Mentioning the competition like netbeans some times is healthly.
It help the foundation to keep on their toes and strive to do better. Or
otherwise, lose to their competition.

Finally, Thanks for the advise and the googled me plug-ins.
Re: Use J2ME with eclipse [message #564023 is a reply to message #12670] Sat, 18 February 2006 03:55 Go to previous message
Arto Laurila is currently offline Arto Laurila
Messages: 32
Registered: July 2009
Member
Hi Richard!

The MTJ project doesn't have any public milestore downloads yet.
Currently there is quite small team building a mobility features enabled
IDE. The IDE will use the Eclipse JDT as the base editor.
We do have plans to enable support to large group of J2ME mobile vendor
devices. There are plans to enable features, which manage the device
fragmentation, e.g. with preprocessing.
Current project plan is that we should have a public milestone available
at the end of March. And the 1st release would be at the end of June
(with the Eclipse 3.2).

So, stay tuned.

-Arto

Richard kirjoitti:
> How I use J2ME with eclipse to develop things for moble phone or
> blackberry? I have tried the mtj eclipse home page and I did not any
> information on J2ME eclipse plug-ins?
>
Re: Use J2ME with eclipse [message #564047 is a reply to message #12791] Sat, 18 February 2006 11:32 Go to previous message
Richard is currently offline Richard
Messages: 49
Registered: July 2009
Member
Thanks. I will be watching for that.
Re: Use J2ME with eclipse [message #564069 is a reply to message #12670] Thu, 23 February 2006 02:37 Go to previous message
Eclipse User
Originally posted by: simon.bretin.anyware-tech.com

Hello richard,

I think the good answer for that is EclipseME (http://www.eclipseme.org)
They provide a very good feature set, for working on various J2ME platforms.

Simon.

Richard wrote:
> How I use J2ME with eclipse to develop things for moble phone or
> blackberry? I have tried the mtj eclipse home page and I did not any
> information on J2ME eclipse plug-ins?
>
Previous Topic:Use J2ME with eclipse
Next Topic:Re: Re: performance tools
Goto Forum:
  


Current Time: Wed Aug 20 12:42:31 EDT 2014

Powered by FUDForum. Page generated in 0.02264 seconds