Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Xbase and changed package names ?
icon4.gif  Xbase and changed package names ? [message #967568] Thu, 01 November 2012 21:38 Go to next message
Cristiano Gaviao is currently offline Cristiano GaviaoFriend
Messages: 253
Registered: July 2009
Senior Member
Hi,

I'm using Xbase in a DSL. It is working properly until today when I notice a lot of empty packages in the src-gen folder.

It seems that the old packages is not being removed after I changed a package name.

Could someone tell me if is this a bug or am I missing something ?

thanks

Cristiano
Re: Xbase and changed package names ? [message #967593 is a reply to message #967568] Thu, 01 November 2012 21:57 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 26285
Registered: July 2009
Senior Member
Cristiano,

The generator only removes files. Folders are created on demand as
needed to contain the generated files, by they're never deleted. I
suppose one might want it to delete empty folders as a final pass when
deleting files that are no longer generated...


On 01/11/2012 10:38 PM, Cristiano Gaviao wrote:
> Hi,
>
> I'm using Xbase in a DSL. It is working properly until today when I
> notice a lot of empty packages in the src-gen folder.
>
> It seems that the old packages is not being removed after I changed a
> package name.
>
> Could someone tell me if is this a bug or am I missing something ?
>
> thanks
>
> Cristiano
Re: Xbase and changed package names ? [message #967630 is a reply to message #967568] Thu, 01 November 2012 22:36 Go to previous message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 2961
Registered: July 2009
Senior Member
Am 01.11.12 22:38, schrieb Cristiano Gaviao:
> Hi,
>
> I'm using Xbase in a DSL. It is working properly until today when I
> notice a lot of empty packages in the src-gen folder.
>
> It seems that the old packages is not being removed after I changed a
> package name.
>
> Could someone tell me if is this a bug or am I missing something ?
>
> thanks
>
> Cristiano

Please file a ticket.

Thanks,
Sebastian
--
Looking for professional support for Xtext, Xtend or Eclipse Modeling?
Go visit: http://xtext.itemis.com
Previous Topic:newLineifNotEmpty on Generator
Next Topic:New to Xtext Grammar help
Goto Forum:
  


Current Time: Sun Dec 21 02:43:57 GMT 2014

Powered by FUDForum. Page generated in 0.02320 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software