Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Eclipse RCP update from indigo-SR2 to juno-SR1
Eclipse RCP update from indigo-SR2 to juno-SR1 [message #967271] Thu, 01 November 2012 16:33 Go to next message
Julia Kurde is currently offline Julia KurdeFriend
Messages: 66
Registered: November 2011
Location: Berlin, Germany
Member
To be honest, I've just very naively updated my Eclipse from Indigo to Juno, not beeing aware of all the changes...

Now, after some browsing the WWW I'm qute happy that the amount of problems in my case is very well defined. There are only two things left and our old RCP is ready for Eclipse 4:

1) How to remove the quick access item from the CoolBar?
2) I can't open Windows Meta Files (WMF) anymore.

For Problem (1) I solved this for the Eclipse workbench by editing the css file, but the RCP application does not have any. Setting the corresponding property "applicationCSS" in the xml file has no effect.

Problem (2) I already posted in the SWT forum
http://www.eclipse.org/forums/index.php/t/422202/
but that was the wrong place, I guess.

Thanks for your help!
Re: Eclipse RCP update from indigo-SR2 to juno-SR1 [message #967327 is a reply to message #967271] Thu, 01 November 2012 17:34 Go to previous messageGo to next message
Lars Vogel is currently offline Lars VogelFriend
Messages: 1049
Registered: July 2009
Senior Member

Hi,

See Eclipse 4 CSS Styling for how to correctly define your CSS and set the visible attribute for #SearchField to invisible. See Brians Blogpost for details on the visible attribute.

Best regards, Lars
Re: Eclipse RCP update from indigo-SR2 to juno-SR1 [message #967389 is a reply to message #967327] Thu, 01 November 2012 18:30 Go to previous messageGo to next message
Julia Kurde is currently offline Julia KurdeFriend
Messages: 66
Registered: November 2011
Location: Berlin, Germany
Member
Thanks, Lars, for the quick answer!
I saw your article before and adding
#SearchField {
     visibility: hidden;
}

to the css file works fine for the Eclipse Workbench itself.
For the RCP I just copy-pasted that css file under the project's root folder and added the corresponding property to the xml file:
<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.0"?>
<plugin>

   <extension
         id="application"
         point="org.eclipse.core.runtime.applications">
      <application>
         <run
               class="eub.rcplzhview.Application">
         </run>
      </application>
   </extension>
   <extension
         point="org.eclipse.ui.perspectives">
      <perspective
            name="Rcplzhview Perspective"
            class="eub.rcplzhview.JLZHViewPerspective"
            id="eub.rcplzhview.perspective">
      </perspective>
   </extension>
   <extension
         id="JLZHView"
         point="org.eclipse.core.runtime.products">
      <product
            application="eub.rcplzhview.application"
            name="jLZHview-2.3-alpha_2012-10-29_1930">
         <property
               name="windowImages"
               value="icons/gedeva-16-neu.gif,icons/gedeva-32-neu.gif"/>
         <property
               name="aboutImage"
               value="icons/about2.gif"/>
         <property
               name="aboutText"
               value="Energie- &amp; Umweltbüro e.V.&#x0A;&#x0A;Tel. (030) 7871-7651&#x0A;Fax (030) 7870-5612&#x0A;&#x0A;John-F.-Kennedy-Platz&#x0A;D-10820 Berlin&#x0A;&#x0A;mail:info@gedeva.de&#x0A;http://www.gedeva.de"/>
         <property
               name="appName"
               value="jLZHview-2.3-alpha_2012-10-29_1930"/>
         <property
               name="applicationCSS"
               value="default.css"/>
      </product>
   </extension>

</plugin>

We started develloping this application with Eclipse 3.0 and maybe there is more to adjust than simply this css property.

But I just noticed that I'm getting the following warning on start up of the application:
Warning default.css changed its meaning it is used now to run without theme support

This warning comes no matter if the default.xml file is actually in the folder or not. When I change "default.css" to "xdefault.css" in the xml file the message comes also with "xdefault.css".
Is it important to have the css file somewhere in platform:/plugin/ ?
Re: Eclipse RCP update from indigo-SR2 to juno-SR1 [message #967462 is a reply to message #967389] Thu, 01 November 2012 19:42 Go to previous messageGo to next message
Lars Vogel is currently offline Lars VogelFriend
Messages: 1049
Registered: July 2009
Senior Member

Hi Julia,

does CSS is a pure Eclipse 4 RCP app work for you? You can use Eclipse 4 RCP to create one standalone example. After you get this working I suggest to try again with the "old" RCP app.

Best regards, Lars
Re: Eclipse RCP update from indigo-SR2 to juno-SR1 [message #968385 is a reply to message #967462] Fri, 02 November 2012 12:20 Go to previous messageGo to next message
Julia Kurde is currently offline Julia KurdeFriend
Messages: 66
Registered: November 2011
Location: Berlin, Germany
Member
Hi Lars,

I tried the example application with wizard. It worked! And it also works in my "old" RCP, when I define the value for the applicationCSS property like "platform:/plugin/eub.rcplzhview/default.css" instead of just "default.css".

One of the two main problems is solved!

Unfortunatelly the WMF problem remains.

Thanks a lot so far!

Regards,
Julia
Re: Eclipse RCP update from indigo-SR2 to juno-SR1 [message #968614 is a reply to message #968385] Fri, 02 November 2012 15:54 Go to previous message
Julia Kurde is currently offline Julia KurdeFriend
Messages: 66
Registered: November 2011
Location: Berlin, Germany
Member
Also the wmf problem is solved Smile

see http://www.eclipse.org/forums/index.php/t/422202/
Previous Topic:Which renderer renders the MinMax buttons for the Part Stack?
Next Topic:Confirm exit dialog when pressing `X` button
Goto Forum:
  


Current Time: Mon Dec 22 21:33:20 GMT 2014

Powered by FUDForum. Page generated in 0.02770 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software