Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Can't run eclipse(Whenever I try to run eclipse I get an error message, followed by it shutting down.)
Can't run eclipse [message #967120] Thu, 01 November 2012 10:05 Go to next message
Ryan Kavanagh is currently offline Ryan Kavanagh
Messages: 3
Registered: November 2012
Junior Member
I'm on both java 32 and 64, So I set up the path to my java 64 and when I did javac in cmd it was working fine, when I downloaded and ran eclipse, it gave me this following error

Java was started but returned exit code=13
C:\Windows\system32\javaw.exe
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Users\Ryan\Desktop\Eclipse!\eclipse\\plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
-os win32
-ws win32
-arch x86_64
-showsplash C:\Users\Ryan\Desktop\Eclipse!\eclipse\\plugins\org.eclipse.platform_4.2.1.v201209141800\splash.bmp
-launcher C:\Users\Ryan\Desktop\Eclipse!\eclipse\eclipse.exe
-name Eclipse
--launcher.library C:\Users\Ryan\Desktop\Eclipse!\eclipse\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20120522-1813\eclipse_1503.dll
-startup C:\Users\Ryan\Desktop\Eclipse!\eclipse\\plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.overrideVmargs
-exitdata 1e98_124
-vm C:\Windows\system32\javaw.exe
-vmargs
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Users\Ryan\Desktop\Eclipse!\eclipse\\plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar 


If anyone could help me, I would appreciate it so much.
Re: Can't run eclipse [message #967223 is a reply to message #967120] Thu, 01 November 2012 11:37 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3125
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 11/1/2012 8:14 AM, Ryan Kavanagh wrote:
> I'm on both java 32 and 64, So I set up the path to my java 64 and when
> I did javac in cmd it was working fine, when I downloaded and ran
> eclipse, it gave me this following error
>
> Java was started but returned exit code=13
> C:\Windows\system32\javaw.exe
> [snip]

Don't use this Java, get a real download, preferably from java.sun.com.
Re: Can't run eclipse [message #967376 is a reply to message #967223] Thu, 01 November 2012 14:18 Go to previous messageGo to next message
Ryan Kavanagh is currently offline Ryan Kavanagh
Messages: 3
Registered: November 2012
Junior Member
Uhh... I don't understand what you mean, or how to do what your doing, might you be able to explain in detail how to do it? Sorry to be such a bother Sad
Best Regards,
Ryan
Re: Can't run eclipse [message #967391 is a reply to message #967376] Thu, 01 November 2012 14:29 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3125
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 11/1/2012 12:18 PM, Ryan Kavanagh wrote:
> Uhh... I don't understand what you mean, or how to do what your doing,
> might you be able to explain in detail how to do it? Sorry to be such a
> bother :(
> Best Regards,
> Ryan

No problem. The fastest thing I can say is have a look at:

http://www.javahotchocolate.com/tutorials/eclipse-summary.html

Then come back and ask more.
Re: Can't run eclipse [message #970272 is a reply to message #967391] Sat, 03 November 2012 20:22 Go to previous messageGo to next message
Ryan Kavanagh is currently offline Ryan Kavanagh
Messages: 3
Registered: November 2012
Junior Member
Hey,
I've checked over it, But I don't understand what is wrong with my java or how to fix the problem, Might you be able to give me a solution to the exact problem I'm having? I don't understand my exact problem, therefore I have no idea what I am suppouse to be doing? I'm really sorry about this.
Best Regards,
Ryan
Re: Can't run eclipse [message #970311 is a reply to message #970272] Sat, 03 November 2012 21:06 Go to previous messageGo to next message
Nir Lisker is currently offline Nir Lisker
Messages: 6
Registered: November 2012
Junior Member
Hi Ryan,

I don't understand the exact cause of the problem from the log. What I would do (if no one gives a better solution) is:

  1. Uninstall your current Java.
  2. Install the JDK from Oracle's website.
  3. If it doesn't work, try to download eclipse (whichever version you need) again.

You can configure which Java to use inside eclipse after it works.
Re: Can't run eclipse [message #970498 is a reply to message #970272] Sun, 04 November 2012 00:46 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3125
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 11/03/2012 06:22 PM, Ryan Kavanagh wrote:
> Hey,
> I've checked over it, But I don't understand what is wrong with my java
> or how to fix the problem, Might you be able to give me a solution to
> the exact problem I'm having? I don't understand my exact problem,
> therefore I have no idea what I am suppouse to be doing? I'm really
> sorry about this.
> Best Regards,
> Ryan

I just happened to set up Juno today, downloading new JDKs (1.6 and 1.7)
as well as Tomcat 6 and 7. I'm up and running and I followed the same
procedure I wrote down in that summary I gave you even though I wrote it
back before Helios had come out. So these instructions work for Europa
through Juno with no trouble.

You appear to have installed a 64-bit Eclipse. I think the JRE you're
using is 32-bit (don't ever use the JRE under Windows\system32 anyway).
I gave you instructions on how to download Eclipse and a proper JDK/JRE
including warning about bittedness. If you follow these directions, it
will work.

If the directions are confusing or inadequate in your particular case,
you may need to find someone who can be physically present to help,
something I can't do obviously.

Best of luck.
Re: Can't run eclipse [message #970989 is a reply to message #970311] Sun, 04 November 2012 08:41 Go to previous message
Russell Bateman is currently offline Russell Bateman
Messages: 3125
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 11/04/2012 05:02 AM, Nir Lisker wrote:
> Hi Ryan,
>
> I don't understand the exact cause of the problem from the log. What I
> would do (if no one gives a better solution) is:
>
> Uninstall your current Java.
> Install the JDK from Oracle's website.
> If it doesn't work, try to download eclipse (whichever version you need)
> again.
>
> You can configure which Java to use inside eclipse after it works.


Don't uninstall your current Java: leave it alone for use by your
computer. Instead, download and install a copy of Sun Java separately,
but when it asks you for the path, change this to something like
C:\Users\ryan\jdk1.7.0_x. Then modify your eclipse.ini to point to it.

Especially don't mess with C:\Windows\system32\javaw.exe.

In this way, the fate of Java and Java applications on your computer
have nothing to do with running Eclipse and developing in Java and what
you're doing in Eclipse won't be disturbed by some update to Java
(though these are usually safe).
Previous Topic:Can't install UML
Next Topic:How to have a tomcat server added that is already running/started outside of eclipse?
Goto Forum:
  


Current Time: Fri Jul 25 14:22:04 EDT 2014

Powered by FUDForum. Page generated in 0.02081 seconds