Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Visual Editor (VE) » Updating org.eclipse.jem to version 1.2.3 and breaking the Faces Configuration E
Updating org.eclipse.jem to version 1.2.3 and breaking the Faces Configuration E [message #136994] Wed, 28 March 2007 13:13 Go to next message
Eclipse User
Originally posted by: pedro.saraiva.arcor.de

Hi everybody,

I found a strange error, I think. I did a fresh eclipse 3.2 install. After
that I updated eclipse to version 3.2.2 using the built-in update
mechanism. Then I installed all the tools to use the JSF plugin: WTP, JST
and all required packages, one of these packages being the Visual Editor
including Java EMF Model version 1.2.1.

Until this point everything works ok, for example the faces-config.xml
editor gets started.

Now: if I use the built-in mechanism to update the installed features and
plugins I get an update only for the Visual Editor, in particular
org.eclipse.jem gets updated to version 1.2.3.

And now the faces-config.xml editor simply fails, I just get the source
code view.

To complete the strangeness, this happens to me only on my mac using
10.4.9. If I do the same procedure using Windows XP SP2 everything works
as expected.

Any hints what could go wrong?

To give you more info, here is what I was doing:

I did nothing particular, I just tried this
http://jsfcentral.com/listings/A93090?link tutorial. The Setup mentioned
in this tutorial was the only thing I adopted with the latests version of
the Eclipse Web Tools 1.5.3 and the corresponding JavaServer Faces plugin
wtp-jsf-R-1.5.3.zip. And, I used myfaces 1.1.5 instead of the SUN
Reference Implementation.

As I said, as long as I don't make this VE update, I can use the
faces-config.xml editor perfectly. These are the installed files by this
update, at least this is what the Install-Log tells me:


org.eclipse.ve_1.2.1.v20060817_M-zXJUB0fx_-eyDdh feature-install
org.eclipse.jem_1.2.3.v20070130_R----6zXJK-L2U8VZ feature-enable
org.eclipse.ve_1.2.1.v20060817_M-zXJUB0fx_-eyDdh feature-enable
org.eclipse.ve_1.2.1.v20060817_M-zXJUB0fxM-0vSdc feature-disabled
org.eclipse.jem_1.2.1.v20060815_M----6zXJJzKIRGVU feature-disabled

Best regards, Pedro
Re: Updating org.eclipse.jem to version 1.2.3 and breaking the Faces Configuration E [message #137009 is a reply to message #136994] Wed, 28 March 2007 13:34 Go to previous message
Eclipse User
Originally posted by: richkulp.us.NO_SPAM.ibm.com

Sorry, not a clue. JEM doesn't touch the xml editor in anyway that I
know of. 1.2.3 changed only one or two classes in JEM and that was it.
They should not of caused the problem.

--
Thanks,
Rich Kulp
Re: Updating org.eclipse.jem to version 1.2.3 and breaking the Faces Configuration E [message #615171 is a reply to message #136994] Wed, 28 March 2007 13:34 Go to previous message
Eclipse User
Originally posted by: richkulp.us.NO_SPAM.ibm.com

Sorry, not a clue. JEM doesn't touch the xml editor in anyway that I
know of. 1.2.3 changed only one or two classes in JEM and that was it.
They should not of caused the problem.

--
Thanks,
Rich Kulp
Previous Topic:Updating org.eclipse.jem to version 1.2.3 and breaking the Faces Configuration E
Next Topic:Adding Code for setting a property programatically
Goto Forum:
  


Current Time: Tue Oct 21 03:52:19 GMT 2014

Powered by FUDForum. Page generated in 0.01969 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software