Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Adding new source files bugs linking stage
Adding new source files bugs linking stage [message #964737] Tue, 30 October 2012 15:13 Go to next message
Tom Jansen is currently offline Tom Jansen
Messages: 2
Registered: October 2012
Junior Member
Hello everyone,

Recently I ran into the problem that for some reason I cannot add new source files to my project anymore. I am using Eclipse IDE for C/C++ Developers. Version: Indigo Service Release 2. The problem that I am currently facing is that when I add a new *.cpp file to the project and link to the header, the project fails during linking and is dropping random letters from the last to-be-included library.

For example when I create a file called SoundSource.cpp and link to the header the console will show "-lSDL_ttf
c:/mingw/bin/../lib/gcc/x86_64-w64-mingw32/4.6.3/../../../../x86_64-w64-mingw32/bin/ld.exe: cannot find -lSDL_tf
collect2: ld returned 1 exit status"

However when I rename the file it sometimes does manage to pass linking stage. I am pretty lost where to start searching for a possible solution. First I thought it was the 161th file being a problem, because when I removed another unused file it simply managed to compile again. I am aware it might have nothing to do with Eclipse IDE at all but maybe gcc is fooling me, however I am pretty clueless at the moment.

If anyone experienced something similar or do you have a suggestion what I could do, please let me know.

With kind regards,
Tom
Re: Adding new source files bugs linking stage [message #965432 is a reply to message #964737] Wed, 31 October 2012 04:22 Go to previous messageGo to next message
Axel Mueller is currently offline Axel Mueller
Messages: 1927
Registered: July 2009
Senior Member
I am not sure but you might be hit the maximum command line length under Windows.

see https://bugs.eclipse.org/bugs/show_bug.cgi?id=72965


Before you ask
- search this forum
- see the FAQ http://wiki.eclipse.org/CDT/User/FAQ
- google
Re: Adding new source files bugs linking stage [message #972832 is a reply to message #965432] Mon, 05 November 2012 18:10 Go to previous message
Tom Jansen is currently offline Tom Jansen
Messages: 2
Registered: October 2012
Junior Member
Hey Axel,

Thanks for your reply. This indeed seemed to be the problem. It is OK to rename my working folder for now. Still seems a pretty odd bug thats been around for a while?

Anyway I am happy that I can work on my project again. Cheers for that!

Previous Topic:MultiCore builds
Next Topic:regexErrorParser for a custom compiler
Goto Forum:
  


Current Time: Sat Apr 19 21:55:20 EDT 2014

Powered by FUDForum. Page generated in 0.02934 seconds