Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » JSDT project setup from GIT sources(Help needed to setup the dependencies of JSDT source)
JSDT project setup from GIT sources [message #963952] Tue, 30 October 2012 06:23 Go to next message
Henrique Smoco is currently offline Henrique Smoco
Messages: 1
Registered: October 2012
Junior Member
I get the source of JSDT from GIT (Master branch), but the eclipse complains about the errors below. There are a better branch to clone to start contribute? How to setup this project/environment?


Missing bundles:
org.eclipse.wst.jsdt.core.tests.compiler
org.eclipse.wst.jsdt.core.tests.model
org.eclipse.wst.jsdt.ui.tests

Error about extension points:
Referenced element 'enablement' is not defined quickAssistProcessors.exsd /org.eclipse.wst.jsdt.ui/schema line 57
Referenced element 'enablement' is not defined quickFixProcessors.exsd /org.eclipse.wst.jsdt.ui/schema line 63

And a bunch o JavaScript erros like this:
Syntax error on token "var", invalid MemberExpression IE_var.js /org.eclipse.wst.jsdt.support.ie/libraries line 74


Thanks
Re: JSDT project setup from GIT sources [message #964433 is a reply to message #963952] Tue, 30 October 2012 14:11 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2310
Registered: July 2009
Senior Member
master is the correct branch for Kepler/3.5/2013.

The test bundles are in the webtools.jsdt.debug.git repository, see http://git.eclipse.org/c/jsdt/webtools.jsdt.tests.git/ . For the extension point messages you're seeing, the 'enablement' element is imported from the extension point schema in org.eclipse.core.expressions (see line 20 of org.eclipse.wst.jsdt.ui/schema/quickAssistProcessors.exsd). You'll either need the Eclipse SDK in/as your target, or at least the sources for the org.eclipse.core.expressions bundle, which would include the schema.

The version of Microsoft Internet Explorer targeted by the org.eclipse.wst.jsdt.support.ie bundle isn't worth spending time on. Those errors have persisted for some time and we're not going to rework the parser to support defining 'var' as a named object rather than/in addition to a keyword.


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: JSDT project setup from GIT sources [message #1053425 is a reply to message #964433] Sun, 05 May 2013 10:53 Go to previous messageGo to next message
Dietrich Schulten is currently offline Dietrich Schulten
Messages: 2
Registered: March 2011
Junior Member
I found that I also had to clone and import the jsdt projects from

webtools.sourceediting.tests: http://git.eclipse.org/gitroot/jsdt/webtools.jsdt.tests.git

Nitin Dahyabhai wrote on Tue, 30 October 2012 10:11
For the extension point messages you're seeing, the 'enablement' element is imported from the extension point schema in org.eclipse.core.expressions (see line 20 of org.eclipse.wst.jsdt.ui/schema/quickAssistProcessors.exsd). You'll either need the Eclipse SDK in/as your target, or at least the sources for the org.eclipse.core.expressions bundle, which would include the schema.


Since importing as a fragment with sources does not work for org.eclipse.core.expressions:
Is there a simple way to solve that, short of downloading hundreds of megabytes of eclipse subprojects and sorting out the dependencies manually?
Is it possible to clone and import the expressions module with sources from git somewhere?


Re: JSDT project setup from GIT sources [message #1058034 is a reply to message #1053425] Fri, 10 May 2013 14:46 Go to previous message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2310
Registered: July 2009
Senior Member
Yes, you can clone git://git.eclipse.org/gitroot/platform/eclipse.platform.runtime.git for the source project itself. My clone's only 16MB.

---
Nitin Dahyabhai
Eclipse WTP, IBM
Previous Topic:Chrome connector?
Next Topic:Javascript Editor Very Slow
Goto Forum:
  


Current Time: Thu Oct 23 18:07:29 GMT 2014

Powered by FUDForum. Page generated in 0.01535 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software