Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Visual Editor (VE) » Extending the palette
Extending the palette [message #135708] Mon, 12 February 2007 00:45 Go to next message
Eclipse User
Originally posted by: savrahami.gmail.com

Hello,

I extended the ve bean palette by my own bean.

The problem is that while dropping the bean from the palette onto the ve, a
rename dialog pops up with an "XYZ" as its default name.

I don't know where this "XYZ" came from, what I need is the class name as
the default name to appear in the dialog

Any idea?



Thanks,

Shachar
Re: Extending the palette [message #135733 is a reply to message #135708] Mon, 12 February 2007 09:53 Go to previous messageGo to next message
Eclipse User
Originally posted by: richkulp.us.NO_SPAM.ibm.com

What kind of entry in the palette did you use? The EMFCreationToolEntry
or the EMFPrototypeToolEntry?

Did you include an entry like this?

<keyedValues xsi:type="ecore:EStringToStringMapEntry"
key="org.eclipse.ve.internal.cde.core.nameincomposition"
value="menu"/>




Shachar wrote:
> Hello,
>
> I extended the ve bean palette by my own bean.
>
> The problem is that while dropping the bean from the palette onto the ve, a
> rename dialog pops up with an "XYZ" as its default name.
>
> I don't know where this "XYZ" came from, what I need is the class name as
> the default name to appear in the dialog
>
> Any idea?
>
>
>
> Thanks,
>
> Shachar
>
>

--
Thanks,
Rich Kulp
Re: Extending the palette [message #135965 is a reply to message #135733] Sun, 18 February 2007 00:40 Go to previous messageGo to next message
Eclipse User
Originally posted by: savrahami.gmail.com

Here's what I've done:


<?xml version="1.0" encoding="UTF-8"?>
<org.eclipse.ve.internal.cde.palette:Drawer xmi:version="2.0"
xmlns:xmi="http://www.omg.org/XMI"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore"
xmlns:org.eclipse.ve.internal.cde.palette="http:///org/eclipse/ve/internal/cde/palette.ecore"
xmlns:org.eclipse.ve.internal.cde.utility="http:///org/eclipse/ve/internal/cde/utility.ecore">

<entryLabel xsi:type="org.eclipse.ve.internal.cde.utility:ConstantString "
string="FE Infra Components" string="fromXmiFile" />

<children
xsi:type="org.eclipse.ve.internal.cde.palette:EMFCreationToolEntry "
icon16Name="platform:/plugin/MyFirstPlugin/icons/mir29.gif"
creationClassURI="java:/controler#MyControl">
<entryLabel
xsi:type="org.eclipse.ve.internal.cde.utility:ConstantString "
string="MyControl" />
<keyedValues xsi:type="ecore:EStringToStringMapEntry"
key="org.eclipse.ve.internal.cde.core.nameincomposition" value="myControl"
/>
</children>

</org.eclipse.ve.internal.cde.palette:Drawer>




"Rich Kulp" <richkulp@us.NO_SPAM.ibm.com> wrote in message
news:eqpv1i$4ga$1@utils.eclipse.org...
> What kind of entry in the palette did you use? The EMFCreationToolEntry or
> the EMFPrototypeToolEntry?
>
> Did you include an entry like this?
>
> <keyedValues xsi:type="ecore:EStringToStringMapEntry"
> key="org.eclipse.ve.internal.cde.core.nameincomposition"
> value="menu"/>
>
>
>
>
> Shachar wrote:
>> Hello,
>>
>> I extended the ve bean palette by my own bean.
>>
>> The problem is that while dropping the bean from the palette onto the ve,
>> a rename dialog pops up with an "XYZ" as its default name.
>>
>> I don't know where this "XYZ" came from, what I need is the class name as
>> the default name to appear in the dialog
>>
>> Any idea?
>>
>>
>>
>> Thanks,
>>
>> Shachar
>>
>>
>
> --
> Thanks,
> Rich Kulp
Re: Extending the palette [message #135989 is a reply to message #135965] Mon, 19 February 2007 10:04 Go to previous messageGo to next message
Eclipse User
Originally posted by: richkulp.us.NO_SPAM.ibm.com

I don't know why. The xmi looks correct. The only reason that I could
see this occurring is that the name in composition was not set
correctly. But I don't see why that would happen.

You would need to see if there are any errors in the log or trace to see
if:

1) CreationToolEntryImpl.getFactory() to see if it adds in a
AnnotationCreationFactory for the getKeyedValues().

2)
NameInCompositionPropertyDescriptor.getUniqueNameInCompositi on(EditDomain
domain, String name, Set otherNames) if the incoming name is null (if it
is then XYZ is used). Trace backward from there.

Rich
Re: Extending the palette [message #135999 is a reply to message #135989] Tue, 20 February 2007 00:19 Go to previous message
Eclipse User
Originally posted by: savrahami.gmail.com

Thanks,

"Rich Kulp" <richkulp@us.NO_SPAM.ibm.com> wrote in message
news:erce9i$e4l$1@utils.eclipse.org...
>I don't know why. The xmi looks correct. The only reason that I could see
>this occurring is that the name in composition was not set correctly. But I
>don't see why that would happen.
>
> You would need to see if there are any errors in the log or trace to see
> if:
>
> 1) CreationToolEntryImpl.getFactory() to see if it adds in a
> AnnotationCreationFactory for the getKeyedValues().
>
> 2)
> NameInCompositionPropertyDescriptor.getUniqueNameInCompositi on(EditDomain
> domain, String name, Set otherNames) if the incoming name is null (if it
> is then XYZ is used). Trace backward from there.
>
> Rich
Re: Extending the palette [message #615059 is a reply to message #135708] Mon, 12 February 2007 09:53 Go to previous message
Eclipse User
Originally posted by: richkulp.us.NO_SPAM.ibm.com

What kind of entry in the palette did you use? The EMFCreationToolEntry
or the EMFPrototypeToolEntry?

Did you include an entry like this?

<keyedValues xsi:type="ecore:EStringToStringMapEntry"
key="org.eclipse.ve.internal.cde.core.nameincomposition"
value="menu"/>




Shachar wrote:
> Hello,
>
> I extended the ve bean palette by my own bean.
>
> The problem is that while dropping the bean from the palette onto the ve, a
> rename dialog pops up with an "XYZ" as its default name.
>
> I don't know where this "XYZ" came from, what I need is the class name as
> the default name to appear in the dialog
>
> Any idea?
>
>
>
> Thanks,
>
> Shachar
>
>

--
Thanks,
Rich Kulp
Re: Extending the palette [message #615077 is a reply to message #135733] Sun, 18 February 2007 00:40 Go to previous message
Eclipse User
Originally posted by: savrahami.gmail.com

Here's what I've done:


<?xml version="1.0" encoding="UTF-8"?>
<org.eclipse.ve.internal.cde.palette:Drawer xmi:version="2.0"
xmlns:xmi="http://www.omg.org/XMI"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore"
xmlns:org.eclipse.ve.internal.cde.palette="http:///org/eclipse/ve/internal/cde/palette.ecore"
xmlns:org.eclipse.ve.internal.cde.utility="http:///org/eclipse/ve/internal/cde/utility.ecore">

<entryLabel xsi:type="org.eclipse.ve.internal.cde.utility:ConstantString "
string="FE Infra Components" string="fromXmiFile" />

<children
xsi:type="org.eclipse.ve.internal.cde.palette:EMFCreationToolEntry "
icon16Name="platform:/plugin/MyFirstPlugin/icons/mir29.gif"
creationClassURI="java:/controler#MyControl">
<entryLabel
xsi:type="org.eclipse.ve.internal.cde.utility:ConstantString "
string="MyControl" />
<keyedValues xsi:type="ecore:EStringToStringMapEntry"
key="org.eclipse.ve.internal.cde.core.nameincomposition" value="myControl"
/>
</children>

</org.eclipse.ve.internal.cde.palette:Drawer>




"Rich Kulp" <richkulp@us.NO_SPAM.ibm.com> wrote in message
news:eqpv1i$4ga$1@utils.eclipse.org...
> What kind of entry in the palette did you use? The EMFCreationToolEntry or
> the EMFPrototypeToolEntry?
>
> Did you include an entry like this?
>
> <keyedValues xsi:type="ecore:EStringToStringMapEntry"
> key="org.eclipse.ve.internal.cde.core.nameincomposition"
> value="menu"/>
>
>
>
>
> Shachar wrote:
>> Hello,
>>
>> I extended the ve bean palette by my own bean.
>>
>> The problem is that while dropping the bean from the palette onto the ve,
>> a rename dialog pops up with an "XYZ" as its default name.
>>
>> I don't know where this "XYZ" came from, what I need is the class name as
>> the default name to appear in the dialog
>>
>> Any idea?
>>
>>
>>
>> Thanks,
>>
>> Shachar
>>
>>
>
> --
> Thanks,
> Rich Kulp
Re: Extending the palette [message #615079 is a reply to message #135965] Mon, 19 February 2007 10:04 Go to previous message
Eclipse User
Originally posted by: richkulp.us.NO_SPAM.ibm.com

I don't know why. The xmi looks correct. The only reason that I could
see this occurring is that the name in composition was not set
correctly. But I don't see why that would happen.

You would need to see if there are any errors in the log or trace to see
if:

1) CreationToolEntryImpl.getFactory() to see if it adds in a
AnnotationCreationFactory for the getKeyedValues().

2)
NameInCompositionPropertyDescriptor.getUniqueNameInCompositi on(EditDomain
domain, String name, Set otherNames) if the incoming name is null (if it
is then XYZ is used). Trace backward from there.

Rich
Re: Extending the palette [message #615080 is a reply to message #135989] Tue, 20 February 2007 00:19 Go to previous message
Eclipse User
Originally posted by: savrahami.gmail.com

Thanks,

"Rich Kulp" <richkulp@us.NO_SPAM.ibm.com> wrote in message
news:erce9i$e4l$1@utils.eclipse.org...
>I don't know why. The xmi looks correct. The only reason that I could see
>this occurring is that the name in composition was not set correctly. But I
>don't see why that would happen.
>
> You would need to see if there are any errors in the log or trace to see
> if:
>
> 1) CreationToolEntryImpl.getFactory() to see if it adds in a
> AnnotationCreationFactory for the getKeyedValues().
>
> 2)
> NameInCompositionPropertyDescriptor.getUniqueNameInCompositi on(EditDomain
> domain, String name, Set otherNames) if the incoming name is null (if it
> is then XYZ is used). Trace backward from there.
>
> Rich
Previous Topic:Plug-in
Next Topic:This is a test for line separator
Goto Forum:
  


Current Time: Thu Aug 21 06:13:13 EDT 2014

Powered by FUDForum. Page generated in 0.01775 seconds