Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Profiler fails to start in 3.3
Profiler fails to start in 3.3 [message #135587] Wed, 10 September 2008 00:37 Go to next message
Fred R. is currently offline Fred R.Friend
Messages: 6
Registered: July 2009
Junior Member
I'm using ver 4.4.2 of tptp with eclipse 3.3.2. I can't use the profiler
at all. It tells me "An application for the process that was about to be
launched is not registered with the Agent Controller. This can be caused
by a missing or corrupted configuration file."

I've used the older version of profiler with Java 1.5, eclipse 3.2 many
times. But I just can't get it to run under 3.3.2. I've tried just about
everything I could find on google with no luck. I can see ACService.exe is
running. The port for AC is available and test connect. I'm not doing any
remote profiling. I'm just trying to profile a local SWT client app with
no server components.

Any is greatly appreciated. Do you know any other open source profiler for
Java that work with eclipse?

TIA,
Fred
Re: Profiler fails to start in 3.3 [message #135678 is a reply to message #135587] Sun, 14 September 2008 13:34 Go to previous message
Asaf Yaffe is currently offline Asaf YaffeFriend
Messages: 333
Registered: July 2009
Senior Member
Fred,

> I'm using ver 4.4.2 of tptp with eclipse 3.3.2. I can't use the
> profiler at all. It tells me "An application for the process that was
> about to be launched is not registered with the Agent Controller. This
> can be caused by a missing or corrupted configuration file."
>
> I've used the older version of profiler with Java 1.5, eclipse 3.2 many
> times. But I just can't get it to run under 3.3.2. I've tried just about
> everything I could find on google with no luck. I can see ACService.exe
> is running. The port for AC is available and test connect. I'm not doing
> any remote profiling. I'm just trying to profile a local SWT client app
> with no server components.
>

Are you using the Integrated Agent Controller? If not, did you run the
SetConfig script of the standalone Agent Controller after installing it?

Thanks,
Asaf


--
Asaf Yaffe
Eclipse TPTP Committer, JVMTI Profiler
Previous Topic:TPTP and J unit 4
Next Topic:How to show java.* classes in profiling statistics?
Goto Forum:
  


Current Time: Wed Nov 26 16:49:49 GMT 2014

Powered by FUDForum. Page generated in 0.02753 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software