Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Disabling autoformat
Disabling autoformat [message #135024] Sun, 16 January 2005 02:23 Go to next message
Eclipse UserFriend
Originally posted by: usenetNOSPAM.jimrandomh.org

HOW do you disable the auto-indentation?

It's driving me nuts. The editor keeps trying to be smart and inserting
tabs when I don't want it to. I've looked all over, and I can't find an
option that will make it stop. It should NOT be so hard to make the
text editor behave like a TEXT EDITOR, so where is it?

--
CalcRogue: TI-89, TI-92+, PalmOS, Windows and Linux.
http://calcrogue.jimrandomh.org/
Re: Disabling autoformat [message #135049 is a reply to message #135024] Sun, 16 January 2005 18:52 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: usenetNOSPAM.jimrandomh.org

jimrandomh <usenetNOSPAM@jimrandomh.org> wrote:
> HOW do you disable the auto-indentation?
>
> It's driving me nuts. The editor keeps trying to be smart and
> inserting tabs when I don't want it to. I've looked all over, and
> I can't find an option that will make it stop. It should NOT be so
> hard to make the text editor behave like a TEXT EDITOR, so where
> is it?

Well, from some experimentation with the JAVA editor, it seems that
ctrl+shift+insert is supposed to do it (disable "smart insert" mode).
But it doesn't work in the C++ editor, so I've opened
https://bugs.eclipse.org/bugs/show_bug.cgi?id=82928

--
CalcRogue: TI-89, TI-92+, PalmOS, Windows and Linux.
http://calcrogue.jimrandomh.org/
Re: Disabling autoformat [message #135461 is a reply to message #135024] Tue, 18 January 2005 18:08 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: usenetNOSPAM.jimrandomh.org

jimrandomh <usenetNOSPAM@jimrandomh.org> wrote:
> HOW do you disable the auto-indentation?
>
> It's driving me nuts. The editor keeps trying to be smart and
> inserting tabs when I don't want it to. I've looked all over, and
> I can't find an option that will make it stop. It should NOT be so
> hard to make the text editor behave like a TEXT EDITOR, so where
> is it?

Due to this problem, and the apparent absence of anyone interested in
fixing it, I have decided not to use Eclipse or to support building any
of my projects with it. Someone wake me up when Eclipse has a working
C++ editor.

--
CalcRogue: TI-89, TI-92+, PalmOS, Windows and Linux.
http://calcrogue.jimrandomh.org/
Re: Disabling autoformat [message #135487 is a reply to message #135461] Tue, 18 January 2005 22:16 Go to previous messageGo to next message
Slamlander is currently offline SlamlanderFriend
Messages: 31
Registered: July 2009
Member
Actually, there is a way to fix it. You just didn't allow enough time for a
response.
go to: Window>Preferences>C/C++>Code Templates
Adjust the templates to your coding style.
viola! you are done!

BTW, if you'd worked through the tutorials then you would have known about
it already.


--
--
E X Q U I S I T U S
Neuchatel, CH
--


"jimrandomh" <usenetNOSPAM@jimrandomh.org> wrote in message
news:Xns95E28559AFDDBjimrandomh@206.191.52.34...
> jimrandomh <usenetNOSPAM@jimrandomh.org> wrote:
> > HOW do you disable the auto-indentation?
> >
> > It's driving me nuts. The editor keeps trying to be smart and
> > inserting tabs when I don't want it to. I've looked all over, and
> > I can't find an option that will make it stop. It should NOT be so
> > hard to make the text editor behave like a TEXT EDITOR, so where
> > is it?
>
> Due to this problem, and the apparent absence of anyone interested in
> fixing it, I have decided not to use Eclipse or to support building any
> of my projects with it. Someone wake me up when Eclipse has a working
> C++ editor.
>
> --
> CalcRogue: TI-89, TI-92+, PalmOS, Windows and Linux.
> http://calcrogue.jimrandomh.org/
Re: Disabling autoformat [message #135514 is a reply to message #135487] Wed, 19 January 2005 04:06 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: usenetNOSPAM.jimrandomh.org

"exquisitus" <slamlander@livejournal.com> wrote:

> Actually, there is a way to fix it. You just didn't allow enough
> time for a response.
> go to: Window>Preferences>C/C++>Code Templates
> Adjust the templates to your coding style.
> viola! you are done!
>
> BTW, if you'd worked through the tutorials then you would have
> known about it already.

Already been through that section, and that's not what I'm talking
about. That section has auto-completions for various control
structures, but even with all of them disabled, simply typing [open
curly brace][enter] into an empty file inserts an unwanted extra tab.

I've systematically gone through everything in the preferences and am
fairly certain that there's nothing there.

--
CalcRogue: TI-89, TI-92+, PalmOS, Windows and Linux.
http://calcrogue.jimrandomh.org/
Re: Disabling autoformat [message #135527 is a reply to message #135514] Wed, 19 January 2005 06:57 Go to previous messageGo to next message
Slamlander is currently offline SlamlanderFriend
Messages: 31
Registered: July 2009
Member
I apologize, I just created a new template called 'braces'. It looks like
this;
{
${cursor}

}

.... well with proper indents, of course (there's a lot to be said for stupid
editors with monotype fonts). It didn't work. The damned thing always gives
you an extra indent after an open brace and doesn't complete the closing
brace. Yes, it bothers me too, just not as much.

This could either be a bug or a feature. 90% of the time, when entering an
open brace, you want the indent on the next line, depending on your coding
style.

I don't know what to tell you now. I'm so used to editors doing that to me
that I just hit the backspace to unindent, when required. It's definitely
stopped irritating me decades ago. Every "smart" editor I know of does this,
all the way back to 'brief'. Personally, I think that it's better than no
indent.

Short answer: I can't find it either. If it's not already written up then it
may be worth a mention in bugzilla. You found it ... have at it.

"jimrandomh" <usenetNOSPAM@jimrandomh.org> wrote in message
news:Xns95E2EAAD0EBBEjimrandomh@206.191.52.34...
> "exquisitus" <slamlander@livejournal.com> wrote:
>
> > Actually, there is a way to fix it. You just didn't allow enough
> > time for a response.
> > go to: Window>Preferences>C/C++>Code Templates
> > Adjust the templates to your coding style.
> > viola! you are done!
> >
> > BTW, if you'd worked through the tutorials then you would have
> > known about it already.
>
> Already been through that section, and that's not what I'm talking
> about. That section has auto-completions for various control
> structures, but even with all of them disabled, simply typing [open
> curly brace][enter] into an empty file inserts an unwanted extra tab.
>
> I've systematically gone through everything in the preferences and am
> fairly certain that there's nothing there.
>
> --
> CalcRogue: TI-89, TI-92+, PalmOS, Windows and Linux.
> http://calcrogue.jimrandomh.org/
Re: Disabling autoformat [message #135552 is a reply to message #135527] Wed, 19 January 2005 14:22 Go to previous messageGo to next message
John Camelon is currently offline John CamelonFriend
Messages: 242
Registered: July 2009
Senior Member
Please raise a bug @ bugs.eclipse.org on CDT UI.
Thanks

"exquisitus" <slamlander@livejournal.com> wrote in message
news:csl0hm$13b$1@www.eclipse.org...
> I apologize, I just created a new template called 'braces'. It looks like
> this;
> {
> ${cursor}
>
> }
>
> ... well with proper indents, of course (there's a lot to be said for
stupid
> editors with monotype fonts). It didn't work. The damned thing always
gives
> you an extra indent after an open brace and doesn't complete the closing
> brace. Yes, it bothers me too, just not as much.
>
> This could either be a bug or a feature. 90% of the time, when entering an
> open brace, you want the indent on the next line, depending on your coding
> style.
>
> I don't know what to tell you now. I'm so used to editors doing that to me
> that I just hit the backspace to unindent, when required. It's definitely
> stopped irritating me decades ago. Every "smart" editor I know of does
this,
> all the way back to 'brief'. Personally, I think that it's better than no
> indent.
>
> Short answer: I can't find it either. If it's not already written up then
it
> may be worth a mention in bugzilla. You found it ... have at it.
>
> "jimrandomh" <usenetNOSPAM@jimrandomh.org> wrote in message
> news:Xns95E2EAAD0EBBEjimrandomh@206.191.52.34...
> > "exquisitus" <slamlander@livejournal.com> wrote:
> >
> > > Actually, there is a way to fix it. You just didn't allow enough
> > > time for a response.
> > > go to: Window>Preferences>C/C++>Code Templates
> > > Adjust the templates to your coding style.
> > > viola! you are done!
> > >
> > > BTW, if you'd worked through the tutorials then you would have
> > > known about it already.
> >
> > Already been through that section, and that's not what I'm talking
> > about. That section has auto-completions for various control
> > structures, but even with all of them disabled, simply typing [open
> > curly brace][enter] into an empty file inserts an unwanted extra tab.
> >
> > I've systematically gone through everything in the preferences and am
> > fairly certain that there's nothing there.
> >
> > --
> > CalcRogue: TI-89, TI-92+, PalmOS, Windows and Linux.
> > http://calcrogue.jimrandomh.org/
>
>
Re: Disabling autoformat [message #135566 is a reply to message #135527] Wed, 19 January 2005 15:46 Go to previous messageGo to next message
Slamlander is currently offline SlamlanderFriend
Messages: 31
Registered: July 2009
Member
Okay, it's done. Bug #83196

"exquisitus" <slamlander@livejournal.com> wrote in message
news:csl0hm$13b$1@www.eclipse.org...
> I apologize, I just created a new template called 'braces'. It looks like
> this;
> {
> ${cursor}
>
> }
>
> ... well with proper indents, of course (there's a lot to be said for
stupid
> editors with monotype fonts). It didn't work. The damned thing always
gives
> you an extra indent after an open brace and doesn't complete the closing
> brace. Yes, it bothers me too, just not as much.
>
> This could either be a bug or a feature. 90% of the time, when entering an
> open brace, you want the indent on the next line, depending on your coding
> style.
>
> I don't know what to tell you now. I'm so used to editors doing that to me
> that I just hit the backspace to unindent, when required. It's definitely
> stopped irritating me decades ago. Every "smart" editor I know of does
this,
> all the way back to 'brief'. Personally, I think that it's better than no
> indent.
>
> Short answer: I can't find it either. If it's not already written up then
it
> may be worth a mention in bugzilla. You found it ... have at it.
>
> "jimrandomh" <usenetNOSPAM@jimrandomh.org> wrote in message
> news:Xns95E2EAAD0EBBEjimrandomh@206.191.52.34...
> > "exquisitus" <slamlander@livejournal.com> wrote:
> >
> > > Actually, there is a way to fix it. You just didn't allow enough
> > > time for a response.
> > > go to: Window>Preferences>C/C++>Code Templates
> > > Adjust the templates to your coding style.
> > > viola! you are done!
> > >
> > > BTW, if you'd worked through the tutorials then you would have
> > > known about it already.
> >
> > Already been through that section, and that's not what I'm talking
> > about. That section has auto-completions for various control
> > structures, but even with all of them disabled, simply typing [open
> > curly brace][enter] into an empty file inserts an unwanted extra tab.
> >
> > I've systematically gone through everything in the preferences and am
> > fairly certain that there's nothing there.
> >
> > --
> > CalcRogue: TI-89, TI-92+, PalmOS, Windows and Linux.
> > http://calcrogue.jimrandomh.org/
>
>
Re: Disabling autoformat [message #135594 is a reply to message #135566] Wed, 19 January 2005 16:37 Go to previous messageGo to next message
John Camelon is currently offline John CamelonFriend
Messages: 242
Registered: July 2009
Senior Member
Thanks

"exquisitus" <slamlander@livejournal.com> wrote in message
news:cslvcj$3cl$1@www.eclipse.org...
> Okay, it's done. Bug #83196
>
> "exquisitus" <slamlander@livejournal.com> wrote in message
> news:csl0hm$13b$1@www.eclipse.org...
> > I apologize, I just created a new template called 'braces'. It looks
like
> > this;
> > {
> > ${cursor}
> >
> > }
> >
> > ... well with proper indents, of course (there's a lot to be said for
> stupid
> > editors with monotype fonts). It didn't work. The damned thing always
> gives
> > you an extra indent after an open brace and doesn't complete the closing
> > brace. Yes, it bothers me too, just not as much.
> >
> > This could either be a bug or a feature. 90% of the time, when entering
an
> > open brace, you want the indent on the next line, depending on your
coding
> > style.
> >
> > I don't know what to tell you now. I'm so used to editors doing that to
me
> > that I just hit the backspace to unindent, when required. It's
definitely
> > stopped irritating me decades ago. Every "smart" editor I know of does
> this,
> > all the way back to 'brief'. Personally, I think that it's better than
no
> > indent.
> >
> > Short answer: I can't find it either. If it's not already written up
then
> it
> > may be worth a mention in bugzilla. You found it ... have at it.
> >
> > "jimrandomh" <usenetNOSPAM@jimrandomh.org> wrote in message
> > news:Xns95E2EAAD0EBBEjimrandomh@206.191.52.34...
> > > "exquisitus" <slamlander@livejournal.com> wrote:
> > >
> > > > Actually, there is a way to fix it. You just didn't allow enough
> > > > time for a response.
> > > > go to: Window>Preferences>C/C++>Code Templates
> > > > Adjust the templates to your coding style.
> > > > viola! you are done!
> > > >
> > > > BTW, if you'd worked through the tutorials then you would have
> > > > known about it already.
> > >
> > > Already been through that section, and that's not what I'm talking
> > > about. That section has auto-completions for various control
> > > structures, but even with all of them disabled, simply typing [open
> > > curly brace][enter] into an empty file inserts an unwanted extra tab.
> > >
> > > I've systematically gone through everything in the preferences and am
> > > fairly certain that there's nothing there.
> > >
> > > --
> > > CalcRogue: TI-89, TI-92+, PalmOS, Windows and Linux.
> > > http://calcrogue.jimrandomh.org/
> >
> >
>
>
Re: Disabling autoformat [message #838710 is a reply to message #135024] Sat, 07 April 2012 14:01 Go to previous messageGo to next message
Ryan Grapp is currently offline Ryan GrappFriend
Messages: 2
Registered: April 2012
Junior Member
Or better yet... disable ALL forms of auto formatting....

Apparently I'm not the only one who hates this feature. Who knew. I mean, if I wanted the code formatted a specific way.... i'd type it that way. If a company wants code formatted a specific way... again.. i'd type it that way or find myself jobless if they are smart.

The only possible reason to use it is if you are copy/paste coding from one project to another. Then.. if you are doing something that silly, you can pay the price of doing it manually. I see no useful reason for this feature other than to somehow magically trigger it, mess up my code and make me spend several minutes if not hours fixing it.

If nothing else, can't there be an "confirmation" popup?
Re: Disabling autoformat [message #993852 is a reply to message #838710] Tue, 25 December 2012 18:17 Go to previous message
Albert Pion is currently offline Albert PionFriend
Messages: 1
Registered: December 2012
Junior Member
Personally, I'd like it if there was some way to disable all "smart" editing features. I am a fast typist, and all I want is an editor that inserts everything I type, exactly as I type it, and nothing more or less. Is that too much to ask of an editor?

How about, when you decide to do something "smart" for me, you give me the option of disabling it just in case I don't think it's so smart?

A very knowledgable person once said "Anything that can be done FOR you automatically can be done TO you automatically".
Previous Topic:Newbie Help: "Launch failed. Binary not found." for c++ on Mac OS X 10.7 Eclipse Indigo
Next Topic:adding gtk-library, c++
Goto Forum:
  


Current Time: Mon Nov 24 01:19:21 GMT 2014

Powered by FUDForum. Page generated in 0.04346 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software