Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » TPTP with Eclipse and RAD Issue
TPTP with Eclipse and RAD Issue [message #134074] Fri, 08 August 2008 07:21 Go to next message
Ankur Shah is currently offline Ankur Shah
Messages: 7
Registered: July 2009
Junior Member
TPTP with Eclipse
==================
I am trying to RUN a TPTP Test suite with eclipse

I tried to install the TPTP on eclipse environment and it got installed
properly but while executing test cases through eclipse i encountered
following issue.

When ever i do test suite run as test it gives following exception.

IWAT4039E The Test Execution Harness reported the following problems:
org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException


TPTP with RAD 7.0.0.7
===================
I have Installed RAD 7.0.0.7, But still not able to find TPTP under this.
If i click button feature details (shown in the screenshot) then under
that list i can see the TPTP packages installed.
But when i open it through File-> new -> others then i can't see TPTP
option under that.

Tried opening RAD with Clean command and also tried on Eclipse but no
success.

Do let me know if any of you guys have encountered and resolved the issues
floating around with TPTP.
Re: TPTP with Eclipse and RAD Issue [message #134084 is a reply to message #134074] Fri, 08 August 2008 08:46 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Ankur,

What version of TPTP are you using? What type of TPTP test suite are
you running? Are you using the IAC or Agent Controller?

When running the TPTP Test Tools in RAD, please enable the Tester
capability.

Paul
"Ankur Shah" <ankur.shah@in.ibm.com> wrote in message
news:b8919813a65e96d05da96ced68a92281$1@www.eclipse.org...
> TPTP with Eclipse
> ==================
> I am trying to RUN a TPTP Test suite with eclipse
>
> I tried to install the TPTP on eclipse environment and it got installed
> properly but while executing test cases through eclipse i encountered
> following issue.
>
> When ever i do test suite run as test it gives following exception.
>
> IWAT4039E The Test Execution Harness reported the following problems:
> org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
>
>
> TPTP with RAD 7.0.0.7
> ===================
> I have Installed RAD 7.0.0.7, But still not able to find TPTP under this.
> If i click button feature details (shown in the screenshot) then under
> that list i can see the TPTP packages installed.
> But when i open it through File-> new -> others then i can't see TPTP
> option under that.
>
> Tried opening RAD with Clean command and also tried on Eclipse but no
> success.
>
> Do let me know if any of you guys have encountered and resolved the issues
> floating around with TPTP.
>
>
Re: TPTP with Eclipse and RAD Issue [message #134100 is a reply to message #134084] Fri, 08 August 2008 09:49 Go to previous messageGo to next message
Ankur Shah is currently offline Ankur Shah
Messages: 7
Registered: July 2009
Junior Member
Hi,

Thanx for the quick trunaround,


I have downloaded eclipse from internet and then run autoupdates through
help->software updates from following site
http://download.eclipse.org/releases/europa/

Regarding TPTP versions,

In my software updates and Add-ons, I can see following TPTP components:
TPTP Monitoring Tools Project
4.4.100.v200804180100-7V7SE9x7zhmh1yz-xOz-fBGuW9St
TPTP Platform Project 4.5.0.v200804180100-8F82Eb49ToWvwDG3z0OLTKR_cEs8
TPTP Profiling for Web
applications 4.4.100.v200804180100-784Ag7GUGJVz0Z-yMEckQdoYbhA
TPTP Reporting with
BIRT 4.4.100.v200802291616-7J7K_77i0i7EsQgZWz0mYnKhiiyD
TPTP Test Framework and Tools
Project 4.3.200.v200805091443-7F7_EAU7SnbjlBGPQ2r6Nij2r6Np
TPTP Tracing and Profiling Tools
Project 4.4.100.v200802291616-7F78CE7VXNA6M-BKOmcZdZPWaTC

Regarding testsuite.
===================
just trying to create a same test suite which is shown in the demo example
in follwoing link
http://www.eclipse.org/tptp/home/documents/tutorials/screenc asts/tptpJunit.html


I have not installed any agent controller or integrated agent controller
(IAC).

I am also not sure about how to enable Tester capabilty in RAD

Thanx and Regards
Ankur
Re: TPTP with Eclipse and RAD Issue [message #134130 is a reply to message #134100] Fri, 08 August 2008 10:41 Go to previous messageGo to next message
Eugene Chan is currently offline Eugene Chan
Messages: 287
Registered: July 2009
Senior Member
'Capability' is under Windows > Preferences... > General of RAD driver, and
there is a category 'Tester' that when selected enables all testing features
of the product.

Eugene

"Ankur Shah" <ankur.shah@in.ibm.com> wrote in message
news:688a2f740490a7da39039719b6c98b9f$1@www.eclipse.org...
> Hi,
>
> Thanx for the quick trunaround,
>
> I have downloaded eclipse from internet and then run autoupdates through
> help->software updates from following site
> http://download.eclipse.org/releases/europa/
>
> Regarding TPTP versions,
>
> In my software updates and Add-ons, I can see following TPTP components:
> TPTP Monitoring Tools Project
> 4.4.100.v200804180100-7V7SE9x7zhmh1yz-xOz-fBGuW9St
> TPTP Platform Project 4.5.0.v200804180100-8F82Eb49ToWvwDG3z0OLTKR_cEs8
> TPTP Profiling for Web applications
> 4.4.100.v200804180100-784Ag7GUGJVz0Z-yMEckQdoYbhA
> TPTP Reporting with BIRT
> 4.4.100.v200802291616-7J7K_77i0i7EsQgZWz0mYnKhiiyD
> TPTP Test Framework and Tools Project
> 4.3.200.v200805091443-7F7_EAU7SnbjlBGPQ2r6Nij2r6Np
> TPTP Tracing and Profiling Tools Project
> 4.4.100.v200802291616-7F78CE7VXNA6M-BKOmcZdZPWaTC
>
> Regarding testsuite.
> ===================
> just trying to create a same test suite which is shown in the demo example
> in follwoing link
> http://www.eclipse.org/tptp/home/documents/tutorials/screenc asts/tptpJunit.html
>
>
> I have not installed any agent controller or integrated agent controller
> (IAC).
>
> I am also not sure about how to enable Tester capabilty in RAD
>
> Thanx and Regards
> Ankur
Re: TPTP with Eclipse and RAD Issue [message #134195 is a reply to message #134100] Mon, 11 August 2008 07:14 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Ankur,
When you install TPTP from the Europa update site, you automatically get
the IAC installed. However, in TPTP 4.4.0 (shipped with Europa) the IAC has
several issues that may be blocking you. I would suggest downloading and
installing the Agent Controller for TPTP 4.4.0:

http://www.eclipse.org/tptp/home/downloads/?ver=4.4.0#agentC ontroller

See Eugene's post for enabling the Tester capability in RAD.

Paul
"Ankur Shah" <ankur.shah@in.ibm.com> wrote in message
news:688a2f740490a7da39039719b6c98b9f$1@www.eclipse.org...
> Hi,
>
> Thanx for the quick trunaround,
>
> I have downloaded eclipse from internet and then run autoupdates through
> help->software updates from following site
> http://download.eclipse.org/releases/europa/
>
> Regarding TPTP versions,
>
> In my software updates and Add-ons, I can see following TPTP components:
> TPTP Monitoring Tools Project
> 4.4.100.v200804180100-7V7SE9x7zhmh1yz-xOz-fBGuW9St
> TPTP Platform Project 4.5.0.v200804180100-8F82Eb49ToWvwDG3z0OLTKR_cEs8
> TPTP Profiling for Web applications
> 4.4.100.v200804180100-784Ag7GUGJVz0Z-yMEckQdoYbhA
> TPTP Reporting with BIRT
> 4.4.100.v200802291616-7J7K_77i0i7EsQgZWz0mYnKhiiyD
> TPTP Test Framework and Tools Project
> 4.3.200.v200805091443-7F7_EAU7SnbjlBGPQ2r6Nij2r6Np
> TPTP Tracing and Profiling Tools Project
> 4.4.100.v200802291616-7F78CE7VXNA6M-BKOmcZdZPWaTC
>
> Regarding testsuite.
> ===================
> just trying to create a same test suite which is shown in the demo example
> in follwoing link
> http://www.eclipse.org/tptp/home/documents/tutorials/screenc asts/tptpJunit.html
>
>
> I have not installed any agent controller or integrated agent controller
> (IAC).
>
> I am also not sure about how to enable Tester capabilty in RAD
>
> Thanx and Regards
> Ankur
Re: TPTP with Eclipse and RAD Issue [message #134247 is a reply to message #134130] Mon, 11 August 2008 08:07 Go to previous messageGo to next message
Ankur Shah is currently offline Ankur Shah
Messages: 7
Registered: July 2009
Junior Member
Thanx Eugene,
It worked now.

As i am very new to this TPTP framwork so facing some more issues as well.

Currently another issue i am facing is that while trying to run that TPTP
suite i am not getting any errors and it shows progress bar till 60% and
then it disappears but it is not generating the .execution file also. Here
let me mention that I am trying to create one TPTPJunittests with some
included JARS and Some dependent project inclusion.

Do you have any idea where i can see the logs if there is no execution
files generated? As there must be some errors exists right ? btw there is
no compilation error.

Thanx again for your help

Thanx and Regards
Ankur Shah
Re: TPTP with Eclipse and RAD Issue [message #134285 is a reply to message #134247] Tue, 12 August 2008 06:37 Go to previous message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Ankur,
Are you running locally or on a remote machine? Are you using the IAC
or Agent Controller?

If no *.execution file was generated for the test execution, check your
..log file for errors.

Can you attach your test suite or project?

Paul
"Ankur Shah" <ankur.shah@in.ibm.com> wrote in message
news:7ad6a254dc6ad27cf677f397d8d7f51d$1@www.eclipse.org...
> Thanx Eugene,
> It worked now.
>
> As i am very new to this TPTP framwork so facing some more issues as well.
>
> Currently another issue i am facing is that while trying to run that TPTP
> suite i am not getting any errors and it shows progress bar till 60% and
> then it disappears but it is not generating the .execution file also. Here
> let me mention that I am trying to create one TPTPJunittests with some
> included JARS and Some dependent project inclusion.
>
> Do you have any idea where i can see the logs if there is no execution
> files generated? As there must be some errors exists right ? btw there is
> no compilation error.
>
> Thanx again for your help
>
> Thanx and Regards
> Ankur Shah
>
Previous Topic:TPTP Agent Controller is not running
Next Topic:Error while running a test in standard mode
Goto Forum:
  


Current Time: Fri Jul 25 14:16:09 EDT 2014

Powered by FUDForum. Page generated in 0.01689 seconds