Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Problem with TPTP Ant script
Problem with TPTP Ant script [message #133617] Thu, 31 July 2008 12:01 Go to next message
Vincent MAHE is currently offline Vincent MAHE
Messages: 129
Registered: July 2009
Senior Member
I try to launch an AGR test with Ant, as explain in documentation.
I found the "test.xml" sample file in the "ant-tptp.jar" library and
adapt it to my needs.
BUT it seems the Ant tool add the project name ("ANewProject") at the
beginning of the (elseway correct) testsuite file path, which it cannot
find afterall:

Buildfile:
/local/vmahe/OpenEmbeDD_DEV/org.openembedd.tests.agr_exp/tes t_launch.xml
test:
[tptp:test] Test execution started.
[tptp:test] Test
'/local/vmahe/OpenEmbeDD_DEV/org.openembedd.tests.agr_exp/Fi rstAgrTest.testsuite'
started.
[tptp:test]
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl$1Diagnos ticWrappedException:
org.eclipse.core.internal.resources.ResourceException: Resource
'/ANewProject/local/vmahe/OpenEmbeDD_DEV/org.openembedd.test s.agr_exp/FirstAgrTest.testsuite'
does not exist.
[tptp:test] at
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.handleDe mandLoadException(ResourceSetImpl.java:315)
[tptp:test] at
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLo adHelper(ResourceSetImpl.java:274)
[tptp:test] at
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getResou rce(ResourceSetImpl.java:397)
[tptp:test] at
org.eclipse.hyades.test.core.services.AbstractTestExecutionS ervice.loadModelElement(AbstractTestExecutionService.java:86 0)
[tptp:test] at
org.eclipse.hyades.test.core.services.AbstractTestExecutionS ervice.loadTestSuite(AbstractTestExecutionService.java:879)
[tptp:test] at
org.eclipse.hyades.test.core.services.AbstractTestExecutionS ervice.beforeLaunch(AbstractTestExecutionService.java:291)
[tptp:test] at
org.eclipse.hyades.test.core.services.AbstractTestExecutionS ervice.execute(AbstractTestExecutionService.java:589)
[tptp:test] at
org.eclipse.hyades.automation.server.AbstractService.execute (AbstractService.java:43)
[tptp:test] at
org.eclipse.hyades.automation.server.ServiceProxy$1.run(Serv iceProxy.java:139)
[tptp:test] at
org.eclipse.hyades.automation.core.utils.ReusableThread.run( ReusableThread.java:131)
[tptp:test] at java.lang.Thread.run(Thread.java:619)
[tptp:test] Caused by:
org.eclipse.core.internal.resources.ResourceException: Resource
'/ANewProject/local/vmahe/OpenEmbeDD_DEV/org.openembedd.test s.agr_exp/FirstAgrTest.testsuite'
does not exist.
[tptp:test] at
org.eclipse.core.internal.resources.Resource.checkExists(Res ource.java:317)
[tptp:test] at
org.eclipse.core.internal.resources.Resource.checkAccessible (Resource.java:194)
[tptp:test] at
org.eclipse.core.internal.resources.File.getContents(File.ja va:296)
[tptp:test] at
org.eclipse.core.internal.resources.File.getContents(File.ja va:287)
[tptp:test] at
org.eclipse.hyades.models.hierarchy.util.HierarchyURIConvert erImpl$WorkbenchHelper.createPlatformResourceInputStream(Hie rarchyURIConverterImpl.java:290)
[tptp:test] at
org.eclipse.hyades.models.hierarchy.util.HierarchyURIConvert erImpl.createPlatformResourceInputStream(HierarchyURIConvert erImpl.java:368)
[tptp:test] at
org.eclipse.emf.ecore.resource.impl.URIConverterImpl.createI nputStream(URIConverterImpl.java:441)
[tptp:test] at
org.eclipse.emf.ecore.resource.impl.URIConverterImpl.createI nputStream(URIConverterImpl.java:457)
[tptp:test] at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(Resour ceImpl.java:1212)
[tptp:test] at
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLo ad(ResourceSetImpl.java:255)
[tptp:test] at
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLo adHelper(ResourceSetImpl.java:270)
[tptp:test] ... 9 more
Re: Problem with TPTP Ant script [message #133844 is a reply to message #133617] Wed, 06 August 2008 07:04 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Vincent,
The 'ANewProject' string must be coming from your Ant script since it
does not appear anywhere in the source. Can you attach your Ant script?

Paul
"Vincent Mahe" <vmahe@irisa.fr> wrote in message
news:g6snl6$bfn$1@build.eclipse.org...
>I try to launch an AGR test with Ant, as explain in documentation.
> I found the "test.xml" sample file in the "ant-tptp.jar" library and adapt
> it to my needs.
> BUT it seems the Ant tool add the project name ("ANewProject") at the
> beginning of the (elseway correct) testsuite file path, which it cannot
> find afterall:
>
> Buildfile:
> /local/vmahe/OpenEmbeDD_DEV/org.openembedd.tests.agr_exp/tes t_launch.xml
> test:
> [tptp:test] Test execution started.
> [tptp:test] Test
> '/local/vmahe/OpenEmbeDD_DEV/org.openembedd.tests.agr_exp/Fi rstAgrTest.testsuite'
> started.
> [tptp:test]
> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl$1Diagnos ticWrappedException:
> org.eclipse.core.internal.resources.ResourceException: Resource
> '/ANewProject/local/vmahe/OpenEmbeDD_DEV/org.openembedd.test s.agr_exp/FirstAgrTest.testsuite'
> does not exist.
> [tptp:test] at
> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.handleDe mandLoadException(ResourceSetImpl.java:315)
> [tptp:test] at
> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLo adHelper(ResourceSetImpl.java:274)
> [tptp:test] at
> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getResou rce(ResourceSetImpl.java:397)
> [tptp:test] at
> org.eclipse.hyades.test.core.services.AbstractTestExecutionS ervice.loadModelElement(AbstractTestExecutionService.java:86 0)
> [tptp:test] at
> org.eclipse.hyades.test.core.services.AbstractTestExecutionS ervice.loadTestSuite(AbstractTestExecutionService.java:879)
> [tptp:test] at
> org.eclipse.hyades.test.core.services.AbstractTestExecutionS ervice.beforeLaunch(AbstractTestExecutionService.java:291)
> [tptp:test] at
> org.eclipse.hyades.test.core.services.AbstractTestExecutionS ervice.execute(AbstractTestExecutionService.java:589)
> [tptp:test] at
> org.eclipse.hyades.automation.server.AbstractService.execute (AbstractService.java:43)
> [tptp:test] at
> org.eclipse.hyades.automation.server.ServiceProxy$1.run(Serv iceProxy.java:139)
> [tptp:test] at
> org.eclipse.hyades.automation.core.utils.ReusableThread.run( ReusableThread.java:131)
> [tptp:test] at java.lang.Thread.run(Thread.java:619)
> [tptp:test] Caused by:
> org.eclipse.core.internal.resources.ResourceException: Resource
> '/ANewProject/local/vmahe/OpenEmbeDD_DEV/org.openembedd.test s.agr_exp/FirstAgrTest.testsuite'
> does not exist.
> [tptp:test] at
> org.eclipse.core.internal.resources.Resource.checkExists(Res ource.java:317)
> [tptp:test] at
> org.eclipse.core.internal.resources.Resource.checkAccessible (Resource.java:194)
> [tptp:test] at
> org.eclipse.core.internal.resources.File.getContents(File.ja va:296)
> [tptp:test] at
> org.eclipse.core.internal.resources.File.getContents(File.ja va:287)
> [tptp:test] at
> org.eclipse.hyades.models.hierarchy.util.HierarchyURIConvert erImpl$WorkbenchHelper.createPlatformResourceInputStream(Hie rarchyURIConverterImpl.java:290)
> [tptp:test] at
> org.eclipse.hyades.models.hierarchy.util.HierarchyURIConvert erImpl.createPlatformResourceInputStream(HierarchyURIConvert erImpl.java:368)
> [tptp:test] at
> org.eclipse.emf.ecore.resource.impl.URIConverterImpl.createI nputStream(URIConverterImpl.java:441)
> [tptp:test] at
> org.eclipse.emf.ecore.resource.impl.URIConverterImpl.createI nputStream(URIConverterImpl.java:457)
> [tptp:test] at
> org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(Resour ceImpl.java:1212)
> [tptp:test] at
> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLo ad(ResourceSetImpl.java:255)
> [tptp:test] at
> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLo adHelper(ResourceSetImpl.java:270)
> [tptp:test] ... 9 more
Re: Problem with TPTP Ant script [message #133858 is a reply to message #133844] Wed, 06 August 2008 07:19 Go to previous message
Vincent MAHE is currently offline Vincent MAHE
Messages: 129
Registered: July 2009
Senior Member
Paul Slauenwhite a écrit :
> Hi Vincent,
> The 'ANewProject' string must be coming from your Ant script since it
> does not appear anywhere in the source. Can you attach your Ant script?
>
> Paul
> "Vincent Mahe" <vmahe@irisa.fr> wrote in message
> news:g6snl6$bfn$1@build.eclipse.org...
>> I try to launch an AGR test with Ant, as explain in documentation.
>> I found the "test.xml" sample file in the "ant-tptp.jar" library and adapt
>> it to my needs.
>> BUT it seems the Ant tool add the project name ("ANewProject") at the
>> beginning of the (elseway correct) testsuite file path, which it cannot
>> find afterall:
>>
>> Buildfile:
>> /local/vmahe/OpenEmbeDD_DEV/org.openembedd.tests.agr_exp/tes t_launch.xml
>> test:
>> [tptp:test] Test execution started.
>> [tptp:test] Test
>> '/local/vmahe/OpenEmbeDD_DEV/org.openembedd.tests.agr_exp/Fi rstAgrTest.testsuite'
>> started.
>> [tptp:test]
>> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl$1Diagnos ticWrappedException:
>> org.eclipse.core.internal.resources.ResourceException: Resource
>> '/ANewProject/local/vmahe/OpenEmbeDD_DEV/org.openembedd.test s.agr_exp/FirstAgrTest.testsuite'
>> does not exist.
>> [tptp:test] at
>> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.handleDe mandLoadException(ResourceSetImpl.java:315)
>> [tptp:test] at
>> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLo adHelper(ResourceSetImpl.java:274)
>> [tptp:test] at

The problem was coming from the fact I thought the project was a target
(same for the workspace). After one week of different tries (including a
direct programming of the launch), I finally understood I was wrong.

Sorry for not closing the thread. I forgot :-(
Thank you for your many answers.

Vincent
Previous Topic:TPTP version
Next Topic:Deprecated Editors in org.eclipse.hyades.test.tools.ui
Goto Forum:
  


Current Time: Sat Apr 19 09:06:29 EDT 2014

Powered by FUDForum. Page generated in 0.10337 seconds