Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Problems after upgrading to Spring 3.1.2(java.lang.ClassNotFoundException: org.springframework.web.SpringServletContainerInitializer)
Problems after upgrading to Spring 3.1.2 [message #953608] Mon, 22 October 2012 11:40 Go to next message
Thorsten Schlathölter is currently offline Thorsten Schlathölter
Messages: 208
Registered: February 2012
Location: Düsseldorf
Senior Member
Hi,
I tried to upgrade the user region of Virgo 3.5.0 from Springframework 3.0.5 to version 3.1.2.

I followed the following FAQ:

http://wiki.eclipse.org/Virgo/FAQ#How_can_I_change_the_version_of_Spring_framework_in_the_user_region.3F

The problem is now that I get the following error when my plan is loaded:

[2012-10-22 12:28:11.428] ERROR start-signalling-5           org.apache.catalina.startup.ContextConfig                         The ServletContentInitializer [org.springframework.web.SpringServletContainerInitializer] could not be created java.lang.ClassNotFoundException: org.springframework.web.SpringServletContainerInitializer
	at org.eclipse.gemini.web.tomcat.internal.loading.BundleWebappClassLoader.loadClass(BundleWebappClassLoader.java:307)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:247)
	at org.apache.catalina.startup.ContextConfig.getServletContainerInitializer(ContextConfig.java:1601)
	at org.apache.catalina.startup.ContextConfig.processServletContainerInitializers(ContextConfig.java:1519)
	at org.apache.catalina.startup.ContextConfig.webConfig(ContextConfig.java:1222)
	at org.apache.catalina.startup.ContextConfig.configureStart(ContextConfig.java:855)
	at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:345)
	at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
	at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:90)
	at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5161)
	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
	at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:895)
	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:871)
	at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:615)
	at org.eclipse.gemini.web.tomcat.internal.TomcatServletContainer.startWebApplication(TomcatServletContainer.java:125)
	at org.eclipse.gemini.web.internal.StandardWebApplication.start(StandardWebApplication.java:95)
	at org.eclipse.virgo.web.core.internal.WebBundleLifecycleListener.onStarted(WebBundleLifecycleListener.java:122)
	at org.eclipse.virgo.kernel.install.artifact.internal.StandardArtifactStateMonitor.onStarted(StandardArtifactStateMonitor.java:271)
	at org.eclipse.virgo.kernel.install.artifact.internal.AbstractInstallArtifact.asyncStartSucceeded(AbstractInstallArtifact.java:319)
	at org.eclipse.virgo.kernel.install.artifact.internal.AbstractInstallArtifact.access$0(AbstractInstallArtifact.java:316)
	at org.eclipse.virgo.kernel.install.artifact.internal.AbstractInstallArtifact$StateMonitorSignal.signalSuccessfulCompletion(AbstractInstallArtifact.java:252)
	at org.eclipse.virgo.kernel.core.internal.BundleStartTracker$1.run(BundleStartTracker.java:140)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
	at java.lang.Thread.run(Thread.java:619)



SpringServletContainerInitializer is part of the org.springframework.web bundle which is available in version 3.1.2 in ext. I have no idea what might cause the problem. Same plan works fine with the original virgo (with Springframework 3.0.5)

Any hint would be appreciated.

Regards,
Thorsten
Re: Problems after upgrading to Spring 3.1.2 [message #963756 is a reply to message #953608] Tue, 30 October 2012 02:39 Go to previous message
Borislav Kapukaranov is currently offline Borislav Kapukaranov
Messages: 80
Registered: September 2010
Member
Hi,

Did you tried that on Virgo 3.6.0. We have successfully upgraded there to Spring 3.1 and seen this issue in the process? I think we fixed it for 3.6.0.M01.

Best Regards
Bobby
Previous Topic:can virgo runs as single region(without kernel/user isolation) mode?
Next Topic:virgo distribution without user region and with repository
Goto Forum:
  


Current Time: Tue Oct 21 12:24:25 GMT 2014

Powered by FUDForum. Page generated in 0.02641 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software