Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » After "Check for updates" Eclipse fails to load
After "Check for updates" Eclipse fails to load [message #953602] Mon, 22 October 2012 11:37 Go to next message
Bruce Cartland is currently offline Bruce Cartland
Messages: 3
Registered: October 2012
Junior Member
I'm running Mint 13 KDE 64bit.

I tried the CDT version and the JDT versions. They both startup fine Smile . I run "Check for updates" which does update a bunch of stuff successfully - until the restart and it no longer loads Sad

Any pointers as to what is going wrong?

java -version reports
=============================================
java version "1.7.0_07" OpenJDK Runtime Environment (IcedTea7 2.3.2) (7u7-2.3.2a-0ubuntu0.12.04.1)
OpenJDK 64-Bit Server VM (build 23.2-b09, mixed mode)
=============================================

The log, which I cut down, reports:
=============================================
!SESSION 2012-10-22 21:35:27.575 -----------------------------------------------
eclipse.buildId=M20120914-1800
java.version=1.7.0_07
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_AU
Framework arguments: -product org.eclipse.epp.package.java.product
Command-line arguments: -os linux -ws gtk -arch x86_64 -product org.eclipse.epp.package.java.product

!ENTRY org.eclipse.osgi 2 0 2012-10-22 21:35:32.346
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-22 21:35:32.346
!MESSAGE Bundle reference:file:plugins/org.eclipse.recommenders.completion.rcp.calls_1.0.0.v20120914-1432-b175.jar was not resolved.
!SUBENTRY 2 org.eclipse.recommenders.completion.rcp.calls 2 0 2012-10-22 21:35:32.346
!MESSAGE Missing required bundle org.eclipse.recommenders.utils_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-22 21:35:32.346
!MESSAGE Bundle reference:file:plugins/org.eclipse.wst.dtd.ui_1.0.700.v201203081826.jar was not resolved.

etc,etc,etc..........

!ENTRY org.eclipse.osgi 4 0 2012-10-22 21:35:32.522
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "org.eclipse.ui.ide.workbench" could not be found in the registry. The applications available are: org.eclipse.ant.core.antRunner, org.eclipse.equinox.app.error, org.eclipse.equinox.p2.director, org.eclipse.equinox.p2.garbagecollector.application, org.eclipse.equinox.p2.publisher.InstallPublisher, org.eclipse.equinox.p2.publisher.EclipseGenerator, org.eclipse.equinox.p2.publisher.ProductPublisher, org.eclipse.equinox.p2.publisher.FeaturesAndBundlesPublisher, org.eclipse.equinox.p2.reconciler.application, org.eclipse.equinox.p2.repository.repo2runnable, org.eclipse.equinox.p2.repository.metadataverifier, org.eclipse.equinox.p2.artifact.repository.mirrorApplication, org.eclipse.equinox.p2.metadata.repository.mirrorApplication, org.eclipse.equinox.p2.updatesite.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.CategoryPublisher, org.eclipse.jdt.apt.core.aptBuild, org.eclipse.help.base.infocenterApplication, org.
eclipse.help.base.helpApplication, org.eclipse.help.base.indexTool, org.eclipse.jdt.core.JavaCodeFormatter, org.eclipse.jdt.core.JavaIndexer.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

=============================================
Re: After "Check for updates" Eclipse fails to load [message #954839 is a reply to message #953602] Tue, 23 October 2012 09:41 Go to previous messageGo to next message
Bruce Cartland is currently offline Bruce Cartland
Messages: 3
Registered: October 2012
Junior Member
Soooo, openjdk-7-jre-lib was installed. Used synaptic to install openjdk-7-jdk and openjdk-7-doc. On a fresh install of Eclipse (eclipse-java-juno-linux-gtk-x86_64.tar.gz), I ran "Check for updates". This time, after updating most packages, it failed and reported a corrupt zip file. Shut down Eclipse, started it up again, then ran "Check for updates" again. This time it completed successfully and prompted for a restart. The restart worked. Did "Check for updates" and this time it reported everything up to date.

Tried the whole thing again with a fresh install (unzip of the package, openjdk installed as above). Got the original error?????

I speculate therefore that the update process is fragile and can result in corrupt downloads which corrupt the installation..... but have no idea really. At this stage I've got a working (updated) installation and will move on.
Re: After "Check for updates" Eclipse fails to load [message #955023 is a reply to message #954839] Tue, 23 October 2012 12:41 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3231
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 10/23/2012 03:41 AM, Bruce Cartland wrote:
> Soooo, openjdk-7-jre-lib was installed. Used synaptic to install
> openjdk-7-jdk and openjdk-7-doc. On a fresh install of Eclipse
> (eclipse-java-juno-linux-gtk-x86_64.tar.gz), I ran "Check for updates".
> This time, after updating most packages, it failed and reported a
> corrupt zip file. Shut down Eclipse, started it up again, then ran
> "Check for updates" again. This time it completed successfully and
> prompted for a restart. The restart worked. Did "Check for updates" and
> this time it reported everything up to date.
>
> Tried the whole thing again with a fresh install (unzip of the package,
> openjdk installed as above). Got the original error?????
>
> I speculate therefore that the update process is fragile and can result
> in corrupt downloads which corrupt the installation..... but have no
> idea really. At this stage I've got a working (updated) installation and
> will move on.

I know openjdk is supposed to work, but as long as the real Java from
Sun (Oracle) is still available (and free), I'd never run Eclipse on
anything else. No, I don't know that this has anything to do with your
problem. Just saying, though.
Re: After "Check for updates" Eclipse fails to load [message #964956 is a reply to message #955023] Tue, 30 October 2012 23:09 Go to previous message
Bruce Cartland is currently offline Bruce Cartland
Messages: 3
Registered: October 2012
Junior Member
Well, with all the broohaha over licencing and Ubuntu pulling the Oracle version, etc, etc, I've been directed to provide support for OpenJDK, so Oracle JDK is not an option (a perfectly reasonable request IMO).

I have another Linux machine with OpenJDK 6 on it and everything worked 100%. Perhaps it's a problem with OpenJDK 7 ?? Anyway, as I said, it's working now.
Previous Topic:Cannot add jars in build path
Next Topic:Eclipse Console showing old exceptions
Goto Forum:
  


Current Time: Fri Oct 31 20:10:06 GMT 2014

Powered by FUDForum. Page generated in 0.02321 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software