Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » No project with name and version in database - dburl(question about error message from Jubula - dburl)
No project with name and version in database - dburl [message #953538] Mon, 22 October 2012 10:27 Go to next message
Erik Gilbert is currently offline Erik Gilbert
Messages: 55
Registered: September 2010
Member
Trying to start Jubula tests using command line from batch file started with Jenkins and get error in Jenkins:

Mon Oct 22 12:14:17 CEST 2012 AUT Agent: Connecting to "localhost:60000" ...
Mon Oct 22 12:14:18 CEST 2012 AUT Agent: connection established.
Mon Oct 22 12:14:18 CEST 2012 Database: Connecting as "sa" to "jdbc:h2:~/.jubula/database/embedded;MVCC=TRUE;AUTO_SERVER=TRUE;DB_CLOSE_ON_EXIT=FALSE"...
Mon Oct 22 12:14:20 CEST 2012 Database: Connection established.
Mon Oct 22 12:14:20 CEST 2012 Database: Loading project "New Project Test 1" in version "1.2"...
Mon Oct 22 12:14:20 CEST 2012 Project: Checking completeness
!!Error occurred !!
No project with name "New Project Test 1" and version "1.2" in database
Mon Oct 22 12:14:20 CEST 2012 AUT Agent: connection closed.
Mon Oct 22 12:14:20 CEST 2012 Exit: Code 1

Batch file runs successfully when called from command line. But when batch file called from Jenkins, get the above error.

The batch file runs on Windows 7, calling testexec:

c:\jubula_6.0.01011\jubula\testexec -c c:\jubula_6.0.01011\jubula\test_config_TC1.xml

my config file, test_config_TC1.xml:

<configuration>
<project>New Project Test 1</project>
<version>1.2</version>
<autid>77211277</autid>
<dbscheme>Default Embedded (H2)</dbscheme>
<dbuser>sa</dbuser>
<dbpw></dbpw>
<server>localhost</server>
<port>60000</port>
<language>DE_DE</language>
<testsuite>TC1</testsuite>
<resultdir>c:/ARCHIVE/DEV/JUBULA/RESULT/</resultdir>
<datadir>c:/ARCHIVE/DEV/JUBULA/DATA/</datadir>
</configuration>

[Updated on: Thu, 25 October 2012 10:26]

Report message to a moderator

Re: No project with name and version in database [message #953779 is a reply to message #953538] Mon, 22 October 2012 14:22 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
Hi,

from the looks of it, you haven't entered a workspace to be used using the -data parameter (which has to be entered on the command line). This means that a new workspace gets created, which has an embedded database that doesn't contain the project. There's more information on this in this thread.

Also, in the latest version, you can use the dburl instead of the workspace to help solve this problem Smile

HTH,
Alex
Re: No project with name and version in database [message #953852 is a reply to message #953779] Mon, 22 October 2012 15:31 Go to previous messageGo to next message
Erik Gilbert is currently offline Erik Gilbert
Messages: 55
Registered: September 2010
Member
how do I add the -data parameter? I tried

c:\jubula_6.0.01011\jubula\testexec -data c:\Users\mylocal\.jubula\ -c c:\jubula_6.0.01011\jubula\test_config_TC1.xml

but still get the same error. Can I add it to the config file?
Re: No project with name and version in database [message #954841 is a reply to message #953852] Tue, 23 October 2012 09:42 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
Hi,

The -data does have to be entered on the command line, it can't be entered in the config file. Are you sure that the workspace you are using with -data has the project in its embedded database (if you use that workspace, on the machine where you are running the test, can you open the project from the ITE?). Otherwise, as I said, you can use the dburl in the config file directly.

HTH,
Alex
Re: No project with name and version in database [message #955110 is a reply to message #954841] Tue, 23 October 2012 14:18 Go to previous messageGo to next message
Erik Gilbert is currently offline Erik Gilbert
Messages: 55
Registered: September 2010
Member
Yes, the workspace I am using is the workspace that is loaded when I start the ITE. Also, I have no problems when I run the command from the command line, only from Jenkins, which currently leads me to believe this is more a Jenkins issue. Perhaps the Jenkins user doesn't have access to the Jubula workspace?

The dburl option might let me work around this issue completely but I'm not sure how to set dburl. How do I know what to set dburl to?
Re: No project with name and version in database [message #956110 is a reply to message #955110] Wed, 24 October 2012 08:47 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
Hi,

If it runs from the command line but not from Jenkins, then there is definitely a difference there. Whether it's a configuration issue or a Jenkins issue, I couldn't say right now. You can see the dburl for a database in the Database Preferences - you can copy it and use it with the -dburl parameter.

HTH,
Alex
Re: No project with name and version in database [message #957569 is a reply to message #956110] Thu, 25 October 2012 10:16 Go to previous messageGo to next message
Erik Gilbert is currently offline Erik Gilbert
Messages: 55
Registered: September 2010
Member
This problem is now resolved.

When running from Jenkins, Jubula was connecting to the following database:

Database: Connecting as "sa" to "jdbc:h2:~/.jubula/database/embedded;MVCC=TRUE;AUTO_SERVER=TRUE;DB_CLOSE_ON_EXIT=FALSE"

~/.jubula/database/embedded was the wrong database, most likely under the Jenkins workspace or who knows where

I added the following dburl to the config file:

<dburl>jdbc:h2:c:/Users/mylocal/.jubula/database/embedded;MVCC=TRUE;AUTO_SERVER=TRUE;DB_CLOSE_ON_EXIT=FALSE</dburl>

and now it works correctly.

Thanks for all the help!!


Re: No project with name and version in database [message #958774 is a reply to message #957569] Fri, 26 October 2012 07:51 Go to previous message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
Thanks for posting the answer!
Alex
Previous Topic:How to set AUT Arguments using Testexec?
Next Topic:RCP Validation Error Window not found
Goto Forum:
  


Current Time: Sat Oct 25 08:50:35 GMT 2014

Powered by FUDForum. Page generated in 0.11612 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software