Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » How can I use JPA 2.0 with hibernate under virgo(Need JPA 2.0 - hibernate combination)
How can I use JPA 2.0 with hibernate under virgo [message #953325] Mon, 22 October 2012 06:34 Go to next message
Erik Vande Velde is currently offline Erik Vande Velde
Messages: 62
Registered: September 2012
Member
When checking the hibernate libraries on ebr.springsource.com/repository/app/ I see that the most recent version of Hibernate JPA is 3.4.0.GA-A. The required bundles of that library mention Java Persistence API/com.springsource.javax.persistence/1.99.0. Why don't we have a hibernate library with JPA 2.0 ?
Re: How can I use JPA 2.0 with hibernate under virgo [message #955838 is a reply to message #953325] Wed, 24 October 2012 03:45 Go to previous messageGo to next message
Alexander Kosarev is currently offline Alexander Kosarev
Messages: 3
Registered: October 2012
Junior Member
In its MANIFEST.MF you can see
Import-Package: javax.persistence;version="[1.0.0, 2.0.0)"


It means that you can use this bundle with JPA 2. Also I use Hibernate with JPA 2 in my projects, and it works fine for me.
Re: How can I use JPA 2.0 with hibernate under virgo [message #956526 is a reply to message #955838] Wed, 24 October 2012 15:30 Go to previous message
Erik Vande Velde is currently offline Erik Vande Velde
Messages: 62
Registered: September 2012
Member
Hi Alexander. Thanks for your answer. Which exact bundle contains the manifest with Import-Package: javax.persistence;version="[1.0.0, 2.0.0)" ?
Previous Topic:OSGi manifests for Spring 3.2 (Java 7 users please note)
Next Topic:Hibernate SessionFactory as osgi:service
Goto Forum:
  


Current Time: Mon Sep 22 06:33:59 GMT 2014

Powered by FUDForum. Page generated in 0.09435 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software