Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Deprecated Editors in org.eclipse.hyades.test.tools.ui
Deprecated Editors in org.eclipse.hyades.test.tools.ui [message #133462] Tue, 29 July 2008 04:08 Go to next message
Eclipse User
Originally posted by: guenter.oeller.mathconsult.co.at

Hi,

I'm wondering when this editors will be replaced by editors using Eclipse
Forms?

I'm doing a Master theses based on the org.eclipse.hyades.test.tools
plugins. For my Master theses I have to add the possibility to show and
edit HTTP Responses and Assertions.

My first idea was to extend the
org.eclipse.hyades.test.tools.ui.common.internal.editor.Test SuiteEditorExtension
and add some new pages.
But I'm worried now because this editor is deprecated and might be
replaced soon. Do you have further information about the development of
org.eclipse.hyades.test.tools or can you give me a hint where I can find
planed activities for the next release?

Thanks very much for your help!!

Günter Öller
Re: Deprecated Editors in org.eclipse.hyades.test.tools.ui [message #133513 is a reply to message #133462] Tue, 29 July 2008 08:04 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi G
Re: Deprecated Editors in org.eclipse.hyades.test.tools.ui [message #133514 is a reply to message #133513] Tue, 29 July 2008 09:32 Go to previous messageGo to next message
Eclipse User
Originally posted by: guenter.oeller.mathconsult.co.at

Thx a lot!

I will discuss this with my tutor and ask him if we can contribute my
code. Personally, I would like to!

Günter Öller

ps: nice to see somebody cares!

Paul Slauenwhite wrote:

> Hi Günter,
> TPTP enhancement https://bugs.eclipse.org/bugs/show_bug.cgi?id=74949
> covers migrating the existing Test editors to the Eclipse flat look and TPTP
> defect https://bugs.eclipse.org/bugs/show_bug.cgi?id=175147 covers removing
> the deprecated APIs. Please add your name to the CC list for these
> Bugzillas.

> Due to recent resource changes in TPTP, we will not proceed with
> enhancement https://bugs.eclipse.org/bugs/show_bug.cgi?id=74949 until
> additional resources are added to the project.

> Since the TPTP Test editors internally use several of the deprecated
> APIs used defect https://bugs.eclipse.org/bugs/show_bug.cgi?id=175147, we
> will not proceed with this defect until replacements (e.g. enhancement
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=74949) are provided and
> documented.

> In my opinion, you should proceed with your thesis using the current
> (4.5.1) code.

> Would you be will to contribute to the TPTP project?
Re: Deprecated Editors in org.eclipse.hyades.test.tools.ui [message #133871 is a reply to message #133514] Wed, 06 August 2008 14:56 Go to previous messageGo to next message
Eclipse User
Originally posted by: guenter.oeller.mathconsult.co.at

Hi,

I will proceed based on TPTP Version 4.5.1.
And I can contribute my code/plugins and documentation. Where can I find
the requirements and/or the required process if I want to do this?

Thx,

Günter Öller


Günter Öller wrote:

> Thx a lot!

> I will discuss this with my tutor and ask him if we can contribute my
> code. Personally, I would like to!

> Günter Öller

> ps: nice to see somebody cares!

> Paul Slauenwhite wrote:

>> Hi Günter,
>> TPTP enhancement https://bugs.eclipse.org/bugs/show_bug.cgi?id=74949
>> covers migrating the existing Test editors to the Eclipse flat look and
TPTP
>> defect https://bugs.eclipse.org/bugs/show_bug.cgi?id=175147 covers removing
>> the deprecated APIs. Please add your name to the CC list for these
>> Bugzillas.

>> Due to recent resource changes in TPTP, we will not proceed with
>> enhancement https://bugs.eclipse.org/bugs/show_bug.cgi?id=74949 until
>> additional resources are added to the project.

>> Since the TPTP Test editors internally use several of the deprecated
>> APIs used defect https://bugs.eclipse.org/bugs/show_bug.cgi?id=175147, we
>> will not proceed with this defect until replacements (e.g. enhancement
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=74949) are provided and
>> documented.

>> In my opinion, you should proceed with your thesis using the current
>> (4.5.1) code.

>> Would you be will to contribute to the TPTP project?
Re: Deprecated Editors in org.eclipse.hyades.test.tools.ui [message #133909 is a reply to message #133871] Thu, 07 August 2008 06:28 Go to previous message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi G
Previous Topic:Problem with TPTP Ant script
Next Topic:C/C++ Code Review Provider: unable to satisfy dependency
Goto Forum:
  


Current Time: Mon Apr 21 11:45:28 EDT 2014

Powered by FUDForum. Page generated in 0.10207 seconds