Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » I could not open static analysis windows
I could not open static analysis windows [message #132860] Thu, 17 July 2008 19:34 Go to next message
Eclipse User
Originally posted by: real.self.gmail.com

Hi,

I just installed the newest version of TPTP 4.5.0. I can profile my java
program to see the execution time, memory allocation and other stuff. But
when I want to look at the static analysis service, I could not find it.

I follow one article saying that I could configure the
windows->customization prospectives->command-->analysis. But there is no
analysis option there. I also follow the help function in the Eclipse
helper article, which saying that I can just run->analysis, but again I
could not find this option.

What is wrong with my procedures? Any help can be appreciated.

Thanks.

Jiangfan
Re: I could not open static analysis windows [message #132873 is a reply to message #132860] Thu, 17 July 2008 20:02 Go to previous messageGo to next message
Eugene Chan is currently offline Eugene Chan
Messages: 287
Registered: July 2009
Senior Member
Hi,

Static Analysis component was moved from a General Availability (GA)
component to an As-Is component. It is no longer packaged in TPTP default
package. You will need to download the component from the Download page >
As-Is component area.

Please try download and unzip the component to the eclipse/dropins folder
and launch eclipse with a -clean.

Eugene

"jiangfan shi" <real.self@gmail.com> wrote in message
news:f5120cc388cdd77b95fc9dcb74466f94$1@www.eclipse.org...
> Hi,
>
> I just installed the newest version of TPTP 4.5.0. I can profile my java
> program to see the execution time, memory allocation and other stuff. But
> when I want to look at the static analysis service, I could not find it.
>
> I follow one article saying that I could configure the
> windows->customization prospectives->command-->analysis. But there is no
> analysis option there. I also follow the help function in the Eclipse
> helper article, which saying that I can just run->analysis, but again I
> could not find this option.
>
> What is wrong with my procedures? Any help can be appreciated.
>
> Thanks.
>
> Jiangfan
>
Re: I could not open static analysis windows [message #132886 is a reply to message #132873] Thu, 17 July 2008 21:28 Go to previous message
Eclipse User
Originally posted by: real.self.gmail.com

Thanks. The "-clean" and "dropin" are the keys for resolving my problem.

Best.

jiangfan
Previous Topic:Profiling WEB-INF classes
Next Topic:my test*.execution could not be edited
Goto Forum:
  


Current Time: Mon Sep 22 02:28:32 GMT 2014

Powered by FUDForum. Page generated in 0.01877 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software