Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » scout » When I follow the Tutorials of "HelloWorld" I get these Error
When I follow the Tutorials of "HelloWorld" I get these Error [message #949692] Fri, 19 October 2012 07:43 Go to next message
yuan yao is currently offline yuan yao
Messages: 4
Registered: October 2012
Junior Member
Hello guys,I am a new to Scout Project. When I follow the tutorials of "HelloWorld", I get these error ,and I cannot start the example project success. I don't know why. Please Help!

Errors:
!SESSION 2012-10-19 15:24:08.421 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_25
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=zh_CN
Framework arguments: -product com.boxun.lab.helloworld.ui.swing.product
Command-line arguments: -product com.boxun.lab.helloworld.ui.swing.product -data D:\eclipse-juno\workspace/../runtime-helloworld-swing-client.product -dev file:D:/eclipse-juno/workspace/.metadata/.plugins/org.eclipse.pde.core/helloworld-swing-client.product/dev.properties -os win32 -ws win32 -arch x86 -consoleLog

!ENTRY org.eclipse.equinox.app 0 0 2012-10-19 15:24:09.217
!MESSAGE Product com.boxun.lab.helloworld.ui.swing.product could not be found.

!ENTRY org.eclipse.osgi 2 0 2012-10-19 15:24:09.232
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.232
!MESSAGE Bundle update@plugins/org.w3c.dom.svg_1.1.0.v201011041433.jar was not resolved.
!SUBENTRY 2 org.w3c.dom.svg 2 0 2012-10-19 15:24:09.232
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=JavaSE)(version=1.3))(&(osgi.ee=CDC/Foundation)(version=1.0)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.232
!MESSAGE Bundle update@rap_target/plugins/org.apache.batik.dom.svg_1.6.0.v201011041432.jar was not resolved.
!SUBENTRY 2 org.apache.batik.dom.svg 2 0 2012-10-19 15:24:09.232
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=JavaSE)(version=1.3)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.232
!MESSAGE Bundle update@rap_target/plugins/org.apache.batik.dom_1.6.0.v201011041432.jar was not resolved.
!SUBENTRY 2 org.apache.batik.dom 2 0 2012-10-19 15:24:09.232
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=JavaSE)(version=1.3)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.232
!MESSAGE Bundle update@plugins/org.w3c.dom.smil_1.0.1.v200903091627.jar was not resolved.
!SUBENTRY 2 org.w3c.dom.smil 2 0 2012-10-19 15:24:09.232
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=JavaSE)(version=1.3))(&(osgi.ee=CDC/Foundation)(version=1.0)))".
!SUBENTRY 2 org.w3c.dom.smil 2 0 2012-10-19 15:24:09.232
!MESSAGE Missing imported package org.w3c.dom.events_[3.0.0,4.0.0).

!ENTRY org.eclipse.osgi 2 0 2012-10-19 15:24:09.232
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.232
!MESSAGE Bundle org.apache.batik.css_1.6.0.v201011041432 was not resolved.
!SUBENTRY 2 org.apache.batik.css 2 0 2012-10-19 15:24:09.232
!MESSAGE Missing required bundle org.w3c.dom.svg_[1.1.0,1.3.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.232
!MESSAGE Bundle com.boxun.lab.helloworld.ui.swing_1.0.0.qualifier was not resolved.
!SUBENTRY 2 com.boxun.lab.helloworld.ui.swing 2 0 2012-10-19 15:24:09.232
!MESSAGE Missing required bundle com.boxun.lab.helloworld.client_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.232
!MESSAGE Bundle org.w3c.dom.svg_1.1.0.v201011041433 was not resolved.
!SUBENTRY 2 org.w3c.dom.svg 2 0 2012-10-19 15:24:09.232
!MESSAGE Missing required bundle org.w3c.dom.smil_ was not resolved.
!SUBENTRY 2 org.w3c.dom.smil 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing imported package org.w3c.dom.events_ was not resolved.
!SUBENTRY 2 com.boxun.lab.helloworld.client 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.eclipse.scout.svg.client_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.248
!MESSAGE Bundle org.apache.batik.parser_1.6.0.v201011041432 was not resolved.
!SUBENTRY 2 org.apache.batik.parser 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.w3c.dom.svg_[1.1.0,1.3.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.248
!MESSAGE Bundle org.apache.batik.bridge_1.6.0.v201011041432 was not resolved.
!SUBENTRY 2 org.apache.batik.bridge 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.css_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.bridge 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.dom_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.bridge 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.dom.svg_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.bridge 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.parser_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.bridge 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.w3c.dom.svg_[1.1.0,1.3.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.248
!MESSAGE Bundle org.apache.batik.dom.svg_1.6.0.v201011041432 was not resolved.
!SUBENTRY 2 org.apache.batik.dom.svg 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.css_ was not resolved.
!SUBENTRY 2 org.eclipse.scout.svg.ui.swing 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.eclipse.scout.svg.client_3.7.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.248
!MESSAGE Bundle org.apache.batik.swing_1.6.0.v201011041432 was not resolved.
!SUBENTRY 2 org.apache.batik.swing 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.bridge_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.swing 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.dom_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.swing 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.dom.svg_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.swing 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.w3c.dom.svg_[1.1.0,1.3.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.248
!MESSAGE Bundle org.apache.batik.transcoder_1.6.0.v201011041432 was not resolved.
!SUBENTRY 2 org.apache.batik.transcoder 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.bridge_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.transcoder 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.dom_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.transcoder 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.dom.svg_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.transcoder 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.w3c.dom.svg_[1.1.0,1.3.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.248
!MESSAGE Bundle org.eclipse.scout.svg.client_3.8.1.201209171521 was not resolved.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.w3c.dom.svg_1.1.0.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.bridge_1.6.0.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.css_1.6.0.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.dom_1.6.0.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.dom.svg_1.6.0.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.parser_1.6.0.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.swing_1.6.0.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.transcoder_1.6.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.248
!MESSAGE Bundle org.apache.batik.dom_1.6.0.v201011041432 was not resolved.
!SUBENTRY 2 org.apache.batik.dom 2 0 2012-10-19 15:24:09.248
!MESSAGE Missing required bundle org.apache.batik.css_ was not resolved.
!SUBENTRY 2 org.apache.batik.css 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.w3c.dom.svg_[1.1.0,1.3.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.264
!MESSAGE Bundle com.boxun.lab.helloworld.ui.swing_1.0.0.qualifier was not resolved.
!SUBENTRY 2 com.boxun.lab.helloworld.ui.swing 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle com.boxun.lab.helloworld.client_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.264
!MESSAGE Bundle org.w3c.dom.svg_1.1.0.v201011041433 was not resolved.
!SUBENTRY 2 org.w3c.dom.svg 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.w3c.dom.smil_ was not resolved.
!SUBENTRY 2 org.w3c.dom.smil 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing imported package org.w3c.dom.events_ was not resolved.
!SUBENTRY 2 com.boxun.lab.helloworld.client 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.eclipse.scout.svg.client_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.264
!MESSAGE Bundle org.apache.batik.parser_1.6.0.v201011041432 was not resolved.
!SUBENTRY 2 org.apache.batik.parser 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.w3c.dom.svg_[1.1.0,1.3.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.264
!MESSAGE Bundle org.apache.batik.bridge_1.6.0.v201011041432 was not resolved.
!SUBENTRY 2 org.apache.batik.bridge 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.css_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.bridge 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.dom_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.bridge 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.dom.svg_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.bridge 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.parser_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.bridge 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.w3c.dom.svg_[1.1.0,1.3.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.264
!MESSAGE Bundle org.apache.batik.dom.svg_1.6.0.v201011041432 was not resolved.
!SUBENTRY 2 org.apache.batik.dom.svg 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.css_ was not resolved.
!SUBENTRY 2 org.eclipse.scout.svg.ui.swing 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.eclipse.scout.svg.client_3.7.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.264
!MESSAGE Bundle org.apache.batik.swing_1.6.0.v201011041432 was not resolved.
!SUBENTRY 2 org.apache.batik.swing 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.bridge_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.swing 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.dom_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.swing 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.dom.svg_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.swing 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.w3c.dom.svg_[1.1.0,1.3.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.264
!MESSAGE Bundle org.apache.batik.transcoder_1.6.0.v201011041432 was not resolved.
!SUBENTRY 2 org.apache.batik.transcoder 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.bridge_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.transcoder 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.dom_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.transcoder 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.dom.svg_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.transcoder 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.w3c.dom.svg_[1.1.0,1.3.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.264
!MESSAGE Bundle org.eclipse.scout.svg.client_3.8.1.201209171521 was not resolved.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.w3c.dom.svg_1.1.0.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.bridge_1.6.0.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.css_1.6.0.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.dom_1.6.0.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.dom.svg_1.6.0.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.parser_1.6.0.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.swing_1.6.0.
!SUBENTRY 2 org.eclipse.scout.svg.client 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.transcoder_1.6.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-10-19 15:24:09.264
!MESSAGE Bundle org.apache.batik.dom_1.6.0.v201011041432 [42] was not resolved.
!SUBENTRY 2 org.apache.batik.dom 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required bundle org.apache.batik.css_[1.6.0,1.7.0).
!SUBENTRY 2 org.apache.batik.dom 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing optionally imported package org.apache.xerces.parsers_0.0.0.
!SUBENTRY 2 org.apache.batik.dom 2 0 2012-10-19 15:24:09.264
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=JavaSE)(version=1.3)))".

!ENTRY org.eclipse.osgi 4 0 2012-10-19 15:24:09.264
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
at org.eclipse.equinox.launcher.Main.main(Main.java:1414)
An error has occurred. See the log file
D:\eclipse-juno\workspace\.metadata\.plugins\org.eclipse.pde.core\helloworld-swing-client.product\1350631448593.log.

My system is :
Windows 7-32bit
Eclipse-juno
Scout the latest
java jdk1.6.0_25
Re: When I follow the Tutorials of "HelloWorld" I get these Error [message #950868 is a reply to message #949692] Sat, 20 October 2012 07:17 Go to previous messageGo to next message
Matthias Zimmermann is currently offline Matthias Zimmermann
Messages: 81
Registered: February 2010
Member
> My system is :
> Windows 7-32bit
> Eclipse-juno
> Scout the latest*
> java jdk1.6.0_25

* did you download scout using the package provided unter eclipse.org/downloads?
if not: please do this and retry (scout kepler is not yet ready)
if yes: could you provide the the exact Scout version number you see (in the Eclipse you use go to menu Help -> About Eclipse -> (then click on the Scout button) and provide the version number from the tab About Eclipse Features (you should see four of them, such as "Scout Runtime"
Re: When I follow the Tutorials of "HelloWorld" I get these Error [message #956131 is a reply to message #950868] Wed, 24 October 2012 09:08 Go to previous messageGo to next message
yuan yao is currently offline yuan yao
Messages: 4
Registered: October 2012
Junior Member
Thanks a lot!

yes,i've downloaded the eclipse for scout developers,the Scout Version is 3.8.1.xxxxxx .

index.php/fa/12030/0/
  • Attachment: Scout.jpg
    (Size: 37.44KB, Downloaded 722 times)

[Updated on: Wed, 24 October 2012 09:12]

Report message to a moderator

Re: When I follow the Tutorials of "HelloWorld" I get these Error [message #963067 is a reply to message #956131] Mon, 29 October 2012 14:53 Go to previous messageGo to next message
Matthias Zimmermann is currently offline Matthias Zimmermann
Messages: 81
Registered: February 2010
Member
wasn't able to reproduce this. if this is still open please add your zipped workspace and we will have a look at it.
Re: When I follow the Tutorials of "HelloWorld" I get these Error [message #968082 is a reply to message #963067] Fri, 02 November 2012 07:22 Go to previous messageGo to next message
yuan yao is currently offline yuan yao
Messages: 4
Registered: October 2012
Junior Member
thank you !
May this problem is cased by new plugins of eclipse? Ex.Android plugins, Windowbuilder plugins?
Re: When I follow the Tutorials of "HelloWorld" I get these Error [message #971310 is a reply to message #968082] Sun, 04 November 2012 19:53 Go to previous messageGo to next message
Claudio Guglielmo is currently offline Claudio Guglielmo
Messages: 127
Registered: March 2010
Senior Member
Hi

It seems there's something wrong with the execution environment.

!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=JavaSE)(version=1.3))(&(osgi.ee=CDC/Foundation)(version=1.0)))".

Please check the java version used to launch your app. Scout requires at least java 6.

Best regards
Claudio
Re: When I follow the Tutorials of "HelloWorld" I get these Error [message #986020 is a reply to message #971310] Sat, 17 November 2012 15:26 Go to previous messageGo to next message
Omkar Mujumdar is currently offline Omkar Mujumdar
Messages: 22
Registered: October 2012
Junior Member
Hi,

I am facing similar issue almost every week. My working scout workspace stops working for my main development project all of a sudden with similar issue. If I create a new project from scratch it works fine.
My setup:

JDK 1.6.0_34
scout 3.8.3
windows 7 x64


Any pointers/advice on avoiding this will help.

Following is the log I get when launching scout server product:

----
!SESSION 2012-11-17 20:46:18.764 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_34
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments: -product com.abc.def.server.product
Command-line arguments: -product com.abc.def.server.product -data C:\Users\developer\workspace/../runtime-def-server-dev.product -dev file:C:/Users/developer/workspace/.metadata/.plugins/org.eclipse.pde.core/def-server-dev.product/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog

!ENTRY org.eclipse.equinox.app 0 0 2012-11-17 20:46:20.147
!MESSAGE Product com.abc.def.server.product could not be found.

!ENTRY org.eclipse.osgi 2 0 2012-11-17 20:46:20.317
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-17 20:46:20.318
!MESSAGE Bundle update@../../workspace/com.abc.def.server/ was not resolved.
!SUBENTRY 2 com.abc.def.server 2 0 2012-11-17 20:46:20.318
!MESSAGE Missing required bundle org.junit_0.0.0.

!ENTRY org.eclipse.osgi 2 0 2012-11-17 20:46:20.323
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-17 20:46:20.323
!MESSAGE Bundle com.abc.def.server_1.0.0.qualifier [6] was not resolved.
!SUBENTRY 2 com.abc.def.server 2 0 2012-11-17 20:46:20.323
!MESSAGE Missing required bundle org.junit_0.0.0.

!ENTRY org.eclipse.osgi 2 0 2012-11-17 20:46:20.347
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-17 20:46:20.348
!MESSAGE Bundle update@../../workspace/com.abc.def.server/ was not resolved.
!SUBENTRY 2 com.abc.def.server 2 0 2012-11-17 20:46:20.348
!MESSAGE Missing required bundle org.junit_0.0.0.

!ENTRY org.eclipse.osgi 2 0 2012-11-17 20:46:20.354
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-17 20:46:20.354
!MESSAGE Bundle com.abc.def.server_1.0.0.qualifier [6] was not resolved.
!SUBENTRY 2 com.abc.def.server 2 0 2012-11-17 20:46:20.355
!MESSAGE Missing required bundle org.junit_0.0.0.

!ENTRY org.eclipse.osgi 4 0 2012-11-17 20:46:20.358
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
at org.eclipse.equinox.launcher.Main.main(Main.java:1414)
An error has occurred. See the log file
C:\Users\developer\workspace\.metadata\.plugins\org.eclipse.pde.core\def-server-dev.product\1353165379061.log.


[Updated on: Sat, 17 November 2012 15:27]

Report message to a moderator

Re: When I follow the Tutorials of "HelloWorld" I get these Error [message #986025 is a reply to message #986020] Sat, 17 November 2012 16:23 Go to previous messageGo to next message
Omkar Mujumdar is currently offline Omkar Mujumdar
Messages: 22
Registered: October 2012
Junior Member
Please ignore the previous message. It was typed out of frustration of spending time on debugging environmental issues rather than core development. In this case the root cause was always in front of me on the console log "Missing required bundle org.junit_0.0.0" !!

Once I removed the dependency on junit it worked.

A related question is: what is the recommendation for organizing Junit tests cases against a scout project. For now I have moved mine out of the server project. But I am worried that it will force me to change many classes with public access modifiers.
Thanks in advance and sorry for the noise
Re: When I follow the Tutorials of "HelloWorld" I get these Error [message #986069 is a reply to message #986025] Sun, 18 November 2012 08:37 Go to previous messageGo to next message
Jeremie Bresson is currently offline Jeremie Bresson
Messages: 118
Registered: November 2010
Senior Member
Omkar Mujumdar wrote on Sat, 17 November 2012 17:23
A related question is: what is the recommendation for organizing Junit tests cases against a scout project. For now I have moved mine out of the server project. But I am worried that it will force me to change many classes with public access modifiers.
Thanks in advance and sorry for the noise


I have answered your related question in an other topic:Testing a scout application.
Re: When I follow the Tutorials of "HelloWorld" I get these Error [message #986851 is a reply to message #986069] Thu, 22 November 2012 02:07 Go to previous messageGo to next message
yuan yao is currently offline yuan yao
Messages: 4
Registered: October 2012
Junior Member
Thank you above!
Maybe I have found the problem. I just downloaded an new 'eclpse for scout developers' not install any plugins,for example the android plugin,windowbuilder plugin,google plugin,and the tutorials of "HelloWorld" it works !
Re: When I follow the Tutorials of "HelloWorld" I get these Error [message #1265194 is a reply to message #986851] Wed, 05 March 2014 20:08 Go to previous message
Wanderlan Santos dos Anjos is currently offline Wanderlan Santos dos Anjos
Messages: 1
Registered: March 2014
Junior Member
I had the same problem. I uninstalled some Eclipse plugins ("MongRel" and "Code Recommenders") and worked. It seems incompatibility among OSGi bundles.
Previous Topic:Object instances / serialization in Scout offline-applications
Next Topic:org.eclipse.scout.mockito-all ???
Goto Forum:
  


Current Time: Tue Oct 21 18:18:26 GMT 2014

Powered by FUDForum. Page generated in 0.02793 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software