Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Eclipse RCP Synchronyze getImageDescriptor
icon5.gif  Eclipse RCP Synchronyze getImageDescriptor [message #945683] Mon, 15 October 2012 14:33 Go to next message
Revton Braga is currently offline Revton BragaFriend
Messages: 6
Registered: May 2012
Junior Member

I have a problem to add the use the SVN(Subversion) in application Eclipse RCP.
When open the perspective Synchronize and have changed in project, don't show image, see attachment.

java.lang.NullPointerException
	at org.eclipse.team.internal.ui.synchronize.SynchronizeModelElement.getImageDescriptor(SynchronizeModelElement.java:127)
	at org.eclipse.team.internal.ui.synchronize.DiffNodeWorkbenchAdapter.getImageDescriptor(DiffNodeWorkbenchAdapter.java:34)
	at org.eclipse.ui.model.WorkbenchLabelProvider.getImage(WorkbenchLabelProvider.java:186)
	at org.eclipse.team.internal.ui.synchronize.SynchronizeModelElementLabelProvider.getImage(SynchronizeModelElementLabelProvider.java:95)


How to do get ImageDescriptor of my application?

Thanks,
Revton
Re: Eclipse RCP Synchronyze getImageDescriptor [message #956847 is a reply to message #945683] Wed, 24 October 2012 21:14 Go to previous message
Revton Braga is currently offline Revton BragaFriend
Messages: 6
Registered: May 2012
Junior Member

I find the solution, to set my adapterFactory in plugin.xml

<extension
       point="org.eclipse.core.runtime.adapters">
       <factory
            adaptableType="org.eclipse.core.resources.IFile"
            class="mypackage.AdapterFactory">
         <adapter
               type="org.eclipse.ui.model.IWorkbenchAdapter">
         </adapter>
      </factory>
      <factory
            adaptableType="org.eclipse.core.resources.IProject"
            class="mypackage.AdapterFactory">
         <adapter
               type="org.eclipse.ui.model.IWorkbenchAdapter">
         </adapter>
      </factory>
 </extension>
Previous Topic:Unconditionally opening an editor
Next Topic:Activity with specified local id does not work
Goto Forum:
  


Current Time: Mon Dec 22 06:30:35 GMT 2014

Powered by FUDForum. Page generated in 0.23784 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software