Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Target Management » ssh shell never shows commands
ssh shell never shows commands [message #11952] Thu, 21 June 2007 08:47 Go to next message
teknokrat is currently offline teknokrat
Messages: 73
Registered: July 2009
Member
I am using eclipse 3.3 with latest RSE. I have opened a SSH connection
to another server and logged in OK. However, whatever i type in the
command box, there is never any output shown. Nothing. If i export the
output to a text file, it is empty.
Re: ssh shell never shows commands [message #11978 is a reply to message #11952] Tue, 26 June 2007 15:16 Go to previous messageGo to next message
Martin Oberhuber is currently offline Martin Oberhuber
Messages: 982
Registered: July 2009
Senior Member
Did you try a simple command like "echo hello"?
Does the ssh file subsystem work properly?
How do you know you logged in OK if you do not see any output?
Are any errors or exceptions logged (Window > Show View > PDE Runtime >
Error Log)?

Thanks,
--
Martin Oberhuber
Target Management Project Lead, DSDP PMC Member
http://www.eclipse.org/dsdp/tm


teknokrat wrote:
> I am using eclipse 3.3 with latest RSE. I have opened a SSH connection
> to another server and logged in OK. However, whatever i type in the
> command box, there is never any output shown. Nothing. If i export the
> output to a text file, it is empty.
Re: ssh shell never shows commands [message #12092 is a reply to message #11978] Mon, 09 July 2007 14:53 Go to previous messageGo to next message
teknokrat is currently offline teknokrat
Messages: 73
Registered: July 2009
Member
Martin Oberhuber wrote:
> Did you try a simple command like "echo hello"?
> Does the ssh file subsystem work properly?
> How do you know you logged in OK if you do not see any output?
> Are any errors or exceptions logged (Window > Show View > PDE Runtime >
> Error Log)?
>


I tried lots of commands and there is no output. I can login into the
server using command line ssh easily. There are no errors on any logs.
When I start a shell I get a Last Login: message and thats it -
sometimes the view is disabled, i.e. I cannot type anything in the box.

Could this be a problem with cygwin? The ssh demon I am running is set
up by cygwin.

> Thanks,
> --
> Martin Oberhuber
> Target Management Project Lead, DSDP PMC Member
> http://www.eclipse.org/dsdp/tm
>
>
> teknokrat wrote:
>> I am using eclipse 3.3 with latest RSE. I have opened a SSH connection
>> to another server and logged in OK. However, whatever i type in the
>> command box, there is never any output shown. Nothing. If i export the
>> output to a text file, it is empty.
Re: ssh shell never shows commands [message #12131 is a reply to message #12092] Thu, 12 July 2007 09:45 Go to previous message
Martin Oberhuber is currently offline Martin Oberhuber
Messages: 982
Registered: July 2009
Senior Member
Hm,

I have seen this effect before but I thought it was fixed. At that time,
it was a problem with Refresh Events not being sent in RSE for the data
that was received.

I do not think that this issue is Cygwin related, it's more likely that
it's specific to timing on your machine. Are you running a Dualcore or
Hyperthreaded PC?

At any rate, please file a bug in bugzilla and give all the information
you have about your environment (host OS, JVM version, processor, RSE
version). You can also attach the output from Eclipse Help > About >
Show Configuration Details and Help > About > View Error Log, it should
have all the information we need.

Thanks,
--
Martin Oberhuber
Target Management Project Lead, DSDP PMC Member
http://www.eclipse.org/dsdp/tm


teknokrat wrote:
> Martin Oberhuber wrote:
>> Did you try a simple command like "echo hello"?
>> Does the ssh file subsystem work properly?
>> How do you know you logged in OK if you do not see any output?
>> Are any errors or exceptions logged (Window > Show View > PDE Runtime
>> > Error Log)?
>>
>
>
> I tried lots of commands and there is no output. I can login into the
> server using command line ssh easily. There are no errors on any logs.
> When I start a shell I get a Last Login: message and thats it -
> sometimes the view is disabled, i.e. I cannot type anything in the box.
>
> Could this be a problem with cygwin? The ssh demon I am running is set
> up by cygwin.
>
>> Thanks,
>> --
>> Martin Oberhuber
>> Target Management Project Lead, DSDP PMC Member
>> http://www.eclipse.org/dsdp/tm
>>
>>
>> teknokrat wrote:
>>> I am using eclipse 3.3 with latest RSE. I have opened a SSH
>>> connection to another server and logged in OK. However, whatever i
>>> type in the command box, there is never any output shown. Nothing. If
>>> i export the output to a text file, it is empty.
Re: ssh shell never shows commands [message #568492 is a reply to message #11952] Tue, 26 June 2007 15:16 Go to previous message
Martin Oberhuber is currently offline Martin Oberhuber
Messages: 982
Registered: July 2009
Senior Member
Did you try a simple command like "echo hello"?
Does the ssh file subsystem work properly?
How do you know you logged in OK if you do not see any output?
Are any errors or exceptions logged (Window > Show View > PDE Runtime >
Error Log)?

Thanks,
--
Martin Oberhuber
Target Management Project Lead, DSDP PMC Member
http://www.eclipse.org/dsdp/tm


teknokrat wrote:
> I am using eclipse 3.3 with latest RSE. I have opened a SSH connection
> to another server and logged in OK. However, whatever i type in the
> command box, there is never any output shown. Nothing. If i export the
> output to a text file, it is empty.
Re: ssh shell never shows commands [message #568700 is a reply to message #11978] Mon, 09 July 2007 14:53 Go to previous message
teknokrat is currently offline teknokrat
Messages: 73
Registered: July 2009
Member
Martin Oberhuber wrote:
> Did you try a simple command like "echo hello"?
> Does the ssh file subsystem work properly?
> How do you know you logged in OK if you do not see any output?
> Are any errors or exceptions logged (Window > Show View > PDE Runtime >
> Error Log)?
>


I tried lots of commands and there is no output. I can login into the
server using command line ssh easily. There are no errors on any logs.
When I start a shell I get a Last Login: message and thats it -
sometimes the view is disabled, i.e. I cannot type anything in the box.

Could this be a problem with cygwin? The ssh demon I am running is set
up by cygwin.

> Thanks,
> --
> Martin Oberhuber
> Target Management Project Lead, DSDP PMC Member
> http://www.eclipse.org/dsdp/tm
>
>
> teknokrat wrote:
>> I am using eclipse 3.3 with latest RSE. I have opened a SSH connection
>> to another server and logged in OK. However, whatever i type in the
>> command box, there is never any output shown. Nothing. If i export the
>> output to a text file, it is empty.
Re: ssh shell never shows commands [message #568777 is a reply to message #12092] Thu, 12 July 2007 09:45 Go to previous message
Martin Oberhuber is currently offline Martin Oberhuber
Messages: 982
Registered: July 2009
Senior Member
Hm,

I have seen this effect before but I thought it was fixed. At that time,
it was a problem with Refresh Events not being sent in RSE for the data
that was received.

I do not think that this issue is Cygwin related, it's more likely that
it's specific to timing on your machine. Are you running a Dualcore or
Hyperthreaded PC?

At any rate, please file a bug in bugzilla and give all the information
you have about your environment (host OS, JVM version, processor, RSE
version). You can also attach the output from Eclipse Help > About >
Show Configuration Details and Help > About > View Error Log, it should
have all the information we need.

Thanks,
--
Martin Oberhuber
Target Management Project Lead, DSDP PMC Member
http://www.eclipse.org/dsdp/tm


teknokrat wrote:
> Martin Oberhuber wrote:
>> Did you try a simple command like "echo hello"?
>> Does the ssh file subsystem work properly?
>> How do you know you logged in OK if you do not see any output?
>> Are any errors or exceptions logged (Window > Show View > PDE Runtime
>> > Error Log)?
>>
>
>
> I tried lots of commands and there is no output. I can login into the
> server using command line ssh easily. There are no errors on any logs.
> When I start a shell I get a Last Login: message and thats it -
> sometimes the view is disabled, i.e. I cannot type anything in the box.
>
> Could this be a problem with cygwin? The ssh demon I am running is set
> up by cygwin.
>
>> Thanks,
>> --
>> Martin Oberhuber
>> Target Management Project Lead, DSDP PMC Member
>> http://www.eclipse.org/dsdp/tm
>>
>>
>> teknokrat wrote:
>>> I am using eclipse 3.3 with latest RSE. I have opened a SSH
>>> connection to another server and logged in OK. However, whatever i
>>> type in the command box, there is never any output shown. Nothing. If
>>> i export the output to a text file, it is empty.
Previous Topic:RFE: Local terminal
Next Topic:Re: File Cache / Memory increase when opening FTP files
Goto Forum:
  


Current Time: Sat Jul 12 13:15:30 EDT 2014

Powered by FUDForum. Page generated in 0.02318 seconds