Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » TPTP and Ganymede M7
TPTP and Ganymede M7 [message #130467] Tue, 27 May 2008 15:30 Go to next message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

I'm trying to get TPTP installed and working on Ganymede M7 but having
no luck. Here are the features I have installed:
TPTP Platform 4.4.100
TPTP Monitoring Tools 4.4.2
TPTP Testing Tools 4.3.200
TPTP Tracing and Profiling 4.3.100

(all installed using p2 from http://download.eclipse.org/tptp/updates)

I have also tried with and without these installed:

TPTP JVMTI Profiler 4.3.100
TPTP Trace JVMTI Profiler 4.2.100


The symptom is that whenever I try to start a profile launch
configuration, it just never starts. Eventually (like 15 minutes later)
I'll get an error dialog saying JMVTI is not available (sorry, I'm
waiting now to the dialog so I can copy the exact text). I also see the
following in the Console view:
"Error occurred during initialization of VM
Could not find agent library on the library path or in the local
directory: JPIBootLoader"

I've tried running Eclipse on both Sun JDK 1.6 and 1.5.0_12.

Is this version of TPTP compatible with Ganymede? Any other advice?

TIA,
Eric
Re: TPTP and Ganymede M7 [message #130480 is a reply to message #130467] Wed, 28 May 2008 08:05 Go to previous messageGo to next message
Asaf Yaffe is currently offline Asaf YaffeFriend
Messages: 333
Registered: July 2009
Senior Member
Eric,

For Ganymede, please use TPTP 4.5, available for download from the TPTP
web site.

Regards,
Asaf

--
Asaf Yaffe
Eclipse TPTP Committer, JVMTI Profiler
Re: TPTP and Ganymede M7 [message #130530 is a reply to message #130480] Wed, 28 May 2008 13:38 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

Asaf Yaffe wrote:
> Eric,
>
> For Ganymede, please use TPTP 4.5, available for download from the TPTP
> web site.

OK, thanks.
Is there no update site for it?
Re: TPTP and Ganymede M7 [message #130543 is a reply to message #130480] Wed, 28 May 2008 18:57 Go to previous message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

Asaf Yaffe wrote:
> Eric,
>
> For Ganymede, please use TPTP 4.5, available for download from the TPTP
> web site.

Using Ganymede M7, I installed TPTP 4.5 (downloaded the "All TPTP
Features" zip, version 4.5 RC2). However, there are still problems.

I tried to launch a profile on a very simple test program; it will run,
but even when I select Memory Analysis as the monitor type, I can get no
memory data. When I try to open the Memory Analysis data, I get the view
with this message:
"No data is available for display.
Either you have no trace selected in the Profiling Monitor view or the
current selection does not contain the type of data this view can display."

It does seem to have Thread Analysis data, because that view is
populated (even though I selected Memory Analysis as the type for the
launch and the Profiling Monitor shows only a Memory Analysis node).

It's even worse for plugin projects. When I try to launch plugins from
my workspace, the workbench never even comes up - the launch just churns
away consuming most of my dual-core CPU and more and more heap space. I
eventually killed it after about 10 minutes of waiting when the host IDE
became unresponsive.

What gives? Where do I start trying to figure out what the hell is wrong?

TIA,
Eric
Previous Topic:JVMTI agen not available
Next Topic:old TPTP data collector with Java 1.4
Goto Forum:
  


Current Time: Mon Nov 24 03:14:23 GMT 2014

Powered by FUDForum. Page generated in 0.01647 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software