Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » AC on Linux (Ubuntu 8.04) symbol lookup error: ./../lib/libtptpUtils.so.4: undefined symbol: __ti3io
AC on Linux (Ubuntu 8.04) symbol lookup error: ./../lib/libtptpUtils.so.4: undefined symbol: __ti3io [message #130376] Thu, 22 May 2008 10:08 Go to next message
Eclipse User
Originally posted by: dennis.brains2b.org

Dear all,

I'm running into a problem trying to start either IAC or AC on a Linux machie.
Starting it manually gives me the following error : symbol lookup error: ./../lib/libtptpUtils.so.4: undefined symbol: __ti3ios.

Versions:
Ubuntu 8.04 (Hardy)
Eclipse 3.3 (Europe)
Java 1.5.0_12
AC agent version 4.4 and 4.5 both give the same problem.

Can someone think of possible causes of this problem and/or solutions?

Thanks.

Dennis..
Re: AC on Linux (Ubuntu 8.04) symbol lookup error: ./../lib/libtptpUtils.so.4: undefined symbol: __t [message #130402 is a reply to message #130376] Fri, 23 May 2008 03:01 Go to previous messageGo to next message
Richard Y.S. HUANG is currently offline Richard Y.S. HUANG
Messages: 18
Registered: July 2009
Junior Member
dennis wrote at Thu, 22 May 2008 14:08:15 +0000:

> Dear all,
>
> I'm running into a problem trying to start either IAC or AC on a Linux
> machie. Starting it manually gives me the following error : symbol
> lookup error: ./../lib/libtptpUtils.so.4: undefined symbol: __ti3ios.
>
> Versions:
> Ubuntu 8.04 (Hardy)
> Eclipse 3.3 (Europe)
> Java 1.5.0_12
> AC agent version 4.4 and 4.5 both give the same problem.
>
> Can someone think of possible causes of this problem and/or solutions?
>
> Thanks.
>
> Dennis..

Hi Dennis,

please follow the below steps:

1, installing the necessary library:
$ sudo apt-get install libstdc++2.10-glibc2.2

2, setting some environment variables: (assume AC is installed at /opt/
tptpdc)
$ export PATH=$PATH:/opt/tptpdc/bin
$ export TEMP=/tmp
$ export LD_LIBRARY_PATH=/opt/tptpdc/lib

OK, you can run SetConfig.sh, and then run ACStart.sh to start the Agent
Controller.

-Richard.
Re: AC on Linux (Ubuntu 8.04) symbol lookup error: [message #131549 is a reply to message #130402] Mon, 23 June 2008 08:56 Go to previous message
Eclipse User
Originally posted by: dennis.brains2b.org

>dennis wrote at Thu, 22 May 2008 14:08:15 +0000:
>> Dear all,
>>
>> I'm running into a problem trying to start either IAC or AC on a Linux
>> machie. Starting it manually gives me the following error : symbol
>> lookup error: ./../lib/libtptpUtils.so.4: undefined symbol: __ti3ios.
>>
>> Versions:
>> Ubuntu 8.04 (Hardy)
>> Eclipse 3.3 (Europe)
>> Java 1.5.0_12
>> AC agent version 4.4 and 4.5 both give the same problem.
>>
>> Can someone think of possible causes of this problem and/or solutions?
>>
>> Thanks.
>>
>> Dennis..
>Hi Dennis,
>please follow the below steps:
>1, installing the necessary library:
>$ sudo apt-get install libstdc++2.10-glibc2.2
>2, setting some environment variables: (assume AC is installed at /opt/
>tptpdc)
>$ export PATH=$PATH:/opt/tptpdc/bin
>$ export TEMP=/tmp
>$ export LD_LIBRARY_PATH=/opt/tptpdc/lib
>OK, you can run SetConfig.sh, and then run ACStart.sh to start the Agent
>Controller.
>-Richard.

Dear Richard,

Sorry for the late reply, but I was away from my systems. The problem is that Hardy (Ubuntu 8.04) does not include
libstdc++2.10-glibc2.2 and I cannot find another library that includes the __ti3ios symbol.

Regards,
Dennis
Previous Topic:Native dialogs: dead ends for GUI testing?
Next Topic:How to record Properties View values (Property <-> Value pair) ???
Goto Forum:
  


Current Time: Wed Aug 27 21:13:39 EDT 2014

Powered by FUDForum. Page generated in 0.01691 seconds