Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » Problem installing Xpand(I get a dependency error)
Problem installing Xpand [message #941607] Fri, 12 October 2012 13:54
jim collins is currently offline jim collins
Messages: 1
Registered: October 2012
Junior Member
When attempting to install Xpand in Eclipse I get the following error. Not being an Eclipse guru I have no idea how to resolve it. I'm not even sure which version of Xpand I should be installing.

Cannot complete the install because one or more required items could not be found.
Software being installed: Xpand SDK 1.2.2.v201209201023 (org.eclipse.xpand.sdk.feature.group 1.2.2.v201209201023)
Missing requirement: UML2 Common 1.7.0.v20121001-1122 (org.eclipse.uml2.common 1.7.0.v20121001-1122) requires 'bundle org.eclipse.emf.ecore [2.9.0,3.0.0)' but it could not be found
Cannot satisfy dependency:
From: UML2 UML Model 4.0.100.v20121001-1122 (org.eclipse.uml2.uml 4.0.100.v20121001-1122)
To: bundle org.eclipse.uml2.common [1.7.0,2.0.0)
Cannot satisfy dependency:
From: Xpand SDK 1.2.2.v201209201023 (org.eclipse.xpand.sdk.feature.group 1.2.2.v201209201023)
To: org.eclipse.xtend.typesystem.uml2.feature.group [1.2.2.v201209201023]
Cannot satisfy dependency:
From: Xtend UML2 typesystem 1.2.2.v201209201023 (org.eclipse.xtend.typesystem.uml2.feature.group 1.2.2.v201209201023)
To: org.eclipse.xtend.typesystem.uml2.ui [1.2.0.v201209201023]
Cannot satisfy dependency:
From: Xtend UML2 Typesystem UI 1.2.0.v201209201023 (org.eclipse.xtend.typesystem.uml2.ui 1.2.0.v201209201023)
To: bundle org.eclipse.uml2.uml 3.0.0
Previous Topic:xtend2 dynamic classloading?
Next Topic:Xtend - access the EnumLiterals - not possible
Goto Forum:
  


Current Time: Thu Apr 17 14:35:57 EDT 2014

Powered by FUDForum. Page generated in 0.01418 seconds