Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Migratiion problem
Migratiion problem [message #940375] Thu, 11 October 2012 15:21 Go to next message
Edmundo López Bóbeda is currently offline Edmundo López Bóbeda
Messages: 12
Registered: October 2012
Junior Member
Hello,

I'm trying to migrate a set of projects from xtext 1 to 2. When I run the MWE (not MWE2) workflow to generate my code I get an error telling me that:

The Antlr generator fragment couldn't be found on the classpath.


Normally it should ask me to download it but I don't even get that option. Everything just stops. I tried to get the plug in and it appears that I am importing all the libraries right libraries in the "Plug-in dependencies" list. I also tried to download the file myself, rename it and put it in the root of my project as explained in this post (http://www.eclipse.org/forums/index.php/m/896639/).

Is there a way I can set the classpath of MWE right for it to regenerate my code? Is there another solution?

Solved it [message #940387 is a reply to message #940375] Thu, 11 October 2012 15:36 Go to previous message
Edmundo López Bóbeda is currently offline Edmundo López Bóbeda
Messages: 12
Registered: October 2012
Junior Member
Hi,

I just found a solution, I needed to replace this line:

<fragment class="org.eclipse.xtext.generator.AntlrDelegatingFragment" />


with this one:

<fragment class="org.eclipse.xtext.generator.parser.antlr.XtextAntlrGeneratorFragment" />


and also this other:

			<fragment class="org.eclipse.xtext.generator.DelegatingGeneratorFragment" 
				delegate="de.itemis.xtext.antlr.XtextAntlrUiGeneratorFragment"
				message="You are generating without ANTLR. It is highly recommended to download and use the plugin 'de.itemis.xtext.antlr' \n\t using the update site <link suppressed>.">
			</fragment>


with

			<fragment class="org.eclipse.xtext.generator.DelegatingGeneratorFragment" 
				delegate="org.eclipse.xtext.generator.parser.antlr.XtextAntlrUiGeneratorFragment"
				message="You are generating without ANTLR. It is highly recommended to download and use the plugin 'de.itemis.xtext.antlr' \n\t using the update site <link suppressed>.">
			</fragment>
Previous Topic:Extracting DSL Metamodels
Next Topic:Conditional Statement Body
Goto Forum:
  


Current Time: Thu Oct 23 15:47:14 GMT 2014

Powered by FUDForum. Page generated in 0.01629 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software