Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » maven repo problem
maven repo problem [message #939535] Wed, 10 October 2012 21:19 Go to next message
Jim Garrison is currently offline Jim GarrisonFriend
Messages: 5
Registered: August 2012
Junior Member
I am having problems using the EclipseLink maven repo at:

download.eclipse.org/rt/eclipselink/maven.repo


I ran the troubleshooting POM from (munged):

www.eclipse.org/downloads/download.php?file=/rt/eclipselink/pom.xml


and got the following error:

[ERROR] Failed to execute goal on project eclipselinkMavenTest: Could not resolve dependencies for project org.eclipse.persistence:eclipselinkMavenTest:jar:1.0.0: Could not find artifact org.eclipse.persistence:org.eclipse.persistence.core:
jar:2.4.0 in all-repos (munged-local-artifactory-link) -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project eclipselinkMavenTest: Could not resolve dependencies for project org.eclipse.persistence:eclipselinkMavenTest:jar:1.0.0: Could not find artifact org.e
clipse.persistence:org.eclipse.persistence.core:jar:2.4.0 in all-repos (munged-local-artifactory-link)


The complete output from running
mvn -X -U install
is attached as a text file.
Re: maven repo problem [message #940447 is a reply to message #939535] Thu, 11 October 2012 16:40 Go to previous messageGo to next message
Jim Garrison is currently offline Jim GarrisonFriend
Messages: 5
Registered: August 2012
Junior Member
If anybody is successfully using EclipseLink with Maven, could you please post your <repository> definition?
Re: maven repo problem [message #940503 is a reply to message #940447] Thu, 11 October 2012 17:51 Go to previous messageGo to next message
Jim Garrison is currently offline Jim GarrisonFriend
Messages: 5
Registered: August 2012
Junior Member
More information

I configured Maven to skip the local mirror for http://download.eclipse.org/rt/eclipselink/maven.repo

In this case I get:

[DEBUG] Using connector WagonRepositoryConnector with priority 0 for http://download.eclipse.org/rt/eclipselink/maven.repo
Downloading: http://download.eclipse.org/rt/eclipselink/maven.repo/org/eclipse/persistence/org.eclipse.persistence.core/2.4.0/org.eclipse.persistence.core-2.4.0.jar
Oct 11, 2012 10:47:57 AM org.apache.maven.wagon.providers.http.httpclient.impl.client.DefaultRequestDirector tryExecute
INFO: I/O exception (org.apache.maven.wagon.providers.http.httpclient.NoHttpResponseException) caught when processing request: The target server failed to respond
Oct 11, 2012 10:47:57 AM org.apache.maven.wagon.providers.http.httpclient.impl.client.DefaultRequestDirector tryExecute
INFO: Retrying request
Oct 11, 2012 10:48:05 AM org.apache.maven.wagon.providers.http.httpclient.impl.client.DefaultRequestDirector tryExecute
INFO: I/O exception (org.apache.maven.wagon.providers.http.httpclient.NoHttpResponseException) caught when processing request: The target server failed to respond
Oct 11, 2012 10:48:05 AM org.apache.maven.wagon.providers.http.httpclient.impl.client.DefaultRequestDirector tryExecute
INFO: Retrying request
Oct 11, 2012 10:48:13 AM org.apache.maven.wagon.providers.http.httpclient.impl.client.DefaultRequestDirector tryExecute
INFO: I/O exception (org.apache.maven.wagon.providers.http.httpclient.NoHttpResponseException) caught when processing request: The target server failed to respond
Oct 11, 2012 10:48:26 AM org.apache.maven.wagon.providers.http.httpclient.impl.client.DefaultRequestDirector tryExecute
INFO: Retrying request


Trying with wget:

$ wget http://download.eclipse.org/rt/eclipselink/maven.repo
--2012-10-11 10:48:39--  http://download.eclipse.org/rt/eclipselink/maven.repo
Resolving download.eclipse.org (download.eclipse.org)... 206.191.52.47
Connecting to download.eclipse.org (download.eclipse.org)|206.191.52.47|:80... connected.
HTTP request sent, awaiting response... No data received.
Retrying.

--2012-10-11 10:48:48--  (try: 2)  http://download.eclipse.org/rt/eclipselink/maven.repo
Connecting to download.eclipse.org (download.eclipse.org)|206.191.52.47|:80... connected.
HTTP request sent, awaiting response... No data received.
Retrying.

--2012-10-11 10:48:58--  (try: 3)  http://download.eclipse.org/rt/eclipselink/maven.repo
Connecting to download.eclipse.org (download.eclipse.org)|206.191.52.47|:80... connected.
HTTP request sent, awaiting response... No data received.
Retrying.
...
etc.


Re: maven repo problem [message #940566 is a reply to message #940503] Thu, 11 October 2012 19:19 Go to previous message
Jim Garrison is currently offline Jim GarrisonFriend
Messages: 5
Registered: August 2012
Junior Member
Corporate firewall issues masquerading as external problem.

For future users, the culprit was Cisco AnyConnect WebSecurity, which proxies ALL outgoing connections and for unknown reasons blocks some selected URLs, including the eclipselink repo. Curiously it does not block other download.eclipse.org URLs, leading us to believe the problem was outside our firewall.
Previous Topic:scalar subqueries in select supported?
Next Topic:Moxy JPA+JAXB mapping issue with list unwrapping
Goto Forum:
  


Current Time: Mon Nov 24 16:41:44 GMT 2014

Powered by FUDForum. Page generated in 0.02490 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software