Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Reusable Thread Error in standard mode
Reusable Thread Error in standard mode [message #129479] Mon, 28 April 2008 17:57 Go to next message
Pushparaj is currently offline Pushparaj
Messages: 62
Registered: July 2009
Member
Hi All,

I can able to run my test cases in quick mode. but hangs in standard mode
with
the progress bar "Preparing and Deploying".


Exception in thread
"org.eclipse.hyades.execution.core.task.ReusableThread@1112e85"
java.lang.NullPointerException
at
org.eclipse.hyades.execution.local.util.AgentControllerDescr iptor.versionIsAtLeast(AgentControllerDescriptor.java:67)
at
org.eclipse.hyades.execution.local.util.AgentControllerDescr iptor.isVersionAtLeast(AgentControllerDescriptor.java:194)
at
org.eclipse.hyades.execution.local.file.FileManagerFactory$3 .run(FileManagerFactory.java:413)
at
org.eclipse.hyades.execution.core.task.ReusableThread.run(Re usableThread.java:131)
at java.lang.Thread.run(Thread.java:595)



Anybody know how to resolve this issue or why this is happening?.

Thanks for your help.

Pushparaj.
Re: Reusable Thread Error in standard mode [message #129647 is a reply to message #129479] Tue, 29 April 2008 06:30 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
What version of TPTP? What version of the Agent Controller?

PS
"Pushparaj" <pushparaj_94@yahoo.com> wrote in message
news:87f5baea2975a31e1b60302657bf9816$1@www.eclipse.org...
> Hi All,
>
> I can able to run my test cases in quick mode. but hangs in standard mode
> with
> the progress bar "Preparing and Deploying".
>
>
> Exception in thread
> "org.eclipse.hyades.execution.core.task.ReusableThread@1112e85"
> java.lang.NullPointerException
> at
> org.eclipse.hyades.execution.local.util.AgentControllerDescr iptor.versionIsAtLeast(AgentControllerDescriptor.java:67)
> at
> org.eclipse.hyades.execution.local.util.AgentControllerDescr iptor.isVersionAtLeast(AgentControllerDescriptor.java:194)
> at
> org.eclipse.hyades.execution.local.file.FileManagerFactory$3 .run(FileManagerFactory.java:413)
> at
> org.eclipse.hyades.execution.core.task.ReusableThread.run(Re usableThread.java:131)
> at java.lang.Thread.run(Thread.java:595)
>
>
>
> Anybody know how to resolve this issue or why this is happening?.
>
> Thanks for your help.
>
> Pushparaj.
>
>
>
Re: Reusable Thread Error in standard mode [message #129670 is a reply to message #129647] Tue, 29 April 2008 13:01 Go to previous messageGo to next message
Pushparaj is currently offline Pushparaj
Messages: 62
Registered: July 2009
Member
Hi Paul,
I am using

tptp.runtime.allInOne.linux.gtk.x86-TPTP-4.4.1.zip

and

agntctrl.linux_ia32-TPTP-4.4.1.zip

Thanks,
Pushparaj.
Re: Reusable Thread Error in standard mode [message #129675 is a reply to message #129670] Tue, 29 April 2008 17:12 Go to previous messageGo to next message
Pushparaj is currently offline Pushparaj
Messages: 62
Registered: July 2009
Member
why Hi Paul,

After restarting Agent Controller(RAStart.h), I am not getting the
ResuableThread error.
But this time only workbench is launched with Java perspective. After few
seconds workbench is also closed without executing single macro from my
testcases. but execution history file is generated under the plug-in.

What needs to be done to execute all my test cases in standard mode?

Thanks,
Pushparaj.
Re: Reusable Thread Error in standard mode [message #129862 is a reply to message #129675] Thu, 08 May 2008 06:14 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Did you add any test invocations to the behaviour of your test suite?

PS
"Pushparaj" <pushparaj_94@yahoo.com> wrote in message
news:45157424ca57962df014ea713d9152e0$1@www.eclipse.org...
> why Hi Paul,
>
> After restarting Agent Controller(RAStart.h), I am not getting the
> ResuableThread error. But this time only workbench is launched with Java
> perspective. After few seconds workbench is also closed without executing
> single macro from my testcases. but execution history file is generated
> under the plug-in.
>
> What needs to be done to execute all my test cases in standard mode?
>
> Thanks,
> Pushparaj.
>
Re: Reusable Thread Error in standard mode [message #130323 is a reply to message #129862] Tue, 20 May 2008 08:29 Go to previous messageGo to next message
Pushparaj is currently offline Pushparaj
Messages: 62
Registered: July 2009
Member
No i didn't add any test invocations in my test suite.

Thanks,
Pushparaj
Re: Reusable Thread Error in standard mode [message #130853 is a reply to message #130323] Tue, 03 June 2008 12:56 Go to previous message
DuWayne Morris is currently offline DuWayne Morris
Messages: 36
Registered: July 2009
Member
In standard mode, the test invocations that you wish to execute must be
specified. So, the behavior you observed is correct. With no invocations
the test will run and execution history will be empty.
Previous Topic:Multiple instances for Verification Class
Next Topic:missing tracing tab
Goto Forum:
  


Current Time: Fri Aug 22 16:00:56 EDT 2014

Powered by FUDForum. Page generated in 0.01999 seconds