Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Help for start
Help for start [message #11792] Mon, 28 March 2005 08:25 Go to next message
Eclipse User
Originally posted by: stone_wei.bj1860.net

Hi,all

Yesterday I download the 3.2A of tptp, and follow the
(Eclipsecon_2005_tutorial_22_antony_miguel_paul_slauenwhite. pdf) to start my
first journey of tptp. But when I set up my profile I meet some problem. the
host setting is localhost:10002 and the test connection is passed. but I can
not find any agent on the (agents) tab, the red tip is IWAT0225E you must
select at least one agent to attach to.

the eclipse version is 3.02, java version is 1.4.2_06

what should i do?

thanks

wei lei

2005-3-28
Re: Help for start [message #11829 is a reply to message #11792] Mon, 28 March 2005 12:13 Go to previous messageGo to next message
Eclipse User
Originally posted by: akuhn.arcor.de

Hi wei lei,

did you want to profile the application ?
You have to start your application with the profiling agent:
java -XrunpiAgent MyMainApplicationClass

After that the profiling agent will be listed in the left tab of the
agents tab in the attach process wizard.

Regards,
Andi

stone wrote:
> Hi,all
>
> Yesterday I download the 3.2A of tptp, and follow the
> (Eclipsecon_2005_tutorial_22_antony_miguel_paul_slauenwhite. pdf) to start my
> first journey of tptp. But when I set up my profile I meet some problem. the
> host setting is localhost:10002 and the test connection is passed. but I can
> not find any agent on the (agents) tab, the red tip is IWAT0225E you must
> select at least one agent to attach to.
>
> the eclipse version is 3.02, java version is 1.4.2_06
>
> what should i do?
>
> thanks
>
> wei lei
>
> 2005-3-28
>
>
Re: Help for start [message #12741 is a reply to message #11792] Thu, 31 March 2005 07:37 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Wei Lei,
When attaching to a Logging Agent (as cited in the tutorial), please
ensure logging is enabled in the Profiling and Logging preferences (Window
>> Preferences >> Profiling and Logging >> Enable Logging). Furthermore,
ensure the <Agent Controller installation directory>/bin directory is on the
system's path, as indicated in the Agent Controller's installation
instructions. Adding the directory to the system's path in a command window
(e.g. Windows) is not sufficient. If these suggestions do not help, please
provide more detail on your scenario.

Paul

"stone" <stone_wei@bj1860.net> wrote in message
news:d295fp$tb6$1@news.eclipse.org...
> Hi,all
>
> Yesterday I download the 3.2A of tptp, and follow the
> (Eclipsecon_2005_tutorial_22_antony_miguel_paul_slauenwhite. pdf) to start
my
> first journey of tptp. But when I set up my profile I meet some problem.
the
> host setting is localhost:10002 and the test connection is passed. but I
can
> not find any agent on the (agents) tab, the red tip is IWAT0225E you must
> select at least one agent to attach to.
>
> the eclipse version is 3.02, java version is 1.4.2_06
>
> what should i do?
>
> thanks
>
> wei lei
>
> 2005-3-28
>
>
Re: Help for start [message #14868 is a reply to message #11829] Mon, 11 April 2005 17:22 Go to previous message
Yu Chen is currently offline Yu Chen
Messages: 28
Registered: July 2009
Junior Member
1) First, I still don't see a list of agents in the
Window/Preferences/Attach to Java process/Agents tab, error says, "...
Fetching children of host" which is localhost:10002.

What does "Attach to Java Process" do? Do I have to do this for profiliing
an Java app?

2) It's interesting that if I do Run/Profile, than as Java Application, it
does not have any profiling data shown, but if I detached from agent,
reattch to agent, then start monitoring, the data is then available in a tab
view...



Any ideas?

Newbie.

"Andreas Kuhn" <akuhn@arcor.de> wrote in message
news:d29irl$fmo$1@news.eclipse.org...
> Hi wei lei,
>
> did you want to profile the application ?
> You have to start your application with the profiling agent:
> java -XrunpiAgent MyMainApplicationClass
>
> After that the profiling agent will be listed in the left tab of the
> agents tab in the attach process wizard.
>
> Regards,
> Andi
>
> stone wrote:
>> Hi,all
>>
>> Yesterday I download the 3.2A of tptp, and follow the
>> (Eclipsecon_2005_tutorial_22_antony_miguel_paul_slauenwhite. pdf) to start
>> my first journey of tptp. But when I set up my profile I meet some
>> problem. the host setting is localhost:10002 and the test connection is
>> passed. but I can not find any agent on the (agents) tab, the red tip is
>> IWAT0225E you must select at least one agent to attach to.
>>
>> the eclipse version is 3.02, java version is 1.4.2_06
>>
>> what should i do?
>>
>> thanks
>>
>> wei lei
>>
>> 2005-3-28
Previous Topic:ExecutionEnvironmentAdapter, ExecutableObjectAdapter and LaunchConfiguration
Next Topic:AOP and tptp
Goto Forum:
  


Current Time: Thu Apr 24 11:27:33 EDT 2014

Powered by FUDForum. Page generated in 0.02578 seconds