Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » trouble profiling with TPTP
trouble profiling with TPTP [message #128472] Mon, 14 April 2008 20:45 Go to next message
Eclipse User
Originally posted by: afraser.broad.mit.edu

Hi, I hope I'm sending this to the correct place, and somebody can help me.

I need to do some memory profiling in Eclipse so I've tried to get the
TPTP plugin working without any luck so far. It's worth noting that
I've never used a profiling tool. Here's what I've installed...

-I'm using Eclipse SDK version 3.3.2.
-I downloaded the TPTP all in one package
javaprofiler.win_ia32-TPTP-4.2.0.zip, and extracted it over my eclipse
distribution.
-I downloaded and installed the new agent controller
(agntctrl.win_ia32-TPTP-4.2.0.zip), and confirmed that this was working.
-I downloaded and installed the JVMTI client (jvmti-client-TPTP-4.2.0.zip).
-I also installed JBoss 4.2.2, although I only found one place that said
that I actually need this.

Here's what I've done...
-run RAServer
-run eclipse
-profile as -> (created a new configuration under "Java Application")
-under "Monitor tab" I chose memory analysis under "Java Profiling - JRE
1.5 or newer"
-clicked the Profile button
-enter the profiling perspective

I get a tree in the "Profiling Monitor" with
+jCPAnalyst.JCPA at XYZ [PID: 3080]
++<monitoring> Profiling
+++Memory Analysis

BUT, my application doesn't actually run. I am able to open other views
(eg: obj allocations, mem. stats, etc), but all are empty. I was
previously having trouble starting the JVMTI, but in such cases a view
would popup with "progress" and it would never get beyond 51%. I've
tried changing the filters in the profile, with no change in the end
result. When I chose "Agent Discoverer" however, the app. did run, but
I get no feedback in the views.

After having done all this, I extracted tptp.runtime-TPTP-4.4.1.zip to
my eclipse directory and tried again, but it occurred to me that the
agent controller was still configured to use 4.2.

Could someone please help me get on my feet with this? Is there
anything that stands out that I may have missed?

thanks so much,
-Adam
Re: trouble profiling with TPTP [message #128711 is a reply to message #128472] Mon, 21 April 2008 07:49 Go to previous message
Asaf Yaffe is currently offline Asaf Yaffe
Messages: 333
Registered: July 2009
Senior Member
I suggest you install a fresh copy of Eclipse 3.3.2. Then download the
TPTP 4.4.1 "all in one" package from the TPTP web site and install it.

Then, uninstall your existing Agent Controller version, and then install
and configure the 4.4.1 Agent Controller.

HTH,
Asaf

--
Asaf Yaffe
Eclipse TPTP Committer, JVMTI Profiler
Previous Topic:Problems getting TPTP to work
Next Topic:Profiling workaround
Goto Forum:
  


Current Time: Sat Oct 25 07:22:58 GMT 2014

Powered by FUDForum. Page generated in 0.01606 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software